summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/tifs-lpm-stub
diff options
context:
space:
mode:
authorRyan Eatmon <reatmon@ti.com>2022-05-09 17:59:40 +0000
committerRyan Eatmon <reatmon@ti.com>2022-05-10 09:56:19 -0500
commit2c1ae06f18cfc362de984bee817953a3ac053c8a (patch)
tree36073d1f3791c40c806d39c40aaf42dd27df14ad /meta-ti-bsp/recipes-bsp/tifs-lpm-stub
parent038882c616ce02707387d12f8b691ef93bbe305b (diff)
downloadmeta-ti-2c1ae06f18cfc362de984bee817953a3ac053c8a.tar.gz
recipes-bsp: tifs-lpm-stub: Introduce new recipe
This firmware stub is required by the TI foundational security software while transitioning to low power mode. Add a recipe for this compatible with am62xx-evm Signed-off-by: Nikhil Devshatwar <nikhil.nd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com> Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/tifs-lpm-stub')
-rw-r--r--meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb b/meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb
new file mode 100644
index 00000000..90af55f1
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb
@@ -0,0 +1,23 @@
1SUMMARY = "TI Foundational security Low Power Management Stub"
2
3require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
4
5PV = "${TIFS_LPM_STUB_FW_VERSION}"
6PR = "${INC_PR}.0"
7
8CLEANBROKEN = "1"
9
10COMPATIBLE_MACHINE = "am62xx-evm"
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14S = "${WORKDIR}/git"
15
16TARGET = "ti-fs-stub-firmware-am62x-gp-signed.bin"
17
18do_install() {
19 install -d ${D}${nonarch_base_libdir}/firmware/ti-sysfw/
20 install -m 0644 ${S}/ti-sysfw/${TARGET} ${D}${nonarch_base_libdir}/firmware/ti-sysfw/${TARGET}
21}
22
23FILES:${PN} = "${nonarch_base_libdir}/firmware"