summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/ti-sci-fw
diff options
context:
space:
mode:
authorAniket Limaye <a-limaye@ti.com>2023-10-12 22:59:46 +0530
committerRyan Eatmon <reatmon@ti.com>2023-10-12 13:13:28 -0500
commita105374b4c2220b0e9008443f7924943f4d5fc1d (patch)
tree86ff35f4f5447d65fd3565c71a177d0177368f5e /meta-ti-bsp/recipes-bsp/ti-sci-fw
parent276d95c553581b006f7a4628a4631c7b79eebad6 (diff)
downloadmeta-ti-a105374b4c2220b0e9008443f7924943f4d5fc1d.tar.gz
ti-sci-fw: Remove COMPATIBLE_MACHINE and extend recipe to k3 machines
Revert ebcf15bf0f31208e87ce60a4696e585940b46777 : "recipes-bsp:ti-sci-fw: Add k3r5 as COMPATIBLE_MACHINE" Extend recipe to k3 machines too, to provide ti-fs-stub-* firmware for u-boot aarch64 build. Update do_deploy() to allow multiconfig builds for k3 machines Signed-off-by: Aniket Limaye <a-limaye@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/ti-sci-fw')
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index 801c8768..2ad93a5d 100644
--- a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -4,7 +4,6 @@ inherit deploy
4 4
5require recipes-bsp/ti-linux-fw/ti-linux-fw.inc 5require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
6 6
7COMPATIBLE_MACHINE = "k3r5"
8PACKAGE_ARCH = "${MACHINE_ARCH}" 7PACKAGE_ARCH = "${MACHINE_ARCH}"
9 8
10CFLAGS[unexport] = "1" 9CFLAGS[unexport] = "1"
@@ -26,7 +25,10 @@ do_install() {
26 25
27FILES:${PN} = "${nonarch_base_libdir}/firmware" 26FILES:${PN} = "${nonarch_base_libdir}/firmware"
28 27
29do_deploy() { 28do_deploy(){
29}
30
31do_deploy:k3r5() {
30 install -d ${DEPLOYDIR}/ti-sysfw 32 install -d ${DEPLOYDIR}/ti-sysfw
31 install -m 644 ${S}/ti-sysfw/ti-sci-firmware-* ${DEPLOYDIR}/ti-sysfw 33 install -m 644 ${S}/ti-sysfw/ti-sci-firmware-* ${DEPLOYDIR}/ti-sysfw
32 install -m 644 ${S}/ti-sysfw/ti-fs-firmware-* ${DEPLOYDIR}/ti-sysfw 34 install -m 644 ${S}/ti-sysfw/ti-fs-firmware-* ${DEPLOYDIR}/ti-sysfw