diff options
author | Nishanth Menon <nm@ti.com> | 2022-05-02 14:51:05 +0000 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2022-05-02 11:31:08 -0500 |
commit | 15ae8b802a05cebb6a272047816d82f345703704 (patch) | |
tree | fef0a562db0b00076ce3a8c840186b5f7e4fc0a4 /meta-ti-bsp/recipes-bsp/ti-sci-fw | |
parent | 0b9083e6a51d3c13fda500804c8478eeab5b7455 (diff) | |
download | meta-ti-15ae8b802a05cebb6a272047816d82f345703704.tar.gz |
machine: Add am62xx evm configuration
Lets add the basic AM62xx-evm configuration.
- Add configurations.
- Add firmware overrides.
- Add u-boot overrides.
- Update TI_LINUX_FW_SRCREV and K3_IMAGE_GEN_SRCREV to appropriate SHAs.
Signed-off-by: Nishanth Menon <nm@ti.com>
Signed-off-by: Hari Nagalla <hnagalla@ti.com>
Signed-off-by: Praneeth Bajjuri <praneeth@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/ti-sci-fw')
-rw-r--r-- | meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | 18 |
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb index 33333e3c..530b25b8 100644 --- a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb +++ b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | |||
@@ -6,6 +6,7 @@ DEPENDS:append:j7200-hs-evm-k3r5 = " virtual/bootloader" | |||
6 | DEPENDS:append:j721s2-evm-k3r5 = " virtual/bootloader" | 6 | DEPENDS:append:j721s2-evm-k3r5 = " virtual/bootloader" |
7 | DEPENDS:append:am64xx-evm-k3r5 = " virtual/bootloader" | 7 | DEPENDS:append:am64xx-evm-k3r5 = " virtual/bootloader" |
8 | DEPENDS:append:am64xx-hs-evm-k3r5 = " virtual/bootloader" | 8 | DEPENDS:append:am64xx-hs-evm-k3r5 = " virtual/bootloader" |
9 | DEPENDS:append:am62xx-evm-k3r5 = " virtual/bootloader" | ||
9 | 10 | ||
10 | CLEANBROKEN = "1" | 11 | CLEANBROKEN = "1" |
11 | PR = "${INC_PR}.2" | 12 | PR = "${INC_PR}.2" |
@@ -29,6 +30,7 @@ SYSFW_PREFIX:j721e-hs-evm-k3r5-sr1-1 = "ti-fs-firmware" | |||
29 | SYSFW_PREFIX:j7200-evm-k3r5 = "ti-fs-firmware" | 30 | SYSFW_PREFIX:j7200-evm-k3r5 = "ti-fs-firmware" |
30 | SYSFW_PREFIX:j7200-hs-evm-k3r5 = "ti-fs-firmware" | 31 | SYSFW_PREFIX:j7200-hs-evm-k3r5 = "ti-fs-firmware" |
31 | SYSFW_PREFIX:j721s2-evm-k3r5 = "ti-fs-firmware" | 32 | SYSFW_PREFIX:j721s2-evm-k3r5 = "ti-fs-firmware" |
33 | SYSFW_PREFIX:am62xx-evm-k3r5 = "ti-fs-firmware" | ||
32 | 34 | ||
33 | SYSFW_SUFFIX ?= "unknown" | 35 | SYSFW_SUFFIX ?= "unknown" |
34 | 36 | ||
@@ -63,6 +65,7 @@ EXTRA_OEMAKE:append:j7200-hs-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-s | |||
63 | EXTRA_OEMAKE:append:j721s2-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" | 65 | EXTRA_OEMAKE:append:j721s2-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" |
64 | EXTRA_OEMAKE:append:am64xx-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" | 66 | EXTRA_OEMAKE:append:am64xx-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" |
65 | EXTRA_OEMAKE:append:am64xx-hs-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" | 67 | EXTRA_OEMAKE:append:am64xx-hs-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" |
68 | EXTRA_OEMAKE:append:am62xx-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" | ||
66 | 69 | ||
67 | do_compile() { | 70 | do_compile() { |
68 | cd ${WORKDIR}/imggen/ | 71 | cd ${WORKDIR}/imggen/ |
@@ -170,4 +173,19 @@ do_deploy:am64xx-hs-evm-k3r5() { | |||
170 | install -m 644 ${SYSFW_TISCI} ${DEPLOYDIR}/ | 173 | install -m 644 ${SYSFW_TISCI} ${DEPLOYDIR}/ |
171 | } | 174 | } |
172 | 175 | ||
176 | do_install:am62xx-evm-k3r5() { | ||
177 | install -d ${D}/boot | ||
178 | install -m 644 ${WORKDIR}/imggen/${UBOOT_BINARY} ${D}/boot/${UBOOT_IMAGE} | ||
179 | ln -sf ${UBOOT_IMAGE} ${D}/boot/${UBOOT_SYMLINK} | ||
180 | ln -sf ${UBOOT_IMAGE} ${D}/boot/${UBOOT_BINARY} | ||
181 | } | ||
182 | |||
183 | do_deploy:am62xx-evm-k3r5() { | ||
184 | install -d ${DEPLOYDIR} | ||
185 | install -m 644 ${WORKDIR}/imggen/${UBOOT_BINARY} ${DEPLOYDIR}/${UBOOT_IMAGE} | ||
186 | ln -sf ${UBOOT_IMAGE} ${DEPLOYDIR}/${UBOOT_SYMLINK} | ||
187 | ln -sf ${UBOOT_IMAGE} ${DEPLOYDIR}/${UBOOT_BINARY} | ||
188 | install -m 644 ${SYSFW_TISCI} ${DEPLOYDIR}/ | ||
189 | } | ||
190 | |||
173 | addtask deploy before do_build after do_compile | 191 | addtask deploy before do_build after do_compile |