summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/ti-img-encode-decode
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-02-22 04:13:45 +0000
committerRyan Eatmon <reatmon@ti.com>2022-02-22 12:01:38 -0600
commit20f3191aeb592dd889eeaf96a31526297de95306 (patch)
treeaec879b9855ff8a54df171ee808e30ac26f1c80b /meta-ti-bsp/recipes-bsp/ti-img-encode-decode
parentbea4fd2c401af05b866bd6af1c4e501d31b7b420 (diff)
downloadmeta-ti-20f3191aeb592dd889eeaf96a31526297de95306.tar.gz
meta-ti: create a sub-layer meta-ti-bsp from existing content
Extra sub-layers will be created next and relevant content moved across them. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/ti-img-encode-decode')
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-img-encode-decode/viddec-test-app_1.0.0.bb20
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-img-encode-decode/videnc-test-app_1.0.0.bb20
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb24
3 files changed, 64 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/viddec-test-app_1.0.0.bb b/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/viddec-test-app_1.0.0.bb
new file mode 100644
index 00000000..9fb473b7
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/viddec-test-app_1.0.0.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Test applications for TI DEC (v4l2 decoder for IMG D5520)"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://main.c;beginline=1;endline=14;md5=f17e17d664f72942124e4fcf06c178ee"
4
5DEPENDS = "libdrm ffmpeg"
6
7inherit autotools pkgconfig
8
9COMPATIBLE_MACHINE = "j7"
10
11PR = "r1"
12SRCREV = "94a80c8c090dbfdc7fafd4e5bb78c2091e715af2"
13
14EXTRA_OEMAKE = "CC="${CC}""
15TARGET_CC_ARCH += "${LDFLAGS}"
16
17BRANCH = "master"
18SRC_URI = "git://git.ti.com/jacinto7_multimedia/viddec-test-app.git;protocol=git;branch=${BRANCH}"
19
20S = "${WORKDIR}/git"
diff --git a/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/videnc-test-app_1.0.0.bb b/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/videnc-test-app_1.0.0.bb
new file mode 100644
index 00000000..3a128b92
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/videnc-test-app_1.0.0.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Test applications for TI ENC (v4l2 encoder for IMG VXE384)"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://main.c;beginline=1;endline=14;md5=3545dd5bdf513840937d38c10b866605"
4
5DEPENDS = "libdrm"
6
7inherit autotools pkgconfig
8
9COMPATIBLE_MACHINE = "j7"
10
11PR = "r0"
12SRCREV = "a5e7d820bea1be24f25a8369d4d4521c784f869a"
13
14EXTRA_OEMAKE = "CC="${CC}""
15TARGET_CC_ARCH += "${LDFLAGS}"
16
17BRANCH = "master"
18SRC_URI = "git://git.ti.com/jacinto7_multimedia/videnc-test-app.git;protocol=git;branch=${BRANCH}"
19
20S = "${WORKDIR}/git"
diff --git a/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb b/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
new file mode 100644
index 00000000..3563cc7e
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Video Decoding Firmware"
2LICENSE = "TI-IMG"
3LIC_FILES_CHKSUM = "file://LICENSE.ti-img;md5=84ca7278930db001870686ad997d6bb1"
4
5require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
6
7PV = "${IMG_DEC_FW_VERSION}"
8PR = "${INC_PR}.0"
9
10CLEANBROKEN = "1"
11
12COMPATIBLE_MACHINE = "j7"
13
14PACKAGE_ARCH = "${MACHINE_ARCH}"
15
16S = "${WORKDIR}/git"
17TARGET = "pvdec_full_bin.fw"
18
19do_install() {
20 install -d ${D}${base_libdir}/firmware
21 install -m 0644 ${S}/ti-img/${TARGET} ${D}${base_libdir}/firmware/${TARGET}
22}
23
24FILES:${PN} = "${base_libdir}/firmware"