summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-02-22 04:14:01 +0000
committerRyan Eatmon <reatmon@ti.com>2022-02-22 12:01:39 -0600
commitfa8035fc263960e06742945da00cb4777e4b24f7 (patch)
tree592e8178d7b5f719480172a83eaa80c34cf0fbd9 /meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb
parentd39f85d1d079e14b89768b7a9d3adb059013e07b (diff)
downloadmeta-ti-fa8035fc263960e06742945da00cb4777e4b24f7.tar.gz
meta-ti: use nonarch_base_libdir for firmware installations
Firmware images should always be installed under /lib and hence should use nonarch_base_libdir, as regular base_libdir is configuration-specific and doesn't always resolve to /lib. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb')
-rw-r--r--meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb
index 4ca06be0..9ccce938 100644
--- a/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb
+++ b/meta-ti-bsp/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb
@@ -19,13 +19,13 @@ TARGET:am57xx-evm = "am57xx-pru0-prueth-fw.elf am57xx-pru1-prueth-fw.elf"
19TARGET:am57xx-hs-evm = "am57xx-pru0-prueth-fw.elf am57xx-pru1-prueth-fw.elf" 19TARGET:am57xx-hs-evm = "am57xx-pru0-prueth-fw.elf am57xx-pru1-prueth-fw.elf"
20 20
21do_install() { 21do_install() {
22 install -d ${D}${base_libdir}/firmware/ti-pruss 22 install -d ${D}${nonarch_base_libdir}/firmware/ti-pruss
23 for f in ${TARGET}; do 23 for f in ${TARGET}; do
24 install -m 0644 ${S}/ti-pruss/$f ${D}${base_libdir}/firmware/ti-pruss/$f 24 install -m 0644 ${S}/ti-pruss/$f ${D}${nonarch_base_libdir}/firmware/ti-pruss/$f
25 done 25 done
26} 26}
27 27
28 28
29FILES:${PN} = "${base_libdir}/firmware" 29FILES:${PN} = "${nonarch_base_libdir}/firmware"
30 30
31INSANE_SKIP:${PN} = "arch" 31INSANE_SKIP:${PN} = "arch"