summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/powervr-drivers
diff options
context:
space:
mode:
authorRandolph Sapp <rs@ti.com>2024-05-02 14:18:41 -0500
committerRyan Eatmon <reatmon@ti.com>2024-05-02 15:01:10 -0500
commit817a950947bf8ed2ce97036f121592e5b906bedf (patch)
tree8f3edda1c485c66c4ee5f1fe9a0430e94f9717e7 /meta-ti-bsp/recipes-bsp/powervr-drivers
parentc293c5188195f7f16bfe93e27fd2c27f12c60ade (diff)
downloadmeta-ti-817a950947bf8ed2ce97036f121592e5b906bedf.tar.gz
ti-img-rogue-*: add ddk 24.1 recipes for ltsprep
Recipes for DDK 24.1, but lock them behind ltsprep tags because they require device tree changes that do not work on the current default kernel for this layer. Signed-off-by: Randolph Sapp <rs@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/powervr-drivers')
-rw-r--r--meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_24.1.6554834.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_24.1.6554834.bb b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_24.1.6554834.bb
new file mode 100644
index 00000000..a1b76d27
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_24.1.6554834.bb
@@ -0,0 +1,44 @@
1DESCRIPTION = "Kernel drivers for the PowerVR Rogue GPU found in the TI SoCs"
2HOMEPAGE = "http://git.ti.com/graphics/ti-img-rogue-driver"
3LICENSE = "MIT | GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://README;beginline=14;endline=19;md5=0403c7dea01a2b8232261e805325fac2"
5
6DEFAULT_PREFERENCE = "-1"
7
8inherit module
9
10PROVIDES = "virtual/gpudriver"
11
12MACHINE_KERNEL_PR:append = "b"
13PR = "${MACHINE_KERNEL_PR}"
14
15PACKAGE_ARCH = "${MACHINE_ARCH}"
16
17COMPATIBLE_MACHINE = "j721e|j721s2|j784s4|am62xx|am62pxx|j722s"
18
19DEPENDS = "virtual/kernel"
20
21BRANCH = "linuxws/scarthgap/k6.6/${PV}"
22
23SRC_URI = "git://git.ti.com/git/graphics/ti-img-rogue-driver.git;protocol=https;branch=${BRANCH}"
24
25S = "${WORKDIR}/git"
26
27SRCREV = "e2dfdfee991dadc18175f27fe9e8676e910a2f8d"
28
29TARGET_PRODUCT:j721e = "j721e_linux"
30TARGET_PRODUCT:j721s2 = "j721s2_linux"
31TARGET_PRODUCT:j784s4 = "j784s4_linux"
32TARGET_PRODUCT:am62xx = "am62_linux"
33TARGET_PRODUCT:am62pxx = "am62p_linux"
34TARGET_PRODUCT:j722s = "j722s_linux"
35PVR_BUILD = "release"
36PVR_WS = "lws-generic"
37
38EXTRA_OEMAKE += 'KERNELDIR="${STAGING_KERNEL_DIR}" BUILD=${PVR_BUILD} PVR_BUILD_DIR=${TARGET_PRODUCT} WINDOW_SYSTEM=${PVR_WS}'
39
40do_install() {
41 make -C ${STAGING_KERNEL_DIR} M=${B}/binary_${TARGET_PRODUCT}_${PVR_WS}_${PVR_BUILD}/target_aarch64/kbuild INSTALL_MOD_PATH=${D}${root_prefix} PREFIX=${STAGING_DIR_HOST} modules_install
42}
43
44RRECOMMENDS:${PN} += "ti-img-rogue-umlibs"