summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb
diff options
context:
space:
mode:
authorRandolph Sapp <rs@ti.com>2023-10-27 17:21:58 -0500
committerRyan Eatmon <reatmon@ti.com>2023-10-30 16:53:44 -0500
commit48000c11148e7a22931e9e2e4b6a03964874667c (patch)
treecc76863826a4a1def78e3679d6f195cf10988dd1 /meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb
parenta6e170fd78515569e6ed2587a813f9134c24742c (diff)
downloadmeta-ti-48000c11148e7a22931e9e2e4b6a03964874667c.tar.gz
ti-img-rogue-*: move to 23.2 release
Move to the 23.2 release branch and bump SRCREV accordingly. This branch has the proper implementation of the cache coherency fix along with some other checks that address some system stability issues on Jacinto devices. Signed-off-by: Randolph Sapp <rs@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb')
-rw-r--r--meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb
new file mode 100644
index 00000000..d46699ca
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-img-rogue-driver_23.2.6460340.bb
@@ -0,0 +1,40 @@
1DESCRIPTION = "Kernel drivers for the PowerVR Rogue GPU found in the TI SoCs"
2HOMEPAGE = "http://git.ti.com/graphics/ti-img-rogue-driver"
3LICENSE = "MIT | GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://README;beginline=14;endline=19;md5=0403c7dea01a2b8232261e805325fac2"
5
6inherit module
7
8PROVIDES = "virtual/gpudriver"
9
10MACHINE_KERNEL_PR:append = "b"
11PR = "${MACHINE_KERNEL_PR}"
12
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14
15COMPATIBLE_MACHINE = "j721e|j721s2|j784s4|am62xx"
16
17DEPENDS = "virtual/kernel"
18
19BRANCH = "linuxws/kirkstone/k6.1/${PV}"
20
21SRC_URI = "git://git.ti.com/git/graphics/ti-img-rogue-driver.git;protocol=https;branch=${BRANCH}"
22
23S = "${WORKDIR}/git"
24
25SRCREV = "778aa5d1e104f36c7f7c1f50e99f8499cbbdadbb"
26
27TARGET_PRODUCT:j721e = "j721e_linux"
28TARGET_PRODUCT:j721s2 = "j721s2_linux"
29TARGET_PRODUCT:j784s4 = "j784s4_linux"
30TARGET_PRODUCT:am62xx = "am62_linux"
31PVR_BUILD = "release"
32PVR_WS = "lws-generic"
33
34EXTRA_OEMAKE += 'KERNELDIR="${STAGING_KERNEL_DIR}" BUILD=${PVR_BUILD} PVR_BUILD_DIR=${TARGET_PRODUCT} WINDOW_SYSTEM=${PVR_WS}'
35
36do_install() {
37 make -C ${STAGING_KERNEL_DIR} M=${B}/binary_${TARGET_PRODUCT}_${PVR_WS}_${PVR_BUILD}/target_aarch64/kbuild INSTALL_MOD_PATH=${D}${root_prefix} PREFIX=${STAGING_DIR_HOST} modules_install
38}
39
40RRECOMMENDS:${PN} += "ti-img-rogue-umlibs"