summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/gc320-drivers
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-02-22 04:13:45 +0000
committerRyan Eatmon <reatmon@ti.com>2022-02-22 12:01:38 -0600
commit20f3191aeb592dd889eeaf96a31526297de95306 (patch)
treeaec879b9855ff8a54df171ee808e30ac26f1c80b /meta-ti-bsp/recipes-bsp/gc320-drivers
parentbea4fd2c401af05b866bd6af1c4e501d31b7b420 (diff)
downloadmeta-ti-20f3191aeb592dd889eeaf96a31526297de95306.tar.gz
meta-ti: create a sub-layer meta-ti-bsp from existing content
Extra sub-layers will be created next and relevant content moved across them. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/gc320-drivers')
-rw-r--r--meta-ti-bsp/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb b/meta-ti-bsp/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
new file mode 100644
index 00000000..e815ae29
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "Kernel drivers for the Vivante GC320 chipset found in TI SoCs"
2HOMEPAGE = "https://git.ti.com/graphics/ti-gc320-driver"
3LICENSE = "MIT | GPLv2"
4LIC_FILES_CHKSUM = "file://../LICENSE;md5=78d9818a51b9a8e9bb89dea418bac297"
5
6inherit module features_check
7
8REQUIRED_MACHINE_FEATURES = "gc320"
9
10MACHINE_KERNEL_PR:append = "i"
11PR = "${MACHINE_KERNEL_PR}"
12
13# Need to branch out with ${PV} var
14BRANCH = "ti-${PV}-k5.10"
15
16SRCREV = "e2a10f31e255a65ec30a6e10b890e77d7e9cb107"
17
18SRC_URI = "git://git.ti.com/graphics/ti-gc320-driver.git;protocol=git;branch=${BRANCH}"
19
20S = "${WORKDIR}/git/src"
21
22EXTRA_OEMAKE += "-f Kbuild AQROOT=${S} KERNEL_DIR=${STAGING_KERNEL_DIR} TOOLCHAIN_PATH=${TOOLCHAIN_PATH} CROSS_COMPILE=${TARGET_PREFIX} ARCH_TYPE=${TARGET_ARCH}"
23
24do_install() {
25 install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/extra
26 install -m 644 ${S}/galcore.ko ${D}/${base_libdir}/modules/${KERNEL_VERSION}/extra
27}
28
29COMPATIBLE_HOST ?= "null"
30COMPATIBLE_HOST:ti-soc = "(.*)"