summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-02-22 04:13:45 +0000
committerRyan Eatmon <reatmon@ti.com>2022-02-22 12:01:38 -0600
commit20f3191aeb592dd889eeaf96a31526297de95306 (patch)
treeaec879b9855ff8a54df171ee808e30ac26f1c80b /meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw
parentbea4fd2c401af05b866bd6af1c4e501d31b7b420 (diff)
downloadmeta-ti-20f3191aeb592dd889eeaf96a31526297de95306.tar.gz
meta-ti: create a sub-layer meta-ti-bsp from existing content
Extra sub-layers will be created next and relevant content moved across them. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw')
-rwxr-xr-xmeta-ti-bsp/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb b/meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb
new file mode 100755
index 00000000..ed36951f
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb
@@ -0,0 +1,43 @@
1SUMMARY = "R5 PSDK CPSW9G Ethernet Switch Firmware"
2
3LICENSE = "TI-TFL"
4LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=04ad0a015d4bb63c2b9e7b112debf3db"
5
6PV = "6.2+git${SRCPV}"
7PACKAGE_ARCH = "${MACHINE_ARCH}"
8
9inherit deploy
10inherit update-alternatives
11
12PROTOCOL = "git"
13BRANCH = "master"
14SRCREV = "91f1628507bf7f8716f0bc7cafe88ad7f14c94f5"
15
16SRC_URI = "git://git.ti.com/glsdk/ti-eth-fw.git;protocol=${PROTOCOL};branch=${BRANCH}"
17
18S = "${WORKDIR}/git"
19
20CPSW9G_FW_DIR = "${S}/ethfw"
21CPSW9G_FW_FILENAME = "app_remoteswitchcfg_server_pdk_mem_map_strip.xer5f"
22
23# make sure that lib/firmware, and all its contents are part of the package
24FILES:${PN} += "${base_libdir}/firmware"
25
26do_install() {
27 install -d ${D}${base_libdir}/firmware
28# Ethernet firmware to be loaded on Main R5 core(needs read permission)
29 install -m 0644 ${CPSW9G_FW_DIR}/${CPSW9G_FW_FILENAME} ${D}${base_libdir}/firmware
30}
31
32TARGET_MAIN_R5FSS0_0 = "j7-main-r5f0_0-fw"
33ALTERNATIVE:${PN} = "j7-main-r5f0_0-fw"
34ALTERNATIVE_LINK_NAME[j7-main-r5f0_0-fw] = "${base_libdir}/firmware/${TARGET_MAIN_R5FSS0_0}"
35ALTERNATIVE_TARGET[j7-main-r5f0_0-fw] = "${base_libdir}/firmware/${CPSW9G_FW_FILENAME}"
36ALTERNATIVE_PRIORITY = "17"
37
38INHIBIT_PACKAGE_STRIP = "1"
39INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
40INSANE_SKIP:${PN} += "arch"
41
42do_compile[noexec] = "1"
43do_configure[noexec] = "1"