diff options
author | Denys Dmytriyenko <denys@konsulko.com> | 2022-02-22 04:13:45 +0000 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2022-02-22 12:01:38 -0600 |
commit | 20f3191aeb592dd889eeaf96a31526297de95306 (patch) | |
tree | aec879b9855ff8a54df171ee808e30ac26f1c80b /meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw | |
parent | bea4fd2c401af05b866bd6af1c4e501d31b7b420 (diff) | |
download | meta-ti-20f3191aeb592dd889eeaf96a31526297de95306.tar.gz |
meta-ti: create a sub-layer meta-ti-bsp from existing content
Extra sub-layers will be created next and relevant content moved across them.
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw')
-rwxr-xr-x | meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb | 43 |
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb b/meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb new file mode 100755 index 00000000..ed36951f --- /dev/null +++ b/meta-ti-bsp/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb | |||
@@ -0,0 +1,43 @@ | |||
1 | SUMMARY = "R5 PSDK CPSW9G Ethernet Switch Firmware" | ||
2 | |||
3 | LICENSE = "TI-TFL" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=04ad0a015d4bb63c2b9e7b112debf3db" | ||
5 | |||
6 | PV = "6.2+git${SRCPV}" | ||
7 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
8 | |||
9 | inherit deploy | ||
10 | inherit update-alternatives | ||
11 | |||
12 | PROTOCOL = "git" | ||
13 | BRANCH = "master" | ||
14 | SRCREV = "91f1628507bf7f8716f0bc7cafe88ad7f14c94f5" | ||
15 | |||
16 | SRC_URI = "git://git.ti.com/glsdk/ti-eth-fw.git;protocol=${PROTOCOL};branch=${BRANCH}" | ||
17 | |||
18 | S = "${WORKDIR}/git" | ||
19 | |||
20 | CPSW9G_FW_DIR = "${S}/ethfw" | ||
21 | CPSW9G_FW_FILENAME = "app_remoteswitchcfg_server_pdk_mem_map_strip.xer5f" | ||
22 | |||
23 | # make sure that lib/firmware, and all its contents are part of the package | ||
24 | FILES:${PN} += "${base_libdir}/firmware" | ||
25 | |||
26 | do_install() { | ||
27 | install -d ${D}${base_libdir}/firmware | ||
28 | # Ethernet firmware to be loaded on Main R5 core(needs read permission) | ||
29 | install -m 0644 ${CPSW9G_FW_DIR}/${CPSW9G_FW_FILENAME} ${D}${base_libdir}/firmware | ||
30 | } | ||
31 | |||
32 | TARGET_MAIN_R5FSS0_0 = "j7-main-r5f0_0-fw" | ||
33 | ALTERNATIVE:${PN} = "j7-main-r5f0_0-fw" | ||
34 | ALTERNATIVE_LINK_NAME[j7-main-r5f0_0-fw] = "${base_libdir}/firmware/${TARGET_MAIN_R5FSS0_0}" | ||
35 | ALTERNATIVE_TARGET[j7-main-r5f0_0-fw] = "${base_libdir}/firmware/${CPSW9G_FW_FILENAME}" | ||
36 | ALTERNATIVE_PRIORITY = "17" | ||
37 | |||
38 | INHIBIT_PACKAGE_STRIP = "1" | ||
39 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
40 | INSANE_SKIP:${PN} += "arch" | ||
41 | |||
42 | do_compile[noexec] = "1" | ||
43 | do_configure[noexec] = "1" | ||