summaryrefslogtreecommitdiffstats
path: root/meta-ti-bsp/recipes-bsp/cadence-mhdp-fw
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-02-22 04:13:45 +0000
committerRyan Eatmon <reatmon@ti.com>2022-02-22 12:01:38 -0600
commit20f3191aeb592dd889eeaf96a31526297de95306 (patch)
treeaec879b9855ff8a54df171ee808e30ac26f1c80b /meta-ti-bsp/recipes-bsp/cadence-mhdp-fw
parentbea4fd2c401af05b866bd6af1c4e501d31b7b420 (diff)
downloadmeta-ti-20f3191aeb592dd889eeaf96a31526297de95306.tar.gz
meta-ti: create a sub-layer meta-ti-bsp from existing content
Extra sub-layers will be created next and relevant content moved across them. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'meta-ti-bsp/recipes-bsp/cadence-mhdp-fw')
-rw-r--r--meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb b/meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb
new file mode 100644
index 00000000..c975e8a4
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Cadence MHDP DP bridge firmware"
2
3require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
4
5LICENSE = "BSD-3-Clause | Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENCE.cadence;md5=009f46816f6956cfb75ede13d3e1cee0"
7
8PV = "${CADENCE_MHDP_FW_VERSION}"
9PR = "${INC_PR}.0"
10
11CLEANBROKEN = "1"
12
13COMPATIBLE_MACHINE = "j7"
14
15PACKAGE_ARCH = "${MACHINE_ARCH}"
16
17S = "${WORKDIR}/git"
18TARGET = "mhdp8546.bin"
19
20do_install() {
21 install -d ${D}${base_libdir}/firmware/cadence
22 install -m 0644 ${S}/cadence/${TARGET} ${D}${base_libdir}/firmware/cadence/${TARGET}
23}
24
25FILES:${PN} = "${base_libdir}/firmware"