diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-01-02 16:45:43 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-01-02 16:45:43 +0100 |
commit | 7d39ce1743e1a58c51b35f42fb70f9e31a4c8908 (patch) | |
tree | d29507cf0c533b104617ce8333fec12289468f84 /conf | |
download | meta-ti-7d39ce1743e1a58c51b35f42fb70f9e31a4c8908.tar.gz |
BSP: rename beagleboard to TI
linux-omap 2.6.37rc: sync with OE
Diffstat (limited to 'conf')
-rw-r--r-- | conf/layer.conf | 10 | ||||
-rw-r--r-- | conf/machine/beagleboard.conf | 44 |
2 files changed, 54 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf new file mode 100644 index 00000000..a507cbc7 --- /dev/null +++ b/conf/layer.conf | |||
@@ -0,0 +1,10 @@ | |||
1 | # We have a conf and classes directory, prepend to BBPATH | ||
2 | BBPATH := "${LAYERDIR}:${BBPATH}" | ||
3 | |||
4 | # We have a recipes directory, add to BBFILES | ||
5 | BBFILES := "${BBFILES} ${LAYERDIR}/recipes*/*/*.bb \ | ||
6 | ${LAYERDIR}/recipes*/*/*.bbappend" | ||
7 | |||
8 | BBFILE_COLLECTIONS += "beagle-bsp" | ||
9 | BBFILE_PATTERN_beagle-bsp := "^${LAYERDIR}/" | ||
10 | BBFILE_PRIORITY_beagle-bsp = "10" | ||
diff --git a/conf/machine/beagleboard.conf b/conf/machine/beagleboard.conf new file mode 100644 index 00000000..ce480193 --- /dev/null +++ b/conf/machine/beagleboard.conf | |||
@@ -0,0 +1,44 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: Beagleboard machine | ||
3 | #@DESCRIPTION: Machine configuration for the http://beagleboard.org/ board | ||
4 | TARGET_ARCH = "arm" | ||
5 | |||
6 | PREFERRED_PROVIDER_virtual/xserver = "xserver-xorg" | ||
7 | XSERVER = "xserver-xorg \ | ||
8 | xf86-input-evdev \ | ||
9 | xf86-input-mouse \ | ||
10 | xf86-video-omapfb \ | ||
11 | xf86-input-keyboard" | ||
12 | |||
13 | # Only has DVI connector for external screen | ||
14 | GUI_MACHINE_CLASS = "bigscreen" | ||
15 | |||
16 | require conf/machine/include/omap3.inc | ||
17 | |||
18 | PREFERRED_PROVIDER_virtual/kernel = "linux-omap-psp" | ||
19 | |||
20 | IMAGE_FSTYPES += "tar.bz2 ubi" | ||
21 | EXTRA_IMAGECMD_jffs2 = "-lnp " | ||
22 | |||
23 | # Guesswork | ||
24 | SERIAL_CONSOLE = "115200 ttyS2" | ||
25 | |||
26 | UBOOT_MACHINE = "omap3_beagle_config" | ||
27 | |||
28 | # do ubiattach /dev/ubi_ctrl -m 4 | ||
29 | # From dmesg: | ||
30 | # UBI: smallest flash I/O unit: 2048 | ||
31 | # UBI: logical eraseblock size: 129024 bytes | ||
32 | # from ubiattach stdout: | ||
33 | # UBI device number 0, total 1996 LEBs | ||
34 | MKUBIFS_ARGS = "-m 2048 -e 129024 -c 1996" | ||
35 | |||
36 | # do ubiattach /dev/ubi_ctrl -m 4 | ||
37 | # from dmesg: | ||
38 | # UBI: smallest flash I/O unit: 2048 | ||
39 | # UBI: physical eraseblock size: 131072 bytes (128 KiB) | ||
40 | # UBI: sub-page size: 512 | ||
41 | UBINIZE_ARGS = "-m 2048 -p 128KiB -s 512" | ||
42 | |||
43 | # and sdio | ||
44 | MACHINE_FEATURES = "kernel26 screen apm usbgadget usbhost vfat alsa" | ||