summaryrefslogtreecommitdiffstats
path: root/classes
diff options
context:
space:
mode:
authorLuca Ceresoli <luca@lucaceresoli.net>2019-12-04 17:45:29 +0100
committerDenys Dmytriyenko <denys@ti.com>2019-12-09 18:15:23 +0000
commitfb189e30ebb76afb88171a8fbd813e0eeb14565d (patch)
tree8c8a069dd1d61bcd4ac58859c320c85d8fa325a0 /classes
parent1108d0167890c575b3887c6df39242d838e3e0c8 (diff)
downloadmeta-ti-fb189e30ebb76afb88171a8fbd813e0eeb14565d.tar.gz
Fix "basehash value changed" errors and BB_NUMBER_THREADS usage
Changing BB_NUMBER_THREADS between successive builds causes a "basehash value changed" error. Additionally, using BB_NUMBER_THREADS to pass a number of processes to run to xdc is wrong: PARALLEL_MAKE is the correct variable to use. Fix both problems by using oe.utils.parallel_make_argument() to obtain the number of processes to run from PARALLEL_MAKE. Fixes: ERROR: When reparsing .../meta-ti/recipes-ti/ipc/ti-ipc-rtos_git.bb.do_configure, the basehash value changed from 63897a188012cedde03f756b5dbbfa70 to 13b80bf4f4327c367bd201eb4aa32ad7. The metadata is not deterministic and this needs to be fixed. ERROR: When reparsing .../meta-ti/recipes-ti/ipc/ti-ipc-rtos_git.bb.do_compile, the basehash value changed from 2fb59a7db2a2f69d2c25c06c1b6a4245 to 314c664cc040afae2800fcc378dd9ae0. The metadata is not deterministic and this needs to be fixed. Steps to reproduce: BB_NUMBER_THREADS="3" bitbake ti-ipc-rtos ti-ipc-examples-linux BB_NUMBER_THREADS="4" bitbake -c cleansstate osal-rtos BB_NUMBER_THREADS="5" bitbake ti-ipc-rtos ti-ipc-examples-linux Reported here: https://e2e.ti.com/support/processors/f/791/p/825142/3059419 Reported-by: Matthew McKee (e-mail unknown) Suggested-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'classes')
-rw-r--r--classes/ti-pdk.bbclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/classes/ti-pdk.bbclass b/classes/ti-pdk.bbclass
index 7030f70e..a07fdbb3 100644
--- a/classes/ti-pdk.bbclass
+++ b/classes/ti-pdk.bbclass
@@ -71,7 +71,7 @@ TI_PDK_DOXYGEN_SUPPORT ?= "1"
71 71
72TI_PDK_XDC_ARGS ?= "${TI_PDK_LIMIT_SOCS}" 72TI_PDK_XDC_ARGS ?= "${TI_PDK_LIMIT_SOCS}"
73 73
74PARALLEL_XDC = "--jobs=${BB_NUMBER_THREADS}" 74PARALLEL_XDC = "${@oe.utils.parallel_make_argument(d, '--jobs=%d')}"
75PARALLEL_MAKE = "" 75PARALLEL_MAKE = ""
76 76
77def get_doxygen_support(d): 77def get_doxygen_support(d):