summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2014-10-08 16:27:29 +0000
committerDenys Dmytriyenko <denys@ti.com>2014-10-08 13:27:31 -0400
commita9fd89aa06356917f6641fde0903f2d462ab5635 (patch)
tree56c23fd6da411a9fad4a0f4c71078ddaf868fb31
parent5171650c1cd2aa7f4d3379657a9cc53899959a47 (diff)
downloadmeta-ti-a9fd89aa06356917f6641fde0903f2d462ab5635.tar.gz
rm-lld: Rename recipe and update to new version
- Removed ti-prefix based on review - Update to new version 2.1.0.6 - Add dependency on libdaemon - Remove device dependency - Updated license to BSD-3-Clause Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/rm-lld/rm-lld_git.bb (renamed from recipes-bsp/rm-lld/ti-rm_git.bb)24
1 files changed, 8 insertions, 16 deletions
diff --git a/recipes-bsp/rm-lld/ti-rm_git.bb b/recipes-bsp/rm-lld/rm-lld_git.bb
index 276c01e2..ed344787 100644
--- a/recipes-bsp/rm-lld/ti-rm_git.bb
+++ b/recipes-bsp/rm-lld/rm-lld_git.bb
@@ -1,17 +1,17 @@
1DESCRIPTION = "TI Resource Manager Low Level Driver" 1DESCRIPTION = "TI Resource Manager Low Level Driver"
2LICENSE = "TI BSD" 2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/rm/COPYING.txt;md5=dc61631b65360e6beb73b6c337800afc" 3LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/rm/COPYING.txt;md5=dc61631b65360e6beb73b6c337800afc"
4 4
5BRANCH="master" 5BRANCH="master"
6SRC_URI = "git://git.ti.com/keystone-rtos/rm-lld.git;destsuffix=git/ti/drv/rm;protocol=git;branch=${BRANCH}" 6SRC_URI = "git://git.ti.com/keystone-rtos/rm-lld.git;destsuffix=git/ti/drv/rm;protocol=git;branch=${BRANCH}"
7# Below commit ID corresponds to DEV.RM_LLD.02.01.00.04 7# Below commit ID corresponds to DEV.RM_LLD.02.01.00.06
8SRCREV = "59e3bf5fca3995dd0f79bbdd1af988d278a2a049" 8SRCREV = "dc0dba4a6b0358efcb861d50b3dae21beb5281a8"
9PV = "02.01.00.06"
9PR = "r0" 10PR = "r0"
10PV = "02.01.00.04"
11 11
12COMPATIBLE_MACHINE = "keystone" 12COMPATIBLE_MACHINE = "keystone"
13 13
14DEPENDS = "ti-ipc" 14DEPENDS = "ti-ipc libdaemon"
15 15
16PACKAGES =+ "${PN}-test" 16PACKAGES =+ "${PN}-test"
17 17
@@ -19,8 +19,6 @@ FILES_${PN}-test = "${bindir}/rmDspClientTest_*.out \
19 ${bindir}/rmLinuxClientTest_*.out \ 19 ${bindir}/rmLinuxClientTest_*.out \
20 ${bindir}/ti/drv/rm/test/dts_files/*.dtb" 20 ${bindir}/ti/drv/rm/test/dts_files/*.dtb"
21 21
22DEVICELIST = "k2h k2k"
23
24CHOICELIST = "yes no" 22CHOICELIST = "yes no"
25 23
26BASEDIR = "${WORKDIR}/git" 24BASEDIR = "${WORKDIR}/git"
@@ -29,12 +27,9 @@ S = "${BASEDIR}/ti/drv/rm"
29do_compile () { 27do_compile () {
30# Now build the lld 28# Now build the lld
31 make -f makefile_armv7 clean lib PDK_INSTALL_PATH=${STAGING_INCDIR} RM_SRC_DIR=${S} 29 make -f makefile_armv7 clean lib PDK_INSTALL_PATH=${STAGING_INCDIR} RM_SRC_DIR=${S}
32 for device in ${DEVICELIST} 30 for choice in ${CHOICELIST}
33 do 31 do
34 for choice in ${CHOICELIST} 32 make -f makefile_armv7 tests IPC_DEVKIT_INSTALL_PATH=${STAGING_INCDIR} PDK_INSTALL_PATH=${BASEDIR} USEDYNAMIC_LIB="$choice"
35 do
36 make -f makefile_armv7 tests IPC_DEVKIT_INSTALL_PATH=${STAGING_INCDIR} PDK_INSTALL_PATH=${BASEDIR} DEVICE="$device" USEDYNAMIC_LIB="$choice"
37 done
38 done 33 done
39} 34}
40 35
@@ -42,8 +37,5 @@ do_install () {
42 install -d ${D}${includedir}/ti/drv/rm 37 install -d ${D}${includedir}/ti/drv/rm
43 install -d ${D}${libdir} 38 install -d ${D}${libdir}
44 install -d ${D}${bindir} 39 install -d ${D}${bindir}
45 for device in ${DEVICELIST} 40 make -f makefile_armv7 install installbin installbin_test INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} INSTALL_BIN_BASE_DIR=${D}${bindir}
46 do
47 make -f makefile_armv7 install installbin installbin_test INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="$device"
48 done
49} 41}