summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2019-11-15 21:14:44 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-12-09 18:15:23 +0000
commit0b784feecded1e64e78ae8ef3e52da478e60d130 (patch)
treea15772ae4bb5eefebcaa5aa819f6323bf6820413
parent55f7592f7ab0894e552520bd1a9dc2645728f957 (diff)
downloadmeta-ti-0b784feecded1e64e78ae8ef3e52da478e60d130.tar.gz
pru: migrate to ti-pdk-fetch.bbclass
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/pru/pru-pwm-fw_git.bb11
-rw-r--r--recipes-bsp/pru/pru-swuart-fw_git.bb12
2 files changed, 11 insertions, 12 deletions
diff --git a/recipes-bsp/pru/pru-pwm-fw_git.bb b/recipes-bsp/pru/pru-pwm-fw_git.bb
index 0fe79879..a8c71034 100644
--- a/recipes-bsp/pru/pru-pwm-fw_git.bb
+++ b/recipes-bsp/pru/pru-pwm-fw_git.bb
@@ -8,17 +8,16 @@ require recipes-ti/includes/ti-paths.inc
8COMPATIBLE_MACHINE = "am65xx" 8COMPATIBLE_MACHINE = "am65xx"
9PACKAGE_ARCH = "${MACHINE_ARCH}" 9PACKAGE_ARCH = "${MACHINE_ARCH}"
10 10
11# Below commit ID corresponds to "DEV.PRUSS_LLD.01.00.00.15B"
12SRCREV = "989f802266d52f50a6db8f2be6967eacd9d2b409"
13 11
14PV = "01.00.00.15B"
15 12
16BRANCH = "master" 13inherit ti-pdk-fetch
17SRC_URI = "git://git.ti.com/keystone-rtos/pruss-lld.git;protocol=git;branch=${BRANCH}" 14
15TI_PDK_COMP = "ti.drv.pruss.example.apps.icssg_pwm.firmware.src"
16
17PE = "1"
18 18
19DEPENDS = "ti-cgt-pru-native pru-icss common-csl-ip-rtos" 19DEPENDS = "ti-cgt-pru-native pru-icss common-csl-ip-rtos"
20 20
21S = "${WORKDIR}/git/example/apps/icssg_pwm/firmware/src"
22 21
23EXTRA_OEMAKE += " \ 22EXTRA_OEMAKE += " \
24 PRU_CGT="${TI_CGT_PRU_INSTALL_DIR}" \ 23 PRU_CGT="${TI_CGT_PRU_INSTALL_DIR}" \
diff --git a/recipes-bsp/pru/pru-swuart-fw_git.bb b/recipes-bsp/pru/pru-swuart-fw_git.bb
index e22b3bea..1cb51f38 100644
--- a/recipes-bsp/pru/pru-swuart-fw_git.bb
+++ b/recipes-bsp/pru/pru-swuart-fw_git.bb
@@ -8,20 +8,20 @@ require recipes-ti/includes/ti-paths.inc
8COMPATIBLE_MACHINE = "ti33x" 8COMPATIBLE_MACHINE = "ti33x"
9PACKAGE_ARCH = "${MACHINE_ARCH}" 9PACKAGE_ARCH = "${MACHINE_ARCH}"
10 10
11# Below commit ID corresponds to "DEV.UART_LLD.01.00.00.15"
12SRCREV = "4493f456549c85749a05b1f46bf0b75d23976db1"
13 11
14PV = "01.00.00.15" 12inherit ti-pdk-fetch
15 13
16BRANCH = "master" 14TI_PDK_COMP = "ti.drv.uart"
17SRC_URI = "git://git.ti.com/keystone-rtos/uart-lld.git;protocol=git;branch=${BRANCH} \ 15
16PE = "1"
17
18SRC_URI_append = " \
18 file://0001-icss_uart-add-Makefile-for-building-firmware.patch \ 19 file://0001-icss_uart-add-Makefile-for-building-firmware.patch \
19 file://0001-icss_uart-remove-dependency-on-PDK-CSL.patch \ 20 file://0001-icss_uart-remove-dependency-on-PDK-CSL.patch \
20" 21"
21 22
22DEPENDS = "ti-cgt-pru-native pru-icss" 23DEPENDS = "ti-cgt-pru-native pru-icss"
23 24
24S = "${WORKDIR}/git"
25 25
26export PRU_CGT = "${TI_CGT_PRU_INSTALL_DIR}" 26export PRU_CGT = "${TI_CGT_PRU_INSTALL_DIR}"
27export PRU_SSP = "${STAGING_DIR_TARGET}/usr" 27export PRU_SSP = "${STAGING_DIR_TARGET}/usr"