summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2020-02-20 11:14:22 +0000
committerDenys Dmytriyenko <denys@ti.com>2020-02-20 16:20:30 +0000
commit7238e370bcfe06db5d5f771b27f46c263e034f3f (patch)
treef56812fc39e7ffbc822266dc32b506e298033acd
parent836f9879261f69b1d9b3670ec53af6a26e6044af (diff)
downloadmeta-ti-7238e370bcfe06db5d5f771b27f46c263e034f3f.tar.gz
ion-tests: move back to meta-arago-extras
As it happens, ion-tests requires gtest from by meta-oe, but meta-ti has no dependency on meta-oe. Unfortunately this was overlooked when all ion recipes were migrated to meta-ti. Fix this by moving just ion-tests back. Cc: Andrew F. Davis <afd@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-devtools/ion/ion-tests/0001-CMakeLists.txt-disable-phys-addr-for-now.patch34
-rw-r--r--recipes-devtools/ion/ion-tests/0001-map_test-Replace-PAGE_SIZE-with-local-variable-name.patch69
-rw-r--r--recipes-devtools/ion/ion-tests_git.bb19
3 files changed, 0 insertions, 122 deletions
diff --git a/recipes-devtools/ion/ion-tests/0001-CMakeLists.txt-disable-phys-addr-for-now.patch b/recipes-devtools/ion/ion-tests/0001-CMakeLists.txt-disable-phys-addr-for-now.patch
deleted file mode 100644
index 7cf5895c..00000000
--- a/recipes-devtools/ion/ion-tests/0001-CMakeLists.txt-disable-phys-addr-for-now.patch
+++ /dev/null
@@ -1,34 +0,0 @@
1From 85264fc72a261d20107a50ea2fad0258900a132b Mon Sep 17 00:00:00 2001
2From: Denys Dmytriyenko <denys@ti.com>
3Date: Sat, 20 Apr 2019 16:54:03 +0000
4Subject: [PATCH] CMakeLists.txt: disable phys-addr for now
5
6Signed-off-by: Denys Dmytriyenko <denys@ti.com>
7---
8 CMakeLists.txt | 13 -------------
9 1 file changed, 13 deletions(-)
10
11diff --git a/CMakeLists.txt b/CMakeLists.txt
12index 1d60003..eca6ba7 100644
13--- a/CMakeLists.txt
14+++ b/CMakeLists.txt
15@@ -54,16 +54,3 @@ target_link_libraries(ion-print-heaps
16 target_include_directories(ion-print-heaps PUBLIC ${LIBION_INCLUDE_DIRS})
17
18 install(TARGETS ion-print-heaps RUNTIME DESTINATION bin)
19-
20-# phys-addr
21-
22-add_executable(phys-addr
23- src/phys-addr.c
24-)
25-
26-target_link_libraries(phys-addr
27- ${LIBION_LIBRARIES}
28-)
29-target_include_directories(phys-addr PUBLIC ${LIBION_INCLUDE_DIRS})
30-
31-install(TARGETS phys-addr RUNTIME DESTINATION bin)
32--
332.17.1
34
diff --git a/recipes-devtools/ion/ion-tests/0001-map_test-Replace-PAGE_SIZE-with-local-variable-name.patch b/recipes-devtools/ion/ion-tests/0001-map_test-Replace-PAGE_SIZE-with-local-variable-name.patch
deleted file mode 100644
index 8915c642..00000000
--- a/recipes-devtools/ion/ion-tests/0001-map_test-Replace-PAGE_SIZE-with-local-variable-name.patch
+++ /dev/null
@@ -1,69 +0,0 @@
1From f045cbf9aae0053e9e785e32b772e473aa892443 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 6 Oct 2019 16:08:36 -0700
4Subject: [PATCH] map_test: Replace PAGE_SIZE with local variable name
5
6PAGE_SIZE is already a define in libc implementations global namespace
7e.g. in musl. Therefore its best to use a unique variable name to not
8stamp on the global definition.
9
10Fixes
11src/map_test.cpp:59:23: error: expected unqualified-id
12unsigned long PAGE_SIZE = sysconf(_SC_PAGESIZE);
13^
14/usr/include/limits.h:89:19: note: expanded from macro 'PAGE_SIZE'
15^
16/usr/include/bits/limits.h:3:18: note: expanded from macro 'PAGESIZE'
17^
18
19Upstream-Status: Submitted [https://github.com/glneo/ion-tests/pull/1]
20
21Signed-off-by: Khem Raj <raj.khem@gmail.com>
22---
23 src/map_test.cpp | 18 +++++++++---------
24 1 file changed, 9 insertions(+), 9 deletions(-)
25
26diff --git a/src/map_test.cpp b/src/map_test.cpp
27index a7ce2c9..7b5746d 100644
28--- a/src/map_test.cpp
29+++ b/src/map_test.cpp
30@@ -56,27 +56,27 @@ TEST_F(Map, MapOffset)
31 SCOPED_TRACE(::testing::Message() << "heap " << heapMask);
32 int map_fd = -1;
33
34- unsigned long PAGE_SIZE = sysconf(_SC_PAGESIZE);
35+ unsigned long psize = sysconf(_SC_PAGESIZE);
36
37- ASSERT_EQ(0, ion_alloc(m_ionFd, PAGE_SIZE * 2, heapMask, 0, &map_fd));
38+ ASSERT_EQ(0, ion_alloc(m_ionFd, psize * 2, heapMask, 0, &map_fd));
39 ASSERT_GE(map_fd, 0);
40
41 unsigned char *ptr;
42- ptr = (unsigned char *)mmap(NULL, PAGE_SIZE * 2, PROT_READ | PROT_WRITE, MAP_SHARED, map_fd, 0);
43+ ptr = (unsigned char *)mmap(NULL, psize * 2, PROT_READ | PROT_WRITE, MAP_SHARED, map_fd, 0);
44 ASSERT_TRUE(ptr != NULL);
45
46- memset(ptr, 0, PAGE_SIZE);
47- memset(ptr + PAGE_SIZE, 0xaa, PAGE_SIZE);
48+ memset(ptr, 0, psize);
49+ memset(ptr + psize, 0xaa, psize);
50
51- ASSERT_EQ(0, munmap(ptr, PAGE_SIZE * 2));
52+ ASSERT_EQ(0, munmap(ptr, psize * 2));
53
54- ptr = (unsigned char *)mmap(NULL, PAGE_SIZE, PROT_READ | PROT_WRITE, MAP_SHARED, map_fd, PAGE_SIZE);
55+ ptr = (unsigned char *)mmap(NULL, psize, PROT_READ | PROT_WRITE, MAP_SHARED, map_fd, psize);
56 ASSERT_TRUE(ptr != NULL);
57
58 ASSERT_EQ(ptr[0], 0xaa);
59- ASSERT_EQ(ptr[PAGE_SIZE - 1], 0xaa);
60+ ASSERT_EQ(ptr[psize - 1], 0xaa);
61
62- ASSERT_EQ(0, munmap(ptr, PAGE_SIZE));
63+ ASSERT_EQ(0, munmap(ptr, psize));
64
65 ASSERT_EQ(0, close(map_fd));
66 }
67--
682.23.0
69
diff --git a/recipes-devtools/ion/ion-tests_git.bb b/recipes-devtools/ion/ion-tests_git.bb
deleted file mode 100644
index 52346f1c..00000000
--- a/recipes-devtools/ion/ion-tests_git.bb
+++ /dev/null
@@ -1,19 +0,0 @@
1SUMMARY = "Test cases for ION"
2HOMEPAGE = "https://github.com/glneo/ion-tests"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://src/ion_test.c;beginline=1;endline=15;md5=b225db900869a4cd31461606e55a3ec5"
5
6PV = "1.0"
7
8BRANCH = "master"
9SRC_URI = "git://github.com/glneo/ion-tests.git;protocol=git;branch=${BRANCH} \
10 file://0001-CMakeLists.txt-disable-phys-addr-for-now.patch \
11 file://0001-map_test-Replace-PAGE_SIZE-with-local-variable-name.patch \
12"
13SRCREV = "70d730cebca29e6fd37b21d9beac82ae645f3900"
14
15DEPENDS = "libion gtest"
16
17S = "${WORKDIR}/git"
18
19inherit cmake pkgconfig