summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2020-02-12 05:06:14 +0000
committerDenys Dmytriyenko <denys@ti.com>2020-02-12 02:16:04 +0000
commite1303e71f9a55f83f95112bb8b718e9ff56ccf21 (patch)
tree94818cee51008e8b2e56af7cfb88578874d1d67f
parentcc5437d810fe8f58fe487db1a229c13a6d51640d (diff)
downloadmeta-ti-e1303e71f9a55f83f95112bb8b718e9ff56ccf21.tar.gz
multiprocmgr-test: also do not access kernel headers directly
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr-test_git.bb14
1 files changed, 8 insertions, 6 deletions
diff --git a/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb b/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb
index f01d6513..aab8ae6c 100644
--- a/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb
+++ b/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb
@@ -1,18 +1,20 @@
1DESCRIPTION = "TI Multiproc Manager test code" 1FILESEXTRAPATHS_prepend := "${THISDIR}/multiprocmgr:"
2
3SUMMARY = "TI Multiproc Manager test code"
2 4
3include multiprocmgr.inc 5include multiprocmgr.inc
4 6
7SRC_URI += " \
8 file://0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch \
9 file://0001-mpmdlif.c-don-t-suppress-kernel-linux-types.h-inclus.patch \
10"
11
5PR = "${INC_PR}.2" 12PR = "${INC_PR}.2"
6 13
7DEPENDS = "multiprocmgr cmem" 14DEPENDS = "multiprocmgr cmem"
8RDEPENDS_${PN} = "multiprocmgr mpm-transport cmem" 15RDEPENDS_${PN} = "multiprocmgr mpm-transport cmem"
9RDEPENDS_${PN} += "multiprocmgr-rtos-test bash" 16RDEPENDS_${PN} += "multiprocmgr-rtos-test bash"
10 17
11CC += "-I${STAGING_KERNEL_DIR}/include"
12
13# Assuming the multiprocmgr kernel API is safe
14CC[vardepsexclude] = "STAGING_KERNEL_DIR"
15
16FILES_${PN} += "\ 18FILES_${PN} += "\
17 ${datadir}/ti/examples/mpm \ 19 ${datadir}/ti/examples/mpm \
18" 20"