summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <trini@konsulko.com>2018-08-31 21:54:34 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-09-05 19:21:19 +0000
commitc3a06e40700cd7e144ad4a8b698f3865a02d9e76 (patch)
tree18f1420d52ffcef55b4e2c2634ab38194356ae64
parentaf1e5cd2cc77f6834bd70909c2adca612113a733 (diff)
downloadmeta-ti-c3a06e40700cd7e144ad4a8b698f3865a02d9e76.tar.gz
amx3-cm3: Fix building with poky-lsb
One of the features of poky-lsb is that it brings in the security_flags.inc file that sets a number of security-related compile time flags. This includes changing some of the default GCC build options. However, for building the amx3-cm3 firmware we want to ensure that none of this enabled as it's not useful in this particular environment. We must pass in ${SECURITY_NOPIE_CFLAGS} to disable PIE. When security_flags.inc is not present this is an empty string so is safe to do at all times. Signed-off-by: Tom Rini <trini@konsulko.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bb b/recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bb
index 5a2b08bb..1dcc021c 100644
--- a/recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bb
+++ b/recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bb
@@ -16,7 +16,7 @@ S = "${WORKDIR}/git"
16FLOATABI = "${@bb.utils.contains("TUNE_FEATURES", "vfp", bb.utils.contains("TUNE_FEATURES", "callconvention-hard", " -mfloat-abi=hard", " -mfloat-abi=softfp", d), "" ,d)}" 16FLOATABI = "${@bb.utils.contains("TUNE_FEATURES", "vfp", bb.utils.contains("TUNE_FEATURES", "callconvention-hard", " -mfloat-abi=hard", " -mfloat-abi=softfp", d), "" ,d)}"
17 17
18do_compile() { 18do_compile() {
19 make CROSS_COMPILE="${TARGET_PREFIX}" CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS} ${FLOATABI}" 19 make CROSS_COMPILE="${TARGET_PREFIX}" CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS} ${FLOATABI} ${SECURITY_NOPIE_CFLAGS}"
20} 20}
21 21
22do_install() { 22do_install() {