summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngela Stegmaier <angelabaker@ti.com>2020-04-16 00:13:56 +0000
committerDenys Dmytriyenko <denys@ti.com>2020-04-15 18:22:07 +0000
commit9852e8586671cd4eb67f002c2edd74e9ce0c4853 (patch)
tree7f29db23878d2341dab820dd7cd9c70a650bb241
parent783139bb9cbb89d96ec5495389bcff16faf56d35 (diff)
downloadmeta-ti-9852e8586671cd4eb67f002c2edd74e9ce0c4853.tar.gz
ipc-lld: Update examples to build only select examples
Full build of all examples is not needed. Update the recipe to build only selected examples. Signed-off-by: Angela Stegmaier <angelabaker@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/ipc-lld/ipc-lld-examples-rtos_git.bb21
-rw-r--r--recipes-bsp/ipc-lld/ipc-lld.inc2
2 files changed, 20 insertions, 3 deletions
diff --git a/recipes-bsp/ipc-lld/ipc-lld-examples-rtos_git.bb b/recipes-bsp/ipc-lld/ipc-lld-examples-rtos_git.bb
index 8defbac1..b9958f1d 100644
--- a/recipes-bsp/ipc-lld/ipc-lld-examples-rtos_git.bb
+++ b/recipes-bsp/ipc-lld/ipc-lld-examples-rtos_git.bb
@@ -12,6 +12,7 @@ REMOTE_FWB_BIN_DIR = "${REMOTE_FW_DIR}/ipc_echo_testb/bin"
12RTOS_ALL_CORES_BIN_DIR = "${REMOTE_FW_DIR}/ex02_bios_multicore_echo_test/bin" 12RTOS_ALL_CORES_BIN_DIR = "${REMOTE_FW_DIR}/ex02_bios_multicore_echo_test/bin"
13RTOS_2_CORES_BIN_DIR = "${REMOTE_FW_DIR}/ex01_bios_2core_echo_test/bin" 13RTOS_2_CORES_BIN_DIR = "${REMOTE_FW_DIR}/ex01_bios_2core_echo_test/bin"
14LINUX_2_CORES_BIN_DIR = "${REMOTE_FW_DIR}/ex03_linux_bios_2core_echo_test/bin" 14LINUX_2_CORES_BIN_DIR = "${REMOTE_FW_DIR}/ex03_linux_bios_2core_echo_test/bin"
15LINUX_2_CORES_BAREMETAL_BIN_DIR = "${REMOTE_FW_DIR}/ex04_linux_baremetal_2core_echo_test/bin"
15 16
16DST_BIN_PATH = "${base_libdir}/firmware/pdk-ipc" 17DST_BIN_PATH = "${base_libdir}/firmware/pdk-ipc"
17 18
@@ -20,9 +21,21 @@ TI_PDK_LIMIT_BOARDS_j7-evm = "j721e_evm"
20do_configure[noexec] = "1" 21do_configure[noexec] = "1"
21 22
22do_compile() { 23do_compile() {
23 cd ${S} 24 cd "${PDK_INSTALL_PATH}/ti/build"
24 25
25 oe_runmake apps LIMIT_BOARDS="${TI_PDK_LIMIT_BOARDS}" LIMIT_CORES="${TI_PDK_LIMIT_CORES}" DEST_ROOT=${REMOTE_FW_DIR} 26 for board in ${TI_PDK_LIMIT_BOARDS}
27 do
28 for core in ${TI_PDK_LIMIT_CORES}
29 do
30 oe_runmake ipc_echo_test BOARD="$board" CORE="$core" DEST_ROOT=${REMOTE_FW_DIR}
31 oe_runmake ex02_bios_multicore_echo_test BOARD="$board" CORE="$core" DEST_ROOT=${REMOTE_FW_DIR}
32 oe_runmake ex01_bios_2core_echo_test BOARD="$board" CORE="$core" DEST_ROOT=${REMOTE_FW_DIR}
33 oe_runmake ex03_linux_bios_2core_echo_test BOARD="$board" CORE="$core" DEST_ROOT=${REMOTE_FW_DIR}
34 oe_runmake ex04_linux_baremetal_2core_echo_test BOARD="$board" CORE="$core" DEST_ROOT=${REMOTE_FW_DIR}
35 oe_runmake ipc_echo_testb BOARD="$board" CORE="$core" DEST_ROOT=${REMOTE_FW_DIR}
36 done
37
38 done
26} 39}
27 40
28do_install() { 41do_install() {
@@ -66,6 +79,9 @@ do_install_append_j7-evm() {
66 install -m 0644 ${REMOTE_FWB_BIN_DIR}/$board/ipc_echo_testb_mcu3_1_release_strip.xer5f ${D}${DST_BIN_PATH} 79 install -m 0644 ${REMOTE_FWB_BIN_DIR}/$board/ipc_echo_testb_mcu3_1_release_strip.xer5f ${D}${DST_BIN_PATH}
67} 80}
68 81
82do_install_append_am65xx-evm() {
83 cp ${CP_ARGS} ${REMOTE_FW_DIR}/ex04_linux_baremetal_2core_echo_test/bin -d ${D}/ex04_linux_baremetal_2core_echo_test
84}
69 85
70# Set up names for the firmwares 86# Set up names for the firmwares
71ALTERNATIVE_${PN}_am65xx = "\ 87ALTERNATIVE_${PN}_am65xx = "\
@@ -138,6 +154,7 @@ FILES_${PN} += "${base_libdir}/firmware"
138FILES_${PN}-rtos += "ex02_bios_multicore_echo_test" 154FILES_${PN}-rtos += "ex02_bios_multicore_echo_test"
139FILES_${PN}-rtos += "ex01_bios_2core_echo_test" 155FILES_${PN}-rtos += "ex01_bios_2core_echo_test"
140FILES_${PN}-rtos += "ex03_linux_bios_2core_echo_test" 156FILES_${PN}-rtos += "ex03_linux_bios_2core_echo_test"
157FILES_${PN}-rtos += "ex04_linux_baremetal_2core_echo_test"
141 158
142INSANE_SKIP_${PN} = "arch ldflags file-rdeps" 159INSANE_SKIP_${PN} = "arch ldflags file-rdeps"
143INSANE_SKIP_${PN}-rtos = "arch ldflags file-rdeps" 160INSANE_SKIP_${PN}-rtos = "arch ldflags file-rdeps"
diff --git a/recipes-bsp/ipc-lld/ipc-lld.inc b/recipes-bsp/ipc-lld/ipc-lld.inc
index f271f31d..2aea055f 100644
--- a/recipes-bsp/ipc-lld/ipc-lld.inc
+++ b/recipes-bsp/ipc-lld/ipc-lld.inc
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=7eae093f2b09fd39307f30028a068b91"
10COMPATIBLE_MACHINE = "k3" 10COMPATIBLE_MACHINE = "k3"
11PACKAGE_ARCH = "${MACHINE_ARCH}" 11PACKAGE_ARCH = "${MACHINE_ARCH}"
12 12
13PR = "r3" 13PR = "r4"
14 14
15# Build with make instead of XDC 15# Build with make instead of XDC
16TI_PDK_XDCMAKE = "0" 16TI_PDK_XDCMAKE = "0"