summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMahesh Radhakrishnan <m-radhakrishnan2@ti.com>2020-03-11 00:33:05 +0000
committerDenys Dmytriyenko <denys@ti.com>2020-03-10 21:04:06 +0000
commit96202061bd81674e13ec8171f3a492a538a0a926 (patch)
tree849ec97746e5edc808e556e66f2e260959e85b69
parentf4ea535d278eb41271c4abe91efedf8b8cb9e94d (diff)
downloadmeta-ti-96202061bd81674e13ec8171f3a492a538a0a926.tar.gz
sciclient-rtos: SRCREV update, adding steps to generate sysfw.bin
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/sciclient/sciclient-rtos_git.bb37
1 files changed, 36 insertions, 1 deletions
diff --git a/recipes-bsp/sciclient/sciclient-rtos_git.bb b/recipes-bsp/sciclient/sciclient-rtos_git.bb
index a5aacd9f..3627cbc7 100644
--- a/recipes-bsp/sciclient/sciclient-rtos_git.bb
+++ b/recipes-bsp/sciclient/sciclient-rtos_git.bb
@@ -14,7 +14,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
14 14
15PR = "r1" 15PR = "r1"
16 16
17DEPENDS_append = " osal-rtos common-csl-ip-rtos" 17DEPENDS_append = " osal-rtos common-csl-ip-rtos openssl-native"
18 18
19# Build with make instead of XDC 19# Build with make instead of XDC
20TI_PDK_XDCMAKE = "0" 20TI_PDK_XDCMAKE = "0"
@@ -60,6 +60,41 @@ do_compile() {
60 tar -cf sciclient.tar --exclude='*.tar' ./* 60 tar -cf sciclient.tar --exclude='*.tar' ./*
61} 61}
62 62
63
64do_compile_prepend_am65xx-hs-evm() {
65
66 cd ${SCICLIENT_ROOTPATH}
67
68 # Saving the GP firmware to a different GP name
69 cp ${CP_ARGS} ./soc/V0/sysfw.bin ./soc/V0/sysfw-gp.bin
70
71 cd ${SCICLIENT_ROOTPATH}/tools
72 # Create the .bin file for HS
73 ${SCICLIENT_ROOTPATH}/tools/firmwareHeaderGen.sh am65x-hs ${PDK_INSTALL_DIR}/packages
74 cd -
75}
76
77do_compile_prepend_am65xx-evm() {
78
79 cd ${SCICLIENT_ROOTPATH}/tools
80
81 # Create the .bin file for GP, PG1
82 ${SCICLIENT_ROOTPATH}/tools/firmwareHeaderGen.sh am65x ${PDK_INSTALL_DIR}/packages
83 # Create the .bin file for GP, PG2
84 ${SCICLIENT_ROOTPATH}/tools/firmwareHeaderGen.sh am65x_pg2 ${PDK_INSTALL_DIR}/packages
85
86 cd -
87}
88
89
90do_compile_prepend_j7-evm() {
91
92 cd ${SCICLIENT_ROOTPATH}/tools
93 # Create the .bin file for GP
94 ${SCICLIENT_ROOTPATH}/tools/firmwareHeaderGen.sh j721e ${PDK_INSTALL_DIR}/packages
95 cd -
96}
97
63do_install() { 98do_install() {
64 cd ${SCICLIENT_ROOTPATH} 99 cd ${SCICLIENT_ROOTPATH}
65 install -d ${D}${PDK_INSTALL_DIR_RECIPE}/packages/ti/drv/sciclient 100 install -d ${D}${PDK_INSTALL_DIR_RECIPE}/packages/ti/drv/sciclient