diff options
author | Gou, Hongmei <h-gou@ti.com> | 2017-06-27 00:25:41 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2017-06-27 11:51:11 -0400 |
commit | 508101b378aee98634843be88ee40bb1bc0e60f7 (patch) | |
tree | b9abea250636a5e56d59518453f2808d07a88286 | |
parent | d64dff779559d15a2cfa68725628d4ed1db5490b (diff) | |
download | meta-ti-508101b378aee98634843be88ee40bb1bc0e60f7.tar.gz |
uio-module-drv*: version bump to 2.2.0 and add test support for am3/am4
* Also defined variables in .inc for GIT SRC_URI parameters
Signed-off-by: Hongmei Gou <h-gou@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r-- | recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb | 14 | ||||
-rw-r--r-- | recipes-bsp/uio-module-drv/uio-module-drv.inc | 12 |
2 files changed, 20 insertions, 6 deletions
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb b/recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb index 8303efe1..2e3bb917 100644 --- a/recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb +++ b/recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb | |||
@@ -2,12 +2,14 @@ DESCRIPTION = "Test code for user space IO (UIO) driver" | |||
2 | 2 | ||
3 | include uio-module-drv.inc | 3 | include uio-module-drv.inc |
4 | 4 | ||
5 | PR = "r2" | 5 | PR = "r3" |
6 | 6 | ||
7 | COMPATIBLE_MACHINE = "keystone|omap-a15" | 7 | COMPATIBLE_MACHINE = "keystone|omap-a15|ti33x|ti43x" |
8 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 8 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
9 | 9 | ||
10 | DEVICE_NAME_omap-a15 = "am57xx" | 10 | DEVICE_NAME_omap-a15 = "am57xx" |
11 | DEVICE_NAME_ti33x = "am33xx" | ||
12 | DEVICE_NAME_ti43x = "am43xx" | ||
11 | DEVICE_NAME_keystone = "keystone" | 13 | DEVICE_NAME_keystone = "keystone" |
12 | RDEPENDS_${PN} = "uio-module-drv" | 14 | RDEPENDS_${PN} = "uio-module-drv" |
13 | 15 | ||
@@ -28,3 +30,11 @@ do_install_append_keystone () { | |||
28 | do_install_append_omap-a15 () { | 30 | do_install_append_omap-a15 () { |
29 | install -c -m 755 ${S}/test/prussdrv_test/test/pruss_uio_test ${D}${bindir}/. | 31 | install -c -m 755 ${S}/test/prussdrv_test/test/pruss_uio_test ${D}${bindir}/. |
30 | } | 32 | } |
33 | |||
34 | do_install_append_ti33x () { | ||
35 | install -c -m 755 ${S}/test/prussdrv_test/test/pruss_uio_test ${D}${bindir}/. | ||
36 | } | ||
37 | |||
38 | do_install_append_ti43x () { | ||
39 | install -c -m 755 ${S}/test/prussdrv_test/test/pruss_uio_test ${D}${bindir}/. | ||
40 | } | ||
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv.inc b/recipes-bsp/uio-module-drv/uio-module-drv.inc index 88eab765..6d55db21 100644 --- a/recipes-bsp/uio-module-drv/uio-module-drv.inc +++ b/recipes-bsp/uio-module-drv/uio-module-drv.inc | |||
@@ -2,11 +2,15 @@ LICENSE = "BSD" | |||
2 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2b7c96eb2aed7b0f6f922214dbde9016" | 2 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2b7c96eb2aed7b0f6f922214dbde9016" |
3 | 3 | ||
4 | BRANCH = "master" | 4 | BRANCH = "master" |
5 | # This corresponds to version 02.01.00.00 | 5 | # This corresponds to version 02.02.00.00 |
6 | SRCREV = "19761495883bf8fb2670b0929d255135bd295dcb" | 6 | UIO_MODULE_DRV_SRCREV = "59cd07395d7f26cbd01969d130d7b8bd5ccb12c5" |
7 | 7 | ||
8 | PV = "2.1.0.0+git${SRCPV}" | 8 | PV = "2.2.0.0+git${SRCPV}" |
9 | 9 | ||
10 | SRC_URI = "git://git.ti.com/keystone-linux/uio-module-drv.git;protocol=git;branch=${BRANCH}" | 10 | UIO_MODULE_DRV_GIT_URI = "git://git.ti.com/keystone-linux/uio-module-drv.git" |
11 | UIO_MODULE_DRV_GIT_PROTOCOL = "git" | ||
12 | SRC_URI = "${UIO_MODULE_DRV_GIT_URI};protocol=${UIO_MODULE_DRV_GIT_PROTOCOL};branch=${BRANCH}" | ||
13 | |||
14 | SRCREV = "${UIO_MODULE_DRV_SRCREV}" | ||
11 | 15 | ||
12 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |