summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2020-02-18 00:42:51 +0000
committerDenys Dmytriyenko <denys@ti.com>2020-02-17 18:25:44 +0000
commit1e9dde5af91990f9d28092fcf300dd3d69bed451 (patch)
treee2000c44a0f61c58a5a93c75c1a46afbe6054bd2
parentff8621e0fa18175ba6614f7de885d5be85941239 (diff)
downloadmeta-ti-1e9dde5af91990f9d28092fcf300dd3d69bed451.tar.gz
multiprocmgr: update to latest, drop upstreamed patches
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr-test_git.bb7
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr.inc4
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch27
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-suppress-kernel-linux-types.h-inclus.patch28
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr_git.bb2
5 files changed, 2 insertions, 66 deletions
diff --git a/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb b/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb
index aab8ae6c..7c3f9e1b 100644
--- a/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb
+++ b/recipes-ti/multiprocmgr/multiprocmgr-test_git.bb
@@ -1,14 +1,7 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/multiprocmgr:"
2
3SUMMARY = "TI Multiproc Manager test code" 1SUMMARY = "TI Multiproc Manager test code"
4 2
5include multiprocmgr.inc 3include multiprocmgr.inc
6 4
7SRC_URI += " \
8 file://0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch \
9 file://0001-mpmdlif.c-don-t-suppress-kernel-linux-types.h-inclus.patch \
10"
11
12PR = "${INC_PR}.2" 5PR = "${INC_PR}.2"
13 6
14DEPENDS = "multiprocmgr cmem" 7DEPENDS = "multiprocmgr cmem"
diff --git a/recipes-ti/multiprocmgr/multiprocmgr.inc b/recipes-ti/multiprocmgr/multiprocmgr.inc
index 40a20af9..64fb6f6f 100644
--- a/recipes-ti/multiprocmgr/multiprocmgr.inc
+++ b/recipes-ti/multiprocmgr/multiprocmgr.inc
@@ -9,10 +9,10 @@ MULTIPROCMGR_GIT_PROTOCOL = "git"
9MULTIPROCMGR_GIT_BRANCH = "master" 9MULTIPROCMGR_GIT_BRANCH = "master"
10 10
11# The following commits correspond to DEV.MPM-3.00.05.00 11# The following commits correspond to DEV.MPM-3.00.05.00
12MULTIPROCMGR_SRCREV = "f7fb3b7c21b3f6dd8b4adeef5df5be1824b9be73" 12MULTIPROCMGR_SRCREV = "810d8a31c797d07abe808cb3fa89465fa934d4dd"
13 13
14PV = "3.0.5.0" 14PV = "3.0.5.0"
15INC_PR = "r0" 15INC_PR = "r1"
16 16
17BRANCH = "${MULTIPROCMGR_GIT_BRANCH}" 17BRANCH = "${MULTIPROCMGR_GIT_BRANCH}"
18SRC_URI = "${MULTIPROCMGR_GIT_URI};protocol=${MULTIPROCMGR_GIT_PROTOCOL};branch=${BRANCH}" 18SRC_URI = "${MULTIPROCMGR_GIT_URI};protocol=${MULTIPROCMGR_GIT_PROTOCOL};branch=${BRANCH}"
diff --git a/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch b/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch
deleted file mode 100644
index 25deedcc..00000000
--- a/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch
+++ /dev/null
@@ -1,27 +0,0 @@
1From 17c307ff6e67af43f243366baa2ccc01f89cdddd Mon Sep 17 00:00:00 2001
2From: Denys Dmytriyenko <denys@ti.com>
3Date: Mon, 23 Apr 2018 15:35:44 -0400
4Subject: [PATCH] mpmdlif.c: don't hardcode kernel's "uapi" location
5 keystone_remoteproc.h
6
7Signed-off-by: Denys Dmytriyenko <denys@ti.com>
8---
9 src/daemon/mpmdlif.c | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/src/daemon/mpmdlif.c b/src/daemon/mpmdlif.c
13index 0c31604..d287bbc 100644
14--- a/src/daemon/mpmdlif.c
15+++ b/src/daemon/mpmdlif.c
16@@ -47,7 +47,7 @@
17 #include <stdint.h>
18
19 #define _LINUX_TYPES_H
20-#include "uapi/linux/keystone_remoteproc.h"
21+#include "linux/keystone_remoteproc.h"
22 #include "internal/rsc_types.h"
23 //#include <elf.h>
24 // #define LOADER_DEBUG
25--
262.7.4
27
diff --git a/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-suppress-kernel-linux-types.h-inclus.patch b/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-suppress-kernel-linux-types.h-inclus.patch
deleted file mode 100644
index c3315cfc..00000000
--- a/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-suppress-kernel-linux-types.h-inclus.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From 95921ccf77ae037bb3b95f45a632f60975c6c9bb Mon Sep 17 00:00:00 2001
2From: Denys Dmytriyenko <denys@ti.com>
3Date: Tue, 11 Feb 2020 17:03:18 -0500
4Subject: [PATCH] mpmdlif.c: don't suppress kernel <linux/types.h> inclusion
5
6Defining _LINUX_TYPES_H before including <linux/keystone_remoteproc.h> causes
7<linux/types.h> to skip defining kernel types, resulting in undefined __u32
8
9Signed-off-by: Denys Dmytriyenko <denys@ti.com>
10---
11 src/daemon/mpmdlif.c | 1 -
12 1 file changed, 1 deletion(-)
13
14diff --git a/src/daemon/mpmdlif.c b/src/daemon/mpmdlif.c
15index 0c31604..1abd00f 100644
16--- a/src/daemon/mpmdlif.c
17+++ b/src/daemon/mpmdlif.c
18@@ -46,7 +46,6 @@
19 #include <byteswap.h>
20 #include <stdint.h>
21
22-#define _LINUX_TYPES_H
23 #include "linux/keystone_remoteproc.h"
24 #include "internal/rsc_types.h"
25 //#include <elf.h>
26--
272.7.4
28
diff --git a/recipes-ti/multiprocmgr/multiprocmgr_git.bb b/recipes-ti/multiprocmgr/multiprocmgr_git.bb
index b3479fb9..07512603 100644
--- a/recipes-ti/multiprocmgr/multiprocmgr_git.bb
+++ b/recipes-ti/multiprocmgr/multiprocmgr_git.bb
@@ -5,8 +5,6 @@ include multiprocmgr.inc
5 5
6SRC_URI += " \ 6SRC_URI += " \
7 file://mpmsrv-daemon.service \ 7 file://mpmsrv-daemon.service \
8 file://0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch \
9 file://0001-mpmdlif.c-don-t-suppress-kernel-linux-types.h-inclus.patch \
10" 8"
11 9
12PR = "${INC_PR}.2" 10PR = "${INC_PR}.2"