summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2020-04-28 19:14:04 -0400
committerDenys Dmytriyenko <denys@ti.com>2020-04-28 23:43:06 +0000
commit8db3352b80b934029306f9404625414555a62b4e (patch)
tree83e280d0457e1e82fc22a71ef24b14f6cf17468d
parente53bcaf45c1d984cffb579c3a557e56f6d95675b (diff)
downloadmeta-ti-8db3352b80b934029306f9404625414555a62b4e.tar.gz
linux-ti-staging: update to 5.4.34
Also drop backported perf patch. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-kernel/linux/files/0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch60
-rw-r--r--recipes-kernel/linux/linux-ti-staging-rt_5.4.bb4
-rw-r--r--recipes-kernel/linux/linux-ti-staging_5.4.bb5
3 files changed, 4 insertions, 65 deletions
diff --git a/recipes-kernel/linux/files/0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch b/recipes-kernel/linux/files/0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch
deleted file mode 100644
index f5220a86..00000000
--- a/recipes-kernel/linux/files/0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch
+++ /dev/null
@@ -1,60 +0,0 @@
1From 0ada120c883d4f1f6aafd01cf0fbb10d8bbba015 Mon Sep 17 00:00:00 2001
2From: Changbin Du <changbin.du@gmail.com>
3Date: Tue, 28 Jan 2020 23:29:38 +0800
4Subject: [PATCH] perf: Make perf able to build with latest libbfd
5
6libbfd has changed the bfd_section_* macros to inline functions
7bfd_section_<field> since 2019-09-18. See below two commits:
8 o http://www.sourceware.org/ml/gdb-cvs/2019-09/msg00064.html
9 o https://www.sourceware.org/ml/gdb-cvs/2019-09/msg00072.html
10
11This fix make perf able to build with both old and new libbfd.
12
13Signed-off-by: Changbin Du <changbin.du@gmail.com>
14Acked-by: Jiri Olsa <jolsa@redhat.com>
15Cc: Peter Zijlstra <peterz@infradead.org>
16Link: http://lore.kernel.org/lkml/20200128152938.31413-1-changbin.du@gmail.com
17Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
18---
19 tools/perf/util/srcline.c | 16 +++++++++++++++-
20 1 file changed, 15 insertions(+), 1 deletion(-)
21
22diff --git a/tools/perf/util/srcline.c b/tools/perf/util/srcline.c
23index 6ccf6f6..5b7d6c1 100644
24--- a/tools/perf/util/srcline.c
25+++ b/tools/perf/util/srcline.c
26@@ -193,16 +193,30 @@ static void find_address_in_section(bfd *abfd, asection *section, void *data)
27 bfd_vma pc, vma;
28 bfd_size_type size;
29 struct a2l_data *a2l = data;
30+ flagword flags;
31
32 if (a2l->found)
33 return;
34
35- if ((bfd_get_section_flags(abfd, section) & SEC_ALLOC) == 0)
36+#ifdef bfd_get_section_flags
37+ flags = bfd_get_section_flags(abfd, section);
38+#else
39+ flags = bfd_section_flags(section);
40+#endif
41+ if ((flags & SEC_ALLOC) == 0)
42 return;
43
44 pc = a2l->addr;
45+#ifdef bfd_get_section_vma
46 vma = bfd_get_section_vma(abfd, section);
47+#else
48+ vma = bfd_section_vma(section);
49+#endif
50+#ifdef bfd_get_section_size
51 size = bfd_get_section_size(section);
52+#else
53+ size = bfd_section_size(section);
54+#endif
55
56 if (pc < vma || pc >= vma + size)
57 return;
58--
592.7.4
60
diff --git a/recipes-kernel/linux/linux-ti-staging-rt_5.4.bb b/recipes-kernel/linux/linux-ti-staging-rt_5.4.bb
index 7bce9394..a0c5fd19 100644
--- a/recipes-kernel/linux/linux-ti-staging-rt_5.4.bb
+++ b/recipes-kernel/linux/linux-ti-staging-rt_5.4.bb
@@ -6,5 +6,5 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-5.4:"
6 6
7BRANCH = "ti-rt-linux-5.4.y" 7BRANCH = "ti-rt-linux-5.4.y"
8 8
9SRCREV = "c19c1f9f817e15b923c18a22b218024788627692" 9SRCREV = "e62f2659b5254a7fcdaad8f5a7705040ccaadeae"
10PV = "5.4.28+git${SRCPV}" 10PV = "5.4.34+git${SRCPV}"
diff --git a/recipes-kernel/linux/linux-ti-staging_5.4.bb b/recipes-kernel/linux/linux-ti-staging_5.4.bb
index 5c0f06b7..1a53decc 100644
--- a/recipes-kernel/linux/linux-ti-staging_5.4.bb
+++ b/recipes-kernel/linux/linux-ti-staging_5.4.bb
@@ -60,8 +60,8 @@ S = "${WORKDIR}/git"
60 60
61BRANCH = "ti-linux-5.4.y" 61BRANCH = "ti-linux-5.4.y"
62 62
63SRCREV = "30623f353f82825846b4086004845ee859b1e992" 63SRCREV = "2050bb49c5732e34cc2372ad9c9879b6d485d556"
64PV = "5.4.28+git${SRCPV}" 64PV = "5.4.34+git${SRCPV}"
65 65
66# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild 66# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
67MACHINE_KERNEL_PR_append = "a" 67MACHINE_KERNEL_PR_append = "a"
@@ -70,7 +70,6 @@ PR = "${MACHINE_KERNEL_PR}"
70KERNEL_GIT_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git" 70KERNEL_GIT_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-kernel.git"
71KERNEL_GIT_PROTOCOL = "git" 71KERNEL_GIT_PROTOCOL = "git"
72SRC_URI += "${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH} \ 72SRC_URI += "${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH} \
73 file://0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch \
74 file://defconfig" 73 file://defconfig"
75 74
76FILES_${KERNEL_PACKAGE_NAME}-devicetree += "/${KERNEL_IMAGEDEST}/*.itb" 75FILES_${KERNEL_PACKAGE_NAME}-devicetree += "/${KERNEL_IMAGEDEST}/*.itb"