summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2015-05-21 07:56:22 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-05-21 11:11:06 -0400
commitfef30ea1bf5c55bf46d5c6a0caa87d19191c5ebf (patch)
treead28bde634f7f8380b5f76fc21af569139d29e18
parente7601086a4db4dbbb93b50251642794314b8e46f (diff)
downloadmeta-ti-fef30ea1bf5c55bf46d5c6a0caa87d19191c5ebf.tar.gz
recipes: move SRCPV from PR to PV, so PRServ can package AUTOINC after patching
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/boot-monitor/boot-monitor_git.bb4
-rw-r--r--recipes-bsp/cmem/cmem-mod_git.bb2
-rw-r--r--recipes-bsp/cmem/cmem.inc2
-rw-r--r--recipes-bsp/cmem/cmem_git.bb2
-rw-r--r--recipes-bsp/hplib/hplib-mod_git.bb2
-rw-r--r--recipes-bsp/hplib/hplib.inc2
-rw-r--r--recipes-bsp/pru/ti-pru-sw-edma-driver_1.00.00.bb3
-rw-r--r--recipes-bsp/ti-ocf-crypto-module/ti-ocf-crypto-module_1.0.bb3
-rw-r--r--recipes-bsp/u-boot/u-boot-am33x_2013.01.01.bb3
-rw-r--r--recipes-bsp/u-boot/u-boot-glsdk_2013.01.01.bb3
-rw-r--r--recipes-bsp/u-boot/u-boot-keystone_2013.01.bb3
-rw-r--r--recipes-bsp/u-boot/u-boot-ti-staging_2013.01.01.bb3
-rw-r--r--recipes-bsp/u-boot/u-boot-ti-staging_2013.10.bb4
-rw-r--r--recipes-bsp/u-boot/u-boot-ti-staging_2014.07.bb4
-rw-r--r--recipes-bsp/u-boot/u-boot_2014.07.bb2
-rw-r--r--recipes-bsp/uio-module-drv/uio-module-drv_git.bb4
-rw-r--r--recipes-kernel/linux/linux-keystone-rt_3.10.bb4
-rw-r--r--recipes-kernel/linux/linux-keystone_3.10.bb4
-rw-r--r--recipes-kernel/linux/linux-keystone_3.13.bb4
-rw-r--r--recipes-kernel/linux/linux-ti-glsdk_3.8.bb4
-rw-r--r--recipes-kernel/linux/linux-ti-staging_3.12.bb4
-rw-r--r--recipes-kernel/linux/linux-ti-staging_3.14.bb4
-rw-r--r--recipes-kernel/linux/sitara-linux-ti-staging_3.14.bb4
23 files changed, 40 insertions, 34 deletions
diff --git a/recipes-bsp/boot-monitor/boot-monitor_git.bb b/recipes-bsp/boot-monitor/boot-monitor_git.bb
index 72dc9241..678e99c3 100644
--- a/recipes-bsp/boot-monitor/boot-monitor_git.bb
+++ b/recipes-bsp/boot-monitor/boot-monitor_git.bb
@@ -6,8 +6,8 @@ COMPATIBLE_MACHINE = "keystone"
6 6
7SRC_URI = "git://git.ti.com/keystone-linux/boot-monitor.git;protocol=git;branch=${BRANCH}" 7SRC_URI = "git://git.ti.com/keystone-linux/boot-monitor.git;protocol=git;branch=${BRANCH}"
8 8
9PV = "2.0" 9PV = "2.0+git${SRCPV}"
10PR = "r2+gitr${SRCPV}" 10PR = "r2"
11 11
12BRANCH = "master" 12BRANCH = "master"
13 13
diff --git a/recipes-bsp/cmem/cmem-mod_git.bb b/recipes-bsp/cmem/cmem-mod_git.bb
index 0cc0b464..b36eb096 100644
--- a/recipes-bsp/cmem/cmem-mod_git.bb
+++ b/recipes-bsp/cmem/cmem-mod_git.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Kernel module for contiguous memory allocation from userspace"
3include cmem.inc 3include cmem.inc
4 4
5# This package builds a kernel module, use kernel PR as base and append a local 5# This package builds a kernel module, use kernel PR as base and append a local
6MACHINE_KERNEL_PR_append = "b+gitr${SRCPV}" 6MACHINE_KERNEL_PR_append = "b"
7PR = "${MACHINE_KERNEL_PR}" 7PR = "${MACHINE_KERNEL_PR}"
8 8
9inherit module 9inherit module
diff --git a/recipes-bsp/cmem/cmem.inc b/recipes-bsp/cmem/cmem.inc
index ff7a8a04..bbb86b05 100644
--- a/recipes-bsp/cmem/cmem.inc
+++ b/recipes-bsp/cmem/cmem.inc
@@ -7,6 +7,8 @@ BRANCH ?= "master"
7# This corresponds to version 4.10.00.01 7# This corresponds to version 4.10.00.01
8SRCREV = "0d2fac7187ca1f6af62a98dee5b3621908cf5831" 8SRCREV = "0d2fac7187ca1f6af62a98dee5b3621908cf5831"
9 9
10PV = "4.10.00.01+git${SRCPV}"
11
10SRC_URI = "git://git.ti.com/ipc/ludev.git;protocol=git;branch=${BRANCH}" 12SRC_URI = "git://git.ti.com/ipc/ludev.git;protocol=git;branch=${BRANCH}"
11 13
12S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
diff --git a/recipes-bsp/cmem/cmem_git.bb b/recipes-bsp/cmem/cmem_git.bb
index 540c2f63..b30029d6 100644
--- a/recipes-bsp/cmem/cmem_git.bb
+++ b/recipes-bsp/cmem/cmem_git.bb
@@ -4,7 +4,7 @@ include cmem.inc
4 4
5RDEPENDS_${PN} = "cmem-mod" 5RDEPENDS_${PN} = "cmem-mod"
6 6
7PR = "r1+gitr${SRCPV}" 7PR = "r1"
8 8
9PACKAGES =+ "${PN}-test" 9PACKAGES =+ "${PN}-test"
10 10
diff --git a/recipes-bsp/hplib/hplib-mod_git.bb b/recipes-bsp/hplib/hplib-mod_git.bb
index acef1ce5..6603a2eb 100644
--- a/recipes-bsp/hplib/hplib-mod_git.bb
+++ b/recipes-bsp/hplib/hplib-mod_git.bb
@@ -7,7 +7,7 @@ DEPENDS = "hplib"
7include hplib.inc 7include hplib.inc
8 8
9# This package builds a kernel module, use kernel PR as base and append a local 9# This package builds a kernel module, use kernel PR as base and append a local
10MACHINE_KERNEL_PR_append = "a+gitr${SRCPV}" 10MACHINE_KERNEL_PR_append = "a"
11PR = "${MACHINE_KERNEL_PR}" 11PR = "${MACHINE_KERNEL_PR}"
12 12
13S ="${WORKDIR}/git/ti/runtime/hplib/module" 13S ="${WORKDIR}/git/ti/runtime/hplib/module"
diff --git a/recipes-bsp/hplib/hplib.inc b/recipes-bsp/hplib/hplib.inc
index de5b2b7a..b3a62b82 100644
--- a/recipes-bsp/hplib/hplib.inc
+++ b/recipes-bsp/hplib/hplib.inc
@@ -7,4 +7,4 @@ SRC_URI = "git://git.ti.com/keystone-rtos/hplib.git;protocol=git;branch=${BRANCH
7 7
8# Below Commit ID corresponds to "DEV.HPLIB.01.01.00.05" 8# Below Commit ID corresponds to "DEV.HPLIB.01.01.00.05"
9SRCREV = "97c2ce177c78c0f7a861c8dc9ac10657d85eae36" 9SRCREV = "97c2ce177c78c0f7a861c8dc9ac10657d85eae36"
10PV = "01.01.00.05" 10PV = "01.01.00.05+git${SRCPV}"
diff --git a/recipes-bsp/pru/ti-pru-sw-edma-driver_1.00.00.bb b/recipes-bsp/pru/ti-pru-sw-edma-driver_1.00.00.bb
index 1a418d7c..a837b356 100644
--- a/recipes-bsp/pru/ti-pru-sw-edma-driver_1.00.00.bb
+++ b/recipes-bsp/pru/ti-pru-sw-edma-driver_1.00.00.bb
@@ -7,8 +7,9 @@ COMPATIBLE_MACHINE = "omapl138"
7 7
8INHIBIT_PACKAGE_STRIP = "1" 8INHIBIT_PACKAGE_STRIP = "1"
9 9
10MACHINE_KERNEL_PR_append = "b+svnr${SRCPV}" 10MACHINE_KERNEL_PR_append = "b"
11PR = "${MACHINE_KERNEL_PR}" 11PR = "${MACHINE_KERNEL_PR}"
12PV_append = "+svn${SRCPV}"
12 13
13SRC_URI = "svn://gforge.ti.com/svn/pru_sw/;module=trunk;protocol=https;user=anonymous;pswd=''" 14SRC_URI = "svn://gforge.ti.com/svn/pru_sw/;module=trunk;protocol=https;user=anonymous;pswd=''"
14 15
diff --git a/recipes-bsp/ti-ocf-crypto-module/ti-ocf-crypto-module_1.0.bb b/recipes-bsp/ti-ocf-crypto-module/ti-ocf-crypto-module_1.0.bb
index ad1d5efb..43eed7d1 100644
--- a/recipes-bsp/ti-ocf-crypto-module/ti-ocf-crypto-module_1.0.bb
+++ b/recipes-bsp/ti-ocf-crypto-module/ti-ocf-crypto-module_1.0.bb
@@ -19,8 +19,9 @@ S = "${WORKDIR}/trunk"
19 19
20inherit module 20inherit module
21 21
22MACHINE_KERNEL_PR_append = "b+svnr${SRCPV}" 22MACHINE_KERNEL_PR_append = "b"
23PR = "${MACHINE_KERNEL_PR}" 23PR = "${MACHINE_KERNEL_PR}"
24PV_append = "+svn${SRCPV}"
24 25
25EXTRA_OEMAKE += "KERNEL_DIR=${STAGING_KERNEL_DIR}" 26EXTRA_OEMAKE += "KERNEL_DIR=${STAGING_KERNEL_DIR}"
26 27
diff --git a/recipes-bsp/u-boot/u-boot-am33x_2013.01.01.bb b/recipes-bsp/u-boot/u-boot-am33x_2013.01.01.bb
index cb2e850e..8f805bc8 100644
--- a/recipes-bsp/u-boot/u-boot-am33x_2013.01.01.bb
+++ b/recipes-bsp/u-boot/u-boot-am33x_2013.01.01.bb
@@ -6,7 +6,8 @@ COMPATIBLE_MACHINE = "ti33x"
6 6
7DEFAULT_PREFERENCE = "-1" 7DEFAULT_PREFERENCE = "-1"
8 8
9PR = "r6+gitr${SRCPV}" 9PR = "r6"
10PV_append = "+git${SRCPV}"
10 11
11SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}" 12SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}"
12 13
diff --git a/recipes-bsp/u-boot/u-boot-glsdk_2013.01.01.bb b/recipes-bsp/u-boot/u-boot-glsdk_2013.01.01.bb
index 07df497b..3a22864a 100644
--- a/recipes-bsp/u-boot/u-boot-glsdk_2013.01.01.bb
+++ b/recipes-bsp/u-boot/u-boot-glsdk_2013.01.01.bb
@@ -2,7 +2,8 @@ require u-boot-ti.inc
2 2
3DESCRIPTION = "u-boot bootloader for TI devices supported by the GLSDK product" 3DESCRIPTION = "u-boot bootloader for TI devices supported by the GLSDK product"
4 4
5PR = "r1+gitr${SRCPV}" 5PR = "r1"
6PV_append = "+git${SRCPV}"
6 7
7DEFAULT_PREFERENCE = "-1" 8DEFAULT_PREFERENCE = "-1"
8 9
diff --git a/recipes-bsp/u-boot/u-boot-keystone_2013.01.bb b/recipes-bsp/u-boot/u-boot-keystone_2013.01.bb
index a464d145..80f4c345 100644
--- a/recipes-bsp/u-boot/u-boot-keystone_2013.01.bb
+++ b/recipes-bsp/u-boot/u-boot-keystone_2013.01.bb
@@ -4,7 +4,8 @@ DESCRIPTION = "u-boot bootloader for Multi-Core BU devices"
4 4
5COMPATIBLE_MACHINE = "keystone" 5COMPATIBLE_MACHINE = "keystone"
6 6
7PR = "r5+gitr${SRCPV}" 7PR = "r5"
8PV_append = "+git${SRCPV}"
8 9
9# Tag "K2_UBOOT_2013_01_14.09" 10# Tag "K2_UBOOT_2013_01_14.09"
10SRCREV = "f9bc365551ff8c685bf6134d795576713fec0917" 11SRCREV = "f9bc365551ff8c685bf6134d795576713fec0917"
diff --git a/recipes-bsp/u-boot/u-boot-ti-staging_2013.01.01.bb b/recipes-bsp/u-boot/u-boot-ti-staging_2013.01.01.bb
index ea72e4df..821e9ed7 100644
--- a/recipes-bsp/u-boot/u-boot-ti-staging_2013.01.01.bb
+++ b/recipes-bsp/u-boot/u-boot-ti-staging_2013.01.01.bb
@@ -2,7 +2,8 @@ require u-boot-ti.inc
2 2
3DESCRIPTION = "u-boot bootloader for TI devices" 3DESCRIPTION = "u-boot bootloader for TI devices"
4 4
5PR = "r5+gitr${SRCPV}" 5PR = "r5"
6PV_append = "+git${SRCPV}"
6 7
7SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}" 8SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}"
8 9
diff --git a/recipes-bsp/u-boot/u-boot-ti-staging_2013.10.bb b/recipes-bsp/u-boot/u-boot-ti-staging_2013.10.bb
index d954db47..de44faa5 100644
--- a/recipes-bsp/u-boot/u-boot-ti-staging_2013.10.bb
+++ b/recipes-bsp/u-boot/u-boot-ti-staging_2013.10.bb
@@ -4,8 +4,8 @@ DESCRIPTION = "u-boot bootloader for TI devices"
4 4
5LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb" 5LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
6 6
7PV = "2013.10" 7PR = "r8"
8PR = "r8+gitr${SRCPV}" 8PV_append = "+git${SRCPV}"
9 9
10SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}" 10SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}"
11 11
diff --git a/recipes-bsp/u-boot/u-boot-ti-staging_2014.07.bb b/recipes-bsp/u-boot/u-boot-ti-staging_2014.07.bb
index eff86800..09dfdfa5 100644
--- a/recipes-bsp/u-boot/u-boot-ti-staging_2014.07.bb
+++ b/recipes-bsp/u-boot/u-boot-ti-staging_2014.07.bb
@@ -7,8 +7,8 @@ DESCRIPTION = "u-boot bootloader for TI devices"
7 7
8LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb" 8LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
9 9
10PV = "2014.07" 10PR = "r12"
11PR = "r12+gitr${SRCPV}" 11PV_append = "+git${SRCPV}"
12 12
13SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}" 13SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}"
14 14
diff --git a/recipes-bsp/u-boot/u-boot_2014.07.bb b/recipes-bsp/u-boot/u-boot_2014.07.bb
index 91406f92..6cd8acd4 100644
--- a/recipes-bsp/u-boot/u-boot_2014.07.bb
+++ b/recipes-bsp/u-boot/u-boot_2014.07.bb
@@ -11,8 +11,6 @@ DEFAULT_PREFERENCE = "-1"
11 11
12LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb" 12LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
13 13
14PV = "2014.07"
15
16SRC_URI = "git://git.denx.de/u-boot.git;protocol=git;branch=${BRANCH}" 14SRC_URI = "git://git.denx.de/u-boot.git;protocol=git;branch=${BRANCH}"
17 15
18BRANCH ?= "master" 16BRANCH ?= "master"
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv_git.bb b/recipes-bsp/uio-module-drv/uio-module-drv_git.bb
index b7a26a1d..b2475278 100644
--- a/recipes-bsp/uio-module-drv/uio-module-drv_git.bb
+++ b/recipes-bsp/uio-module-drv/uio-module-drv_git.bb
@@ -6,12 +6,12 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2b7c96eb2aed7b0f6f922214dbde9016"
6BRANCH ?= "master" 6BRANCH ?= "master"
7# This corresponds to version 01.00.02.01 7# This corresponds to version 01.00.02.01
8SRCREV = "c1988446e3364af4df7cd877e6536f0c6647d7bb" 8SRCREV = "c1988446e3364af4df7cd877e6536f0c6647d7bb"
9PV = "1.0.2.1" 9PV = "1.0.2.1+git${SRCPV}"
10 10
11SRC_URI = "git://git.ti.com/keystone-linux/uio-module-drv.git;protocol=git;branch=${BRANCH}" 11SRC_URI = "git://git.ti.com/keystone-linux/uio-module-drv.git;protocol=git;branch=${BRANCH}"
12 12
13# This package builds a kernel module, use kernel PR as base and append a local 13# This package builds a kernel module, use kernel PR as base and append a local
14MACHINE_KERNEL_PR_append = "b+gitr${SRCPV}" 14MACHINE_KERNEL_PR_append = "b"
15PR = "${MACHINE_KERNEL_PR}" 15PR = "${MACHINE_KERNEL_PR}"
16 16
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
diff --git a/recipes-kernel/linux/linux-keystone-rt_3.10.bb b/recipes-kernel/linux/linux-keystone-rt_3.10.bb
index 5560ad21..7ce45b55 100644
--- a/recipes-kernel/linux/linux-keystone-rt_3.10.bb
+++ b/recipes-kernel/linux/linux-keystone-rt_3.10.bb
@@ -10,7 +10,7 @@ inherit kernel
10require recipes-kernel/linux/linux-dtb.inc 10require recipes-kernel/linux/linux-dtb.inc
11require recipes-kernel/linux/setup-defconfig.inc 11require recipes-kernel/linux/setup-defconfig.inc
12 12
13MACHINE_KERNEL_PR_append = "d+gitr${SRCPV}" 13MACHINE_KERNEL_PR_append = "d"
14PR = "${MACHINE_KERNEL_PR}" 14PR = "${MACHINE_KERNEL_PR}"
15 15
16KERNEL_DEVICETREE_k2hk-evm = "k2hk-evm.dtb" 16KERNEL_DEVICETREE_k2hk-evm = "k2hk-evm.dtb"
@@ -21,7 +21,7 @@ KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
21 21
22#This commit corresponds to "K2_RT_LINUX_03.10.61_15.02" 22#This commit corresponds to "K2_RT_LINUX_03.10.61_15.02"
23SRCREV = "e2e31a1d996d2ed8dd06dab1221e159033432b72" 23SRCREV = "e2e31a1d996d2ed8dd06dab1221e159033432b72"
24PV = "3.10.61" 24PV = "3.10.61+git${SRCPV}"
25 25
26BRANCH = "v3.10.61/master-rt" 26BRANCH = "v3.10.61/master-rt"
27SRC_URI = "git://git.ti.com/keystone-linux/linux.git;protocol=git;branch=${BRANCH}\ 27SRC_URI = "git://git.ti.com/keystone-linux/linux.git;protocol=git;branch=${BRANCH}\
diff --git a/recipes-kernel/linux/linux-keystone_3.10.bb b/recipes-kernel/linux/linux-keystone_3.10.bb
index 005aff41..78d5a0e5 100644
--- a/recipes-kernel/linux/linux-keystone_3.10.bb
+++ b/recipes-kernel/linux/linux-keystone_3.10.bb
@@ -10,7 +10,7 @@ inherit kernel
10require recipes-kernel/linux/linux-dtb.inc 10require recipes-kernel/linux/linux-dtb.inc
11require recipes-kernel/linux/setup-defconfig.inc 11require recipes-kernel/linux/setup-defconfig.inc
12 12
13MACHINE_KERNEL_PR_append = "d+gitr${SRCPV}" 13MACHINE_KERNEL_PR_append = "d"
14PR = "${MACHINE_KERNEL_PR}" 14PR = "${MACHINE_KERNEL_PR}"
15 15
16KERNEL_DEVICETREE_k2hk-evm = "k2hk-evm.dtb" 16KERNEL_DEVICETREE_k2hk-evm = "k2hk-evm.dtb"
@@ -21,7 +21,7 @@ KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
21 21
22#This commit corresponds to "K2_LINUX_03.10.61_15.02" 22#This commit corresponds to "K2_LINUX_03.10.61_15.02"
23SRCREV = "a17b4c3fd6c93f908daf032786f90c0321296957" 23SRCREV = "a17b4c3fd6c93f908daf032786f90c0321296957"
24PV = "3.10.61" 24PV = "3.10.61+git${SRCPV}"
25 25
26BRANCH = "v3.10.61/master" 26BRANCH = "v3.10.61/master"
27SRC_URI = "git://git.ti.com/keystone-linux/linux.git;protocol=git;branch=${BRANCH}\ 27SRC_URI = "git://git.ti.com/keystone-linux/linux.git;protocol=git;branch=${BRANCH}\
diff --git a/recipes-kernel/linux/linux-keystone_3.13.bb b/recipes-kernel/linux/linux-keystone_3.13.bb
index 13ce73e8..dc53e42b 100644
--- a/recipes-kernel/linux/linux-keystone_3.13.bb
+++ b/recipes-kernel/linux/linux-keystone_3.13.bb
@@ -13,7 +13,7 @@ require recipes-kernel/linux/setup-defconfig.inc
13# Look in the generic major.minor directory for files 13# Look in the generic major.minor directory for files
14FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-3.13:" 14FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-3.13:"
15 15
16MACHINE_KERNEL_PR_append = "a+gitr${SRCPV}" 16MACHINE_KERNEL_PR_append = "a"
17PR = "${MACHINE_KERNEL_PR}" 17PR = "${MACHINE_KERNEL_PR}"
18 18
19# Only k2hk DTB is available in this version 19# Only k2hk DTB is available in this version
@@ -22,7 +22,7 @@ KERNEL_DEVICETREE_k2hk-evm = "k2hk-evm.dtb"
22KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}" 22KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
23 23
24SRCREV = "11a8eaee39b68e6047f07382c251786b40bef165" 24SRCREV = "11a8eaee39b68e6047f07382c251786b40bef165"
25PV = "3.13.0" 25PV = "3.13.0+git${SRCPV}"
26 26
27BRANCH = "v3.13/master" 27BRANCH = "v3.13/master"
28SRC_URI = "git://git.ti.com/keystone-linux/linux.git;protocol=git;branch=${BRANCH}\ 28SRC_URI = "git://git.ti.com/keystone-linux/linux.git;protocol=git;branch=${BRANCH}\
diff --git a/recipes-kernel/linux/linux-ti-glsdk_3.8.bb b/recipes-kernel/linux/linux-ti-glsdk_3.8.bb
index 17bee023..906da49c 100644
--- a/recipes-kernel/linux/linux-ti-glsdk_3.8.bb
+++ b/recipes-kernel/linux/linux-ti-glsdk_3.8.bb
@@ -21,10 +21,10 @@ S = "${WORKDIR}/git"
21BRANCH ?= "p-ti-glsdk-3.8.y" 21BRANCH ?= "p-ti-glsdk-3.8.y"
22 22
23SRCREV ?= "cc16f99176bf083829c028f9af5b8eb560debcc1" 23SRCREV ?= "cc16f99176bf083829c028f9af5b8eb560debcc1"
24PV = "3.8.13" 24PV = "3.8.13+git${SRCPV}"
25 25
26# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild 26# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
27MACHINE_KERNEL_PR_append = "d+gitr${SRCPV}" 27MACHINE_KERNEL_PR_append = "d"
28PR = "${MACHINE_KERNEL_PR}" 28PR = "${MACHINE_KERNEL_PR}"
29 29
30SRC_URI = "git://git.omapzoom.org/kernel/omap.git;protocol=git;branch=${BRANCH} \ 30SRC_URI = "git://git.omapzoom.org/kernel/omap.git;protocol=git;branch=${BRANCH} \
diff --git a/recipes-kernel/linux/linux-ti-staging_3.12.bb b/recipes-kernel/linux/linux-ti-staging_3.12.bb
index 358bd1be..dd68b8e6 100644
--- a/recipes-kernel/linux/linux-ti-staging_3.12.bb
+++ b/recipes-kernel/linux/linux-ti-staging_3.12.bb
@@ -40,10 +40,10 @@ S = "${WORKDIR}/git"
40BRANCH = "ti-linux-3.12.y" 40BRANCH = "ti-linux-3.12.y"
41 41
42SRCREV = "68f449afccf6d1fb6b38bddfc3a40d9e97b53bdf" 42SRCREV = "68f449afccf6d1fb6b38bddfc3a40d9e97b53bdf"
43PV = "3.12.30" 43PV = "3.12.30+git${SRCPV}"
44 44
45# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild 45# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
46MACHINE_KERNEL_PR_append = "a+gitr${SRCPV}" 46MACHINE_KERNEL_PR_append = "a"
47PR = "${MACHINE_KERNEL_PR}" 47PR = "${MACHINE_KERNEL_PR}"
48 48
49KERNEL_CONFIG_FRAGMENTS = "${WORKDIR}/baseport.cfg ${WORKDIR}/connectivity.cfg \ 49KERNEL_CONFIG_FRAGMENTS = "${WORKDIR}/baseport.cfg ${WORKDIR}/connectivity.cfg \
diff --git a/recipes-kernel/linux/linux-ti-staging_3.14.bb b/recipes-kernel/linux/linux-ti-staging_3.14.bb
index 3a319dcd..084c8e36 100644
--- a/recipes-kernel/linux/linux-ti-staging_3.14.bb
+++ b/recipes-kernel/linux/linux-ti-staging_3.14.bb
@@ -47,10 +47,10 @@ S = "${WORKDIR}/git"
47BRANCH = "ti-linux-3.14.y" 47BRANCH = "ti-linux-3.14.y"
48 48
49SRCREV = "d0f5c460aac292d2942b23dd6199fe23021212ad" 49SRCREV = "d0f5c460aac292d2942b23dd6199fe23021212ad"
50PV = "3.14.43" 50PV = "3.14.43+git${SRCPV}"
51 51
52# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild 52# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
53MACHINE_KERNEL_PR_append = "b+gitr${SRCPV}" 53MACHINE_KERNEL_PR_append = "b"
54PR = "${MACHINE_KERNEL_PR}" 54PR = "${MACHINE_KERNEL_PR}"
55 55
56KERNEL_CONFIG_DIR = "${S}/ti_config_fragments" 56KERNEL_CONFIG_DIR = "${S}/ti_config_fragments"
diff --git a/recipes-kernel/linux/sitara-linux-ti-staging_3.14.bb b/recipes-kernel/linux/sitara-linux-ti-staging_3.14.bb
index 31c12239..cc364463 100644
--- a/recipes-kernel/linux/sitara-linux-ti-staging_3.14.bb
+++ b/recipes-kernel/linux/sitara-linux-ti-staging_3.14.bb
@@ -36,10 +36,10 @@ S = "${WORKDIR}/git"
36BRANCH = "sitara-ti-linux-3.14.y" 36BRANCH = "sitara-ti-linux-3.14.y"
37 37
38SRCREV = "2489c022b2932432606f897741a71b712e6dbe77" 38SRCREV = "2489c022b2932432606f897741a71b712e6dbe77"
39PV = "3.14.26" 39PV = "3.14.26+git${SRCPV}"
40 40
41# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild 41# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
42MACHINE_KERNEL_PR_append = "h+gitr${SRCPV}" 42MACHINE_KERNEL_PR_append = "h"
43PR = "${MACHINE_KERNEL_PR}" 43PR = "${MACHINE_KERNEL_PR}"
44 44
45MULTI_CONFIG_BASE_SUFFIX = "" 45MULTI_CONFIG_BASE_SUFFIX = ""