diff options
author | Sam Nelson <sam.nelson@ti.com> | 2016-06-21 02:04:12 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2016-06-20 16:55:38 -0400 |
commit | baa05bfea30db2039c686da1c92bd5d7df5f5f3c (patch) | |
tree | 1d4d05fe1f17eba8643fd822c86bea4ee41df03e | |
parent | f9897495ca1dda7ef62c301a43ccfa7c283c3ec3 (diff) | |
download | meta-ti-baa05bfea30db2039c686da1c92bd5d7df5f5f3c.tar.gz |
uio-module-drv: Update to new version 2.1.0.0
One API change in read/write
Additional test code added
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r-- | recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb | 18 | ||||
-rw-r--r-- | recipes-bsp/uio-module-drv/uio-module-drv.inc | 6 |
2 files changed, 18 insertions, 6 deletions
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb b/recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb index 3134a032..1923b369 100644 --- a/recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb +++ b/recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb | |||
@@ -2,16 +2,28 @@ DESCRIPTION = "Test code for user space IO (UIO) driver" | |||
2 | 2 | ||
3 | include uio-module-drv.inc | 3 | include uio-module-drv.inc |
4 | 4 | ||
5 | PR = "r1" | 5 | PR = "r0" |
6 | 6 | ||
7 | COMPATIBLE_MACHINE = "keystone" | 7 | COMPATIBLE_MACHINE = "keystone|am57xx-evm" |
8 | |||
9 | DEVICE_NAME_am57xx-evm = "am57xx" | ||
10 | DEVICE_NAME_keystone-evm = "keystone" | ||
8 | RDEPENDS_${PN} = "uio-module-drv" | 11 | RDEPENDS_${PN} = "uio-module-drv" |
9 | 12 | ||
10 | do_compile() { | 13 | do_compile() { |
11 | oe_runmake -C ${S} test | 14 | oe_runmake -C ${S} test "DEVICE=${DEVICE_NAME}" |
12 | } | 15 | } |
13 | 16 | ||
14 | do_install() { | 17 | do_install() { |
15 | install -d ${D}${bindir}/ | 18 | install -d ${D}${bindir}/ |
19 | install -c -m 755 ${S}/test/uio_mem_test ${D}${bindir}/. | ||
20 | install -c -m 755 ${S}/test/uio_int_test ${D}${bindir}/. | ||
21 | } | ||
22 | |||
23 | do_install_append_keystone () { | ||
16 | install -c -m 755 ${S}/test/uio_cic2_int_multithread_test ${D}${bindir}/. | 24 | install -c -m 755 ${S}/test/uio_cic2_int_multithread_test ${D}${bindir}/. |
17 | } | 25 | } |
26 | |||
27 | do_install_append_am57xx-evm () { | ||
28 | install -c -m 755 ${S}/test/prussdrv_test/test/pruss_uio_test ${D}${bindir}/. | ||
29 | } | ||
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv.inc b/recipes-bsp/uio-module-drv/uio-module-drv.inc index 161c45bc..88eab765 100644 --- a/recipes-bsp/uio-module-drv/uio-module-drv.inc +++ b/recipes-bsp/uio-module-drv/uio-module-drv.inc | |||
@@ -2,10 +2,10 @@ LICENSE = "BSD" | |||
2 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2b7c96eb2aed7b0f6f922214dbde9016" | 2 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2b7c96eb2aed7b0f6f922214dbde9016" |
3 | 3 | ||
4 | BRANCH = "master" | 4 | BRANCH = "master" |
5 | # This corresponds to version 02.00.00.00 | 5 | # This corresponds to version 02.01.00.00 |
6 | SRCREV = "6a7eda36e390658593a5b8d87b0f00beb3997240" | 6 | SRCREV = "19761495883bf8fb2670b0929d255135bd295dcb" |
7 | 7 | ||
8 | PV = "2.0.0.0+git${SRCPV}" | 8 | PV = "2.1.0.0+git${SRCPV}" |
9 | 9 | ||
10 | SRC_URI = "git://git.ti.com/keystone-linux/uio-module-drv.git;protocol=git;branch=${BRANCH}" | 10 | SRC_URI = "git://git.ti.com/keystone-linux/uio-module-drv.git;protocol=git;branch=${BRANCH}" |
11 | 11 | ||