diff options
author | Denys Dmytriyenko <denys@ti.com> | 2015-08-28 01:44:29 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-08-27 15:58:59 -0400 |
commit | b5be811d51b61c2d10f54f9c52152cff37c04f2c (patch) | |
tree | e4b15b356d6267302f7c815c6fee6c5f545b3928 | |
parent | d8cba916f310305fd116b455c0c04975cf6f5b7b (diff) | |
download | meta-ti-b5be811d51b61c2d10f54f9c52152cff37c04f2c.tar.gz |
linux-ti-staging: bump rev, update J6/AM5 GFX patches to rev3
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r-- | recipes-kernel/linux/linux-ti-staging-4.1/0001-DT-gpu-add-binding-for-TI-SGX-driver.patch | 25 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-ti-staging-4.1/0002-ARM-dts-DRA7xx-add-device-tree-entry-for-SGX.patch (renamed from recipes-kernel/linux/linux-ti-staging-4.1/0003-ARM-dts-DRA7xx-add-device-tree-entry-for-SGX.patch) | 24 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-ti-staging-4.1/0002-ARM-dts-DRA7xx-add-gpu-interface-clock.patch | 34 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-ti-staging-4.1/0003-arm-dra7xx-Add-gpu-hwmod-data.patch (renamed from recipes-kernel/linux/linux-ti-staging-4.1/0004-arm-dra7xx-Add-gpu-hwmod-data.patch) | 48 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-ti-staging-4.1/0004-drm-omap-Add-omapdrm-plugin-API.patch (renamed from recipes-kernel/linux/linux-ti-staging-4.1/0005-drm-omap-Add-omapdrm-plugin-API.patch) | 22 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-ti-staging_4.1.bb | 11 |
6 files changed, 52 insertions, 112 deletions
diff --git a/recipes-kernel/linux/linux-ti-staging-4.1/0001-DT-gpu-add-binding-for-TI-SGX-driver.patch b/recipes-kernel/linux/linux-ti-staging-4.1/0001-DT-gpu-add-binding-for-TI-SGX-driver.patch index d4ad9852..e7cf88f6 100644 --- a/recipes-kernel/linux/linux-ti-staging-4.1/0001-DT-gpu-add-binding-for-TI-SGX-driver.patch +++ b/recipes-kernel/linux/linux-ti-staging-4.1/0001-DT-gpu-add-binding-for-TI-SGX-driver.patch | |||
@@ -1,22 +1,22 @@ | |||
1 | From cab4b45daa65a79d24a4ae1345e2591986c7c73e Mon Sep 17 00:00:00 2001 | 1 | From 4b4e3b2f13798a581171abb09b400c033ece9211 Mon Sep 17 00:00:00 2001 |
2 | From: Anand Balagopalakrishnan <anandb@ti.com> | 2 | From: Anand Balagopalakrishnan <anandb@ti.com> |
3 | Date: Sat, 15 Aug 2015 22:37:38 +0000 | 3 | Date: Wed, 26 Aug 2015 09:34:49 +0000 |
4 | Subject: [PATCH 1/5] DT: gpu: add binding for TI SGX driver | 4 | Subject: [PATCH 1/4] DT: gpu: add binding for TI SGX driver |
5 | 5 | ||
6 | This patch adds the devicetree binding for TI SGX device driver. | 6 | This patch adds the devicetree binding for TI SGX device driver. |
7 | 7 | ||
8 | Signed-off-by: Anand Balagopalakrishnan <anandb@ti.com> | 8 | Signed-off-by: Anand Balagopalakrishnan <anandb@ti.com> |
9 | --- | 9 | --- |
10 | Documentation/devicetree/bindings/gpu/ti-sgx.txt | 27 ++++++++++++++++++++++++ | 10 | Documentation/devicetree/bindings/gpu/ti-sgx.txt | 30 ++++++++++++++++++++++++ |
11 | 1 file changed, 27 insertions(+) | 11 | 1 file changed, 30 insertions(+) |
12 | create mode 100644 Documentation/devicetree/bindings/gpu/ti-sgx.txt | 12 | create mode 100644 Documentation/devicetree/bindings/gpu/ti-sgx.txt |
13 | 13 | ||
14 | diff --git a/Documentation/devicetree/bindings/gpu/ti-sgx.txt b/Documentation/devicetree/bindings/gpu/ti-sgx.txt | 14 | diff --git a/Documentation/devicetree/bindings/gpu/ti-sgx.txt b/Documentation/devicetree/bindings/gpu/ti-sgx.txt |
15 | new file mode 100644 | 15 | new file mode 100644 |
16 | index 0000000..a13e105 | 16 | index 0000000..6b7886a |
17 | --- /dev/null | 17 | --- /dev/null |
18 | +++ b/Documentation/devicetree/bindings/gpu/ti-sgx.txt | 18 | +++ b/Documentation/devicetree/bindings/gpu/ti-sgx.txt |
19 | @@ -0,0 +1,27 @@ | 19 | @@ -0,0 +1,30 @@ |
20 | +TI SGX 3D Graphics Accelerator | 20 | +TI SGX 3D Graphics Accelerator |
21 | + | 21 | + |
22 | +Required properties: | 22 | +Required properties: |
@@ -30,19 +30,22 @@ index 0000000..a13e105 | |||
30 | + - reg: base address and length of the SGX registers | 30 | + - reg: base address and length of the SGX registers |
31 | + - interrupts : SGX interrupt number | 31 | + - interrupts : SGX interrupt number |
32 | + | 32 | + |
33 | +Recommended properties: | 33 | +Optional properties: |
34 | + - ti,hwmods: Name of the hwmod associated with the SGX | 34 | + - ti,hwmods: Name of the hwmod associated with the SGX |
35 | + - clocks : from SoC clock binding | 35 | + - clocks : from SoC clock binding |
36 | + - clock-names : names of clocks listed in clocks property in the same order | 36 | + - clock-names : names of clocks listed in clocks property in the same order |
37 | + - reg-names : names of registers listed in reg property in same order | ||
37 | + | 38 | + |
38 | +Example: | 39 | +Example: |
39 | + sgx@0x56000000 { | 40 | + sgx@0x56000000 { |
40 | + compatible = "ti,dra7-sgx544", "img,sgx544"; | 41 | + compatible = "ti,dra7-sgx544", "img,sgx544"; |
41 | + reg = <0x56000000 0x100000>; | 42 | + reg = <0x5600fe00 0x200>; |
43 | + reg-names = "gpu_wrapper"; | ||
42 | + interrupts = <GIC_SPI 16 IRQ_TYPE_LEVEL_HIGH>; | 44 | + interrupts = <GIC_SPI 16 IRQ_TYPE_LEVEL_HIGH>; |
43 | + ti,hwmods = "gpu"; | 45 | + ti,hwmods = "gpu"; |
44 | + clocks = <&gpu_l3_iclk>, <&gpu_core_gclk_mux>, <&gpu_hyd_gclk_mux>; | 46 | + clocks = <&l3_iclk_div>, <&gpu_core_gclk_mux>, |
45 | + clock-names = "sys", "core", "hyd"; | 47 | + <&gpu_hyd_gclk_mux>; |
48 | + clock-names = "gpu_iclk", "gpu_fclk1", "gpu_fclk2"; | ||
46 | + }; | 49 | + }; |
47 | -- | 50 | -- |
48 | 2.2.0 | 51 | 2.2.0 |
diff --git a/recipes-kernel/linux/linux-ti-staging-4.1/0003-ARM-dts-DRA7xx-add-device-tree-entry-for-SGX.patch b/recipes-kernel/linux/linux-ti-staging-4.1/0002-ARM-dts-DRA7xx-add-device-tree-entry-for-SGX.patch index df4dbc3d..ac168c79 100644 --- a/recipes-kernel/linux/linux-ti-staging-4.1/0003-ARM-dts-DRA7xx-add-device-tree-entry-for-SGX.patch +++ b/recipes-kernel/linux/linux-ti-staging-4.1/0002-ARM-dts-DRA7xx-add-device-tree-entry-for-SGX.patch | |||
@@ -1,30 +1,32 @@ | |||
1 | From e3ac183fe81a9bbd43a0f889253054d9311d5431 Mon Sep 17 00:00:00 2001 | 1 | From 20d10ea071c2b9eebb740f94f1fd0a7e4c9f7c03 Mon Sep 17 00:00:00 2001 |
2 | From: Anand Balagopalakrishnan <anandb@ti.com> | 2 | From: Anand Balagopalakrishnan <anandb@ti.com> |
3 | Date: Sat, 15 Aug 2015 22:37:40 +0000 | 3 | Date: Wed, 26 Aug 2015 09:34:50 +0000 |
4 | Subject: [PATCH 3/5] ARM: dts: DRA7xx: add device tree entry for SGX | 4 | Subject: [PATCH 2/4] ARM: dts: DRA7xx: add device tree entry for SGX |
5 | 5 | ||
6 | Addition of SGX to DRA7xx DTS to enable graphics support. | 6 | Addition of SGX to DRA7xx DTS to enable graphics support. |
7 | 7 | ||
8 | Signed-off-by: Anand Balagopalakrishnan <anandb@ti.com> | 8 | Signed-off-by: Anand Balagopalakrishnan <anandb@ti.com> |
9 | --- | 9 | --- |
10 | arch/arm/boot/dts/dra7.dtsi | 9 +++++++++ | 10 | arch/arm/boot/dts/dra7.dtsi | 11 +++++++++++ |
11 | 1 file changed, 9 insertions(+) | 11 | 1 file changed, 11 insertions(+) |
12 | 12 | ||
13 | diff --git a/arch/arm/boot/dts/dra7.dtsi b/arch/arm/boot/dts/dra7.dtsi | 13 | diff --git a/arch/arm/boot/dts/dra7.dtsi b/arch/arm/boot/dts/dra7.dtsi |
14 | index e599b29..dd974f9 100644 | 14 | index ce10ce3..c117ed0 100644 |
15 | --- a/arch/arm/boot/dts/dra7.dtsi | 15 | --- a/arch/arm/boot/dts/dra7.dtsi |
16 | +++ b/arch/arm/boot/dts/dra7.dtsi | 16 | +++ b/arch/arm/boot/dts/dra7.dtsi |
17 | @@ -889,6 +889,15 @@ | 17 | @@ -889,6 +889,17 @@ |
18 | status = "disabled"; | 18 | status = "disabled"; |
19 | }; | 19 | }; |
20 | 20 | ||
21 | + sgx: sgx@0x56000000 { | 21 | + sgx: sgx@0x56000000 { |
22 | + compatible = "ti,omap5-sgx544", "img,sgx544"; | 22 | + compatible = "ti,dra7-sgx544", "img,sgx544"; |
23 | + reg = <0x56000000 0x100000>; | 23 | + reg = <0x5600fe00 0x200>; |
24 | + reg-names = "gpu_wrapper"; | ||
24 | + interrupts = <GIC_SPI 16 IRQ_TYPE_LEVEL_HIGH>; | 25 | + interrupts = <GIC_SPI 16 IRQ_TYPE_LEVEL_HIGH>; |
25 | + ti,hwmods = "gpu"; | 26 | + ti,hwmods = "gpu"; |
26 | + clocks = <&gpu_l3_iclk>, <&gpu_core_gclk_mux>, <&gpu_hyd_gclk_mux>; | 27 | + clocks = <&l3_iclk_div>, <&gpu_core_gclk_mux>, |
27 | + clock-names = "sys", "core", "hyd"; | 28 | + <&gpu_hyd_gclk_mux>; |
29 | + clock-names = "gpu_iclk", "gpu_fclk1", "gpu_fclk2"; | ||
28 | + }; | 30 | + }; |
29 | + | 31 | + |
30 | i2c1: i2c@48070000 { | 32 | i2c1: i2c@48070000 { |
diff --git a/recipes-kernel/linux/linux-ti-staging-4.1/0002-ARM-dts-DRA7xx-add-gpu-interface-clock.patch b/recipes-kernel/linux/linux-ti-staging-4.1/0002-ARM-dts-DRA7xx-add-gpu-interface-clock.patch deleted file mode 100644 index c4282cb1..00000000 --- a/recipes-kernel/linux/linux-ti-staging-4.1/0002-ARM-dts-DRA7xx-add-gpu-interface-clock.patch +++ /dev/null | |||
@@ -1,34 +0,0 @@ | |||
1 | From f50b88d4be286d744361f7dadff0e6ae8ba107ff Mon Sep 17 00:00:00 2001 | ||
2 | From: Anand Balagopalakrishnan <anandb@ti.com> | ||
3 | Date: Sat, 15 Aug 2015 22:37:39 +0000 | ||
4 | Subject: [PATCH 2/5] ARM: dts: DRA7xx: add gpu interface clock | ||
5 | |||
6 | Addition of SGX interface sys clock to DRA7xx device tree. | ||
7 | |||
8 | Signed-off-by: Anand Balagopalakrishnan <anandb@ti.com> | ||
9 | --- | ||
10 | arch/arm/boot/dts/dra7xx-clocks.dtsi | 8 ++++++++ | ||
11 | 1 file changed, 8 insertions(+) | ||
12 | |||
13 | diff --git a/arch/arm/boot/dts/dra7xx-clocks.dtsi b/arch/arm/boot/dts/dra7xx-clocks.dtsi | ||
14 | index bd11c46..c734f75 100644 | ||
15 | --- a/arch/arm/boot/dts/dra7xx-clocks.dtsi | ||
16 | +++ b/arch/arm/boot/dts/dra7xx-clocks.dtsi | ||
17 | @@ -753,6 +753,14 @@ | ||
18 | ti,index-power-of-two; | ||
19 | }; | ||
20 | |||
21 | + gpu_l3_iclk: gpu_l3_iclk { | ||
22 | + #clock-cells = <0>; | ||
23 | + compatible = "fixed-factor-clock"; | ||
24 | + clocks = <&l3_iclk_div>; | ||
25 | + clock-mult = <1>; | ||
26 | + clock-div = <1>; | ||
27 | + }; | ||
28 | + | ||
29 | l4_root_clk_div: l4_root_clk_div { | ||
30 | #clock-cells = <0>; | ||
31 | compatible = "fixed-factor-clock"; | ||
32 | -- | ||
33 | 2.2.0 | ||
34 | |||
diff --git a/recipes-kernel/linux/linux-ti-staging-4.1/0004-arm-dra7xx-Add-gpu-hwmod-data.patch b/recipes-kernel/linux/linux-ti-staging-4.1/0003-arm-dra7xx-Add-gpu-hwmod-data.patch index 99b34733..57ee2689 100644 --- a/recipes-kernel/linux/linux-ti-staging-4.1/0004-arm-dra7xx-Add-gpu-hwmod-data.patch +++ b/recipes-kernel/linux/linux-ti-staging-4.1/0003-arm-dra7xx-Add-gpu-hwmod-data.patch | |||
@@ -1,18 +1,19 @@ | |||
1 | From 738de270894a7a2296c612ced981634df641f093 Mon Sep 17 00:00:00 2001 | 1 | From cbfdfed432347a3c52cf1c62cba5141b540d8d09 Mon Sep 17 00:00:00 2001 |
2 | From: Hemant Hariyani <hemanthariyani@ti.com> | 2 | From: Hemant Hariyani <hemanthariyani@ti.com> |
3 | Date: Sat, 15 Aug 2015 22:37:41 +0000 | 3 | Date: Wed, 26 Aug 2015 09:34:51 +0000 |
4 | Subject: [PATCH 4/5] arm:dra7xx: Add gpu hwmod data | 4 | Subject: [PATCH 3/4] arm:dra7xx: Add gpu hwmod data |
5 | 5 | ||
6 | GPU hwmod data for DRA7xx | 6 | GPU hwmod data for DRA7xx |
7 | 7 | ||
8 | Signed-off-by: Hemant Hariyani <hemanthariyani@ti.com> | 8 | Signed-off-by: Hemant Hariyani <hemanthariyani@ti.com> |
9 | Signed-off-by: Gowtham Tammana <g-tammana@ti.com> | 9 | Signed-off-by: Gowtham Tammana <g-tammana@ti.com> |
10 | Signed-off-by: Anand Balagopalakrishnan <anandb@ti.com> | ||
10 | --- | 11 | --- |
11 | arch/arm/mach-omap2/omap_hwmod_7xx_data.c | 74 +++++++++++++++++++++++++++++++ | 12 | arch/arm/mach-omap2/omap_hwmod_7xx_data.c | 43 +++++++++++++++++++++++++++++++ |
12 | 1 file changed, 74 insertions(+) | 13 | 1 file changed, 43 insertions(+) |
13 | 14 | ||
14 | diff --git a/arch/arm/mach-omap2/omap_hwmod_7xx_data.c b/arch/arm/mach-omap2/omap_hwmod_7xx_data.c | 15 | diff --git a/arch/arm/mach-omap2/omap_hwmod_7xx_data.c b/arch/arm/mach-omap2/omap_hwmod_7xx_data.c |
15 | index 0641f03..e1cc927 100644 | 16 | index 0641f03..03982b7 100644 |
16 | --- a/arch/arm/mach-omap2/omap_hwmod_7xx_data.c | 17 | --- a/arch/arm/mach-omap2/omap_hwmod_7xx_data.c |
17 | +++ b/arch/arm/mach-omap2/omap_hwmod_7xx_data.c | 18 | +++ b/arch/arm/mach-omap2/omap_hwmod_7xx_data.c |
18 | @@ -1318,6 +1318,40 @@ static struct omap_hwmod dra7xx_gpmc_hwmod = { | 19 | @@ -1318,6 +1318,40 @@ static struct omap_hwmod dra7xx_gpmc_hwmod = { |
@@ -56,53 +57,22 @@ index 0641f03..e1cc927 100644 | |||
56 | * 'hdq1w' class | 57 | * 'hdq1w' class |
57 | * | 58 | * |
58 | */ | 59 | */ |
59 | @@ -3686,6 +3720,45 @@ static struct omap_hwmod_ocp_if dra7xx_l3_main_1__gpmc = { | 60 | @@ -3686,6 +3720,14 @@ static struct omap_hwmod_ocp_if dra7xx_l3_main_1__gpmc = { |
60 | .user = OCP_USER_MPU | OCP_USER_SDMA, | 61 | .user = OCP_USER_MPU | OCP_USER_SDMA, |
61 | }; | 62 | }; |
62 | 63 | ||
63 | +static struct omap_hwmod_addr_space dra7xx_gpu_addrs[] = { | ||
64 | + { | ||
65 | + .name = "klio", | ||
66 | + .pa_start = 0x56000000, | ||
67 | + .pa_end = 0x56001fff, | ||
68 | + }, | ||
69 | + { | ||
70 | + .name = "hydra2", | ||
71 | + .pa_start = 0x56004000, | ||
72 | + .pa_end = 0x56004fff, | ||
73 | + }, | ||
74 | + { | ||
75 | + .name = "klio_0", | ||
76 | + .pa_start = 0x56008000, | ||
77 | + .pa_end = 0x56009fff, | ||
78 | + }, | ||
79 | + { | ||
80 | + .name = "klio_1", | ||
81 | + .pa_start = 0x5600c000, | ||
82 | + .pa_end = 0x5600dfff, | ||
83 | + }, | ||
84 | + { | ||
85 | + .name = "klio_hl", | ||
86 | + .pa_start = 0x5600fe00, | ||
87 | + .pa_end = 0x5600ffff, | ||
88 | + .flags = ADDR_TYPE_RT | ||
89 | + }, | ||
90 | + { } | ||
91 | +}; | ||
92 | + | ||
93 | +/* l3_main_1 -> gpu */ | 64 | +/* l3_main_1 -> gpu */ |
94 | +static struct omap_hwmod_ocp_if dra7xx_l3_main_1__gpu = { | 65 | +static struct omap_hwmod_ocp_if dra7xx_l3_main_1__gpu = { |
95 | + .master = &dra7xx_l3_main_1_hwmod, | 66 | + .master = &dra7xx_l3_main_1_hwmod, |
96 | + .slave = &dra7xx_gpu_hwmod, | 67 | + .slave = &dra7xx_gpu_hwmod, |
97 | + .clk = "l3_iclk_div", | 68 | + .clk = "l3_iclk_div", |
98 | + .addr = dra7xx_gpu_addrs, | ||
99 | + .user = OCP_USER_MPU | OCP_USER_SDMA, | 69 | + .user = OCP_USER_MPU | OCP_USER_SDMA, |
100 | +}; | 70 | +}; |
101 | + | 71 | + |
102 | static struct omap_hwmod_addr_space dra7xx_hdq1w_addrs[] = { | 72 | static struct omap_hwmod_addr_space dra7xx_hdq1w_addrs[] = { |
103 | { | 73 | { |
104 | .pa_start = 0x480b2000, | 74 | .pa_start = 0x480b2000, |
105 | @@ -4461,6 +4534,7 @@ static struct omap_hwmod_ocp_if *dra7xx_hwmod_ocp_ifs[] __initdata = { | 75 | @@ -4461,6 +4503,7 @@ static struct omap_hwmod_ocp_if *dra7xx_hwmod_ocp_ifs[] __initdata = { |
106 | &dra7xx_l4_per1__gpio7, | 76 | &dra7xx_l4_per1__gpio7, |
107 | &dra7xx_l4_per1__gpio8, | 77 | &dra7xx_l4_per1__gpio8, |
108 | &dra7xx_l3_main_1__gpmc, | 78 | &dra7xx_l3_main_1__gpmc, |
diff --git a/recipes-kernel/linux/linux-ti-staging-4.1/0005-drm-omap-Add-omapdrm-plugin-API.patch b/recipes-kernel/linux/linux-ti-staging-4.1/0004-drm-omap-Add-omapdrm-plugin-API.patch index b458ecf5..c89a49dd 100644 --- a/recipes-kernel/linux/linux-ti-staging-4.1/0005-drm-omap-Add-omapdrm-plugin-API.patch +++ b/recipes-kernel/linux/linux-ti-staging-4.1/0004-drm-omap-Add-omapdrm-plugin-API.patch | |||
@@ -1,10 +1,9 @@ | |||
1 | From 7635957dc5dde6de6753fcadb1b4f6044f1d16fa Mon Sep 17 00:00:00 2001 | 1 | From a5ddaecfdf950bd47560ac0a9b1ca9e57afc0c2e Mon Sep 17 00:00:00 2001 |
2 | From: Rob Clark <rob@ti.com> | 2 | From: Rob Clark <rob@ti.com> |
3 | Date: Sat, 15 Aug 2015 22:37:42 +0000 | 3 | Date: Wed, 26 Aug 2015 09:34:52 +0000 |
4 | Subject: [PATCH 5/5] drm/omap: Add omapdrm plugin API | 4 | Subject: [PATCH 4/4] drm/omap: Add omapdrm plugin API |
5 | 5 | ||
6 | This patch enables SGX driver to be added as a plugin to omapdrm. Plugins can | 6 | This patch enables SGX driver to be added as a plugin to omapdrm. |
7 | be loaded/unloaded at runtime. Currently, only SGX registers as a plugin. | ||
8 | 7 | ||
9 | Main changes involved: | 8 | Main changes involved: |
10 | 9 | ||
@@ -37,12 +36,12 @@ Signed-off-by: Anand Balagopalakrishnan <anandb@ti.com> | |||
37 | --- | 36 | --- |
38 | drivers/gpu/drm/omapdrm/omap_drv.c | 125 +++++++++++++++++++++++++++++++++++-- | 37 | drivers/gpu/drm/omapdrm/omap_drv.c | 125 +++++++++++++++++++++++++++++++++++-- |
39 | drivers/gpu/drm/omapdrm/omap_drv.h | 60 ++++++++++++++++-- | 38 | drivers/gpu/drm/omapdrm/omap_drv.h | 60 ++++++++++++++++-- |
40 | drivers/gpu/drm/omapdrm/omap_gem.c | 89 ++++++++++++++++++++++++++ | 39 | drivers/gpu/drm/omapdrm/omap_gem.c | 90 ++++++++++++++++++++++++++ |
41 | include/uapi/drm/omap_drm.h | 10 +-- | 40 | include/uapi/drm/omap_drm.h | 10 +-- |
42 | 4 files changed, 269 insertions(+), 15 deletions(-) | 41 | 4 files changed, 270 insertions(+), 15 deletions(-) |
43 | 42 | ||
44 | diff --git a/drivers/gpu/drm/omapdrm/omap_drv.c b/drivers/gpu/drm/omapdrm/omap_drv.c | 43 | diff --git a/drivers/gpu/drm/omapdrm/omap_drv.c b/drivers/gpu/drm/omapdrm/omap_drv.c |
45 | index ea537a5..1b0fb19 100644 | 44 | index ea537a5..00876c7 100644 |
46 | --- a/drivers/gpu/drm/omapdrm/omap_drv.c | 45 | --- a/drivers/gpu/drm/omapdrm/omap_drv.c |
47 | +++ b/drivers/gpu/drm/omapdrm/omap_drv.c | 46 | +++ b/drivers/gpu/drm/omapdrm/omap_drv.c |
48 | @@ -34,11 +34,20 @@ | 47 | @@ -34,11 +34,20 @@ |
@@ -61,7 +60,7 @@ index ea537a5..1b0fb19 100644 | |||
61 | +/* keep track of whether we are already loaded.. we may need to call | 60 | +/* keep track of whether we are already loaded.. we may need to call |
62 | + * plugin's load() if they register after we are already loaded | 61 | + * plugin's load() if they register after we are already loaded |
63 | + */ | 62 | + */ |
64 | +static bool loaded = false; | 63 | +static bool loaded; |
65 | + | 64 | + |
66 | /* | 65 | /* |
67 | * mode config funcs | 66 | * mode config funcs |
@@ -338,7 +337,7 @@ index 1f13c96..502d7b9 100644 | |||
338 | + | 337 | + |
339 | #endif /* __OMAP_DRV_H__ */ | 338 | #endif /* __OMAP_DRV_H__ */ |
340 | diff --git a/drivers/gpu/drm/omapdrm/omap_gem.c b/drivers/gpu/drm/omapdrm/omap_gem.c | 339 | diff --git a/drivers/gpu/drm/omapdrm/omap_gem.c b/drivers/gpu/drm/omapdrm/omap_gem.c |
341 | index f9ddbf5..49f5222 100644 | 340 | index f9ddbf5..8634fc6 100644 |
342 | --- a/drivers/gpu/drm/omapdrm/omap_gem.c | 341 | --- a/drivers/gpu/drm/omapdrm/omap_gem.c |
343 | +++ b/drivers/gpu/drm/omapdrm/omap_gem.c | 342 | +++ b/drivers/gpu/drm/omapdrm/omap_gem.c |
344 | @@ -117,6 +117,14 @@ struct omap_gem_object { | 343 | @@ -117,6 +117,14 @@ struct omap_gem_object { |
@@ -475,7 +474,7 @@ index f9ddbf5..49f5222 100644 | |||
475 | 474 | ||
476 | /* don't call directly.. called from GEM core when it is time to actually | 475 | /* don't call directly.. called from GEM core when it is time to actually |
477 | * free the object.. | 476 | * free the object.. |
478 | @@ -1485,3 +1510,67 @@ void omap_gem_deinit(struct drm_device *dev) | 477 | @@ -1485,3 +1510,68 @@ void omap_gem_deinit(struct drm_device *dev) |
479 | */ | 478 | */ |
480 | kfree(usergart); | 479 | kfree(usergart); |
481 | } | 480 | } |
@@ -500,6 +499,7 @@ index f9ddbf5..49f5222 100644 | |||
500 | + obj = omap_gem_new(dev, gsize, flags | OMAP_BO_EXT_MEM); | 499 | + obj = omap_gem_new(dev, gsize, flags | OMAP_BO_EXT_MEM); |
501 | + if (obj) { | 500 | + if (obj) { |
502 | + struct omap_gem_object *omap_obj = to_omap_bo(obj); | 501 | + struct omap_gem_object *omap_obj = to_omap_bo(obj); |
502 | + | ||
503 | + omap_obj->paddr = paddr; | 503 | + omap_obj->paddr = paddr; |
504 | + omap_obj->pages = pages; | 504 | + omap_obj->pages = pages; |
505 | + omap_obj->ops = ops; | 505 | + omap_obj->ops = ops; |
diff --git a/recipes-kernel/linux/linux-ti-staging_4.1.bb b/recipes-kernel/linux/linux-ti-staging_4.1.bb index 6ce53bbd..dff9867f 100644 --- a/recipes-kernel/linux/linux-ti-staging_4.1.bb +++ b/recipes-kernel/linux/linux-ti-staging_4.1.bb | |||
@@ -50,11 +50,11 @@ S = "${WORKDIR}/git" | |||
50 | 50 | ||
51 | BRANCH = "ti-lsk-linux-4.1.y" | 51 | BRANCH = "ti-lsk-linux-4.1.y" |
52 | 52 | ||
53 | SRCREV = "77889ef34c567c94faf6ba7b39aa7c65a6f3e841" | 53 | SRCREV = "4d8b97ba78fe68be2ce19008a6968a2aea0af8bb" |
54 | PV = "4.1.6+git${SRCPV}" | 54 | PV = "4.1.6+git${SRCPV}" |
55 | 55 | ||
56 | # Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild | 56 | # Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild |
57 | MACHINE_KERNEL_PR_append = "c" | 57 | MACHINE_KERNEL_PR_append = "d" |
58 | PR = "${MACHINE_KERNEL_PR}" | 58 | PR = "${MACHINE_KERNEL_PR}" |
59 | 59 | ||
60 | KERNEL_CONFIG_DIR = "${S}/ti_config_fragments" | 60 | KERNEL_CONFIG_DIR = "${S}/ti_config_fragments" |
@@ -72,9 +72,8 @@ SRC_URI += "${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH} \ | |||
72 | " | 72 | " |
73 | 73 | ||
74 | GFX_PATCHES = "file://0001-DT-gpu-add-binding-for-TI-SGX-driver.patch \ | 74 | GFX_PATCHES = "file://0001-DT-gpu-add-binding-for-TI-SGX-driver.patch \ |
75 | file://0002-ARM-dts-DRA7xx-add-gpu-interface-clock.patch \ | 75 | file://0002-ARM-dts-DRA7xx-add-device-tree-entry-for-SGX.patch \ |
76 | file://0003-ARM-dts-DRA7xx-add-device-tree-entry-for-SGX.patch \ | 76 | file://0003-arm-dra7xx-Add-gpu-hwmod-data.patch \ |
77 | file://0004-arm-dra7xx-Add-gpu-hwmod-data.patch \ | 77 | file://0004-drm-omap-Add-omapdrm-plugin-API.patch" |
78 | file://0005-drm-omap-Add-omapdrm-plugin-API.patch" | ||
79 | 78 | ||
80 | SRC_URI_append_dra7xx = " ${GFX_PATCHES}" | 79 | SRC_URI_append_dra7xx = " ${GFX_PATCHES}" |