summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2015-11-25 03:17:14 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-11-24 17:44:42 -0500
commit9f5af2f7d16f9ccfd9844327946bc94d495b4d89 (patch)
tree43bdf0152adf1d4327fd2c6adfa1a363e77bbdc5
parentbc7dad24ef9c92604e53ad1d3b6f6af54369ccb6 (diff)
downloadmeta-ti-9f5af2f7d16f9ccfd9844327946bc94d495b4d89.tar.gz
pmmc-fw: add initial PMMC firmware binary
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/pmmc-fw/pmmc-fw_git.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-bsp/pmmc-fw/pmmc-fw_git.bb b/recipes-bsp/pmmc-fw/pmmc-fw_git.bb
new file mode 100644
index 00000000..8d862349
--- /dev/null
+++ b/recipes-bsp/pmmc-fw/pmmc-fw_git.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = "PMMC firmware"
2
3LICENSE = "TI-TFL"
4LIC_FILES_CHKSUM = "file://LICENCE.ti-keystone;md5=3a86335d32864b0bef996bee26cc0f2c"
5
6PV = "0.1.0.63"
7PR = "r0"
8
9CLEANBROKEN = "1"
10
11COMPATIBLE_MACHINE = "k2g-evm"
12
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14
15SRCREV = "474abaf61ef4778df84b74c4a50f740149b38115"
16BRANCH ?= "master"
17
18SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}"
19
20S = "${WORKDIR}/git"
21TARGET = "pmmc-firmware.bin"
22
23do_install() {
24 install -d ${D}/boot
25 install -m 0644 ${S}/ti-keystone/${TARGET} ${D}/boot/${TARGET}
26}
27
28FILES_${PN} = "/boot"
29
30inherit deploy
31
32do_deploy () {
33 install -d ${DEPLOYDIR}
34 install -m 0644 ${S}/ti-keystone/${TARGET} ${DEPLOYDIR}/${TARGET}
35}
36
37addtask deploy before do_build after do_compile