summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2020-02-16 03:13:32 +0000
committerDenys Dmytriyenko <denys@ti.com>2020-02-17 17:15:51 +0000
commit35fb18a35f224a62eadbe0b1660b5ed4bd38c5ca (patch)
treef890a46806ed72a59ca085ca3da8366ff4d74dd2
parenta139fa4d47b233c3c00837a254b1f9b4c9e23db8 (diff)
downloadmeta-ti-35fb18a35f224a62eadbe0b1660b5ed4bd38c5ca.tar.gz
gdbc6x: suppress gcc9 -Wstringop-truncation warning
It's an old bfd/coff code, will need to be updated in the future. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-devtools/gdbc6x/gdbc6x/0001-libbfd.h-suppress-GCC9-Wstringop-truncation.patch28
-rw-r--r--recipes-devtools/gdbc6x/gdbc6x_git.bb1
2 files changed, 29 insertions, 0 deletions
diff --git a/recipes-devtools/gdbc6x/gdbc6x/0001-libbfd.h-suppress-GCC9-Wstringop-truncation.patch b/recipes-devtools/gdbc6x/gdbc6x/0001-libbfd.h-suppress-GCC9-Wstringop-truncation.patch
new file mode 100644
index 00000000..1cc23b32
--- /dev/null
+++ b/recipes-devtools/gdbc6x/gdbc6x/0001-libbfd.h-suppress-GCC9-Wstringop-truncation.patch
@@ -0,0 +1,28 @@
1From 0aa294e2bbd37a42266e59cb67687e57bfba4a88 Mon Sep 17 00:00:00 2001
2From: Denys Dmytriyenko <denys@ti.com>
3Date: Sat, 15 Feb 2020 15:59:37 -0500
4Subject: [PATCH] libbfd.h: suppress GCC9 -Wstringop-truncation
5
6Signed-off-by: Denys Dmytriyenko <denys@ti.com>
7---
8 gdbc6x/bfd/libbfd.h | 4 ++++
9 1 file changed, 4 insertions(+)
10
11diff --git a/gdbc6x/bfd/libbfd.h b/gdbc6x/bfd/libbfd.h
12index 72d3c50..3465f89 100644
13--- a/gdbc6x/bfd/libbfd.h
14+++ b/gdbc6x/bfd/libbfd.h
15@@ -34,6 +34,10 @@
16 #pragma GCC diagnostic ignored "-Wcast-function-type"
17 #endif
18
19+#if __GNUC__ >= 9
20+#pragma GCC diagnostic ignored "-Wstringop-truncation"
21+#endif
22+
23 #include "hashtab.h"
24
25 /* Align an address upward to a boundary, expressed as a number of bytes.
26--
272.7.4
28
diff --git a/recipes-devtools/gdbc6x/gdbc6x_git.bb b/recipes-devtools/gdbc6x/gdbc6x_git.bb
index 8ab9cf90..2d2f6c1d 100644
--- a/recipes-devtools/gdbc6x/gdbc6x_git.bb
+++ b/recipes-devtools/gdbc6x/gdbc6x_git.bb
@@ -11,6 +11,7 @@ PR = "${INC_PR}.1"
11 11
12SRC_URI_append = " \ 12SRC_URI_append = " \
13 file://init \ 13 file://init \
14 file://0001-libbfd.h-suppress-GCC9-Wstringop-truncation.patch;striplevel=2 \
14" 15"
15 16
16S = "${WORKDIR}/git/gdbc6x" 17S = "${WORKDIR}/git/gdbc6x"