summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2020-02-12 04:19:12 +0000
committerDenys Dmytriyenko <denys@ti.com>2020-02-11 22:17:04 +0000
commitcc5437d810fe8f58fe487db1a229c13a6d51640d (patch)
tree30d7b77a3af1ca836ca463ad520bececd8e9377a
parent489d825af690b2236a113f2f507968932f4c48de (diff)
downloadmeta-ti-cc5437d810fe8f58fe487db1a229c13a6d51640d.tar.gz
multiprocmgr: do not mix kernel and user-space headers, fully depend on uapi
As multiprocmgr is a user-space app and should only use uapi headers, drop extra -I for the kernel headers. Patch out any assumptions of direct access to the kernel headers. Cc: Suman Anna <s-anna@ti.com> Cc: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-suppress-kernel-linux-types.h-inclus.patch28
-rw-r--r--recipes-ti/multiprocmgr/multiprocmgr_git.bb3
2 files changed, 29 insertions, 2 deletions
diff --git a/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-suppress-kernel-linux-types.h-inclus.patch b/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-suppress-kernel-linux-types.h-inclus.patch
new file mode 100644
index 00000000..c3315cfc
--- /dev/null
+++ b/recipes-ti/multiprocmgr/multiprocmgr/0001-mpmdlif.c-don-t-suppress-kernel-linux-types.h-inclus.patch
@@ -0,0 +1,28 @@
1From 95921ccf77ae037bb3b95f45a632f60975c6c9bb Mon Sep 17 00:00:00 2001
2From: Denys Dmytriyenko <denys@ti.com>
3Date: Tue, 11 Feb 2020 17:03:18 -0500
4Subject: [PATCH] mpmdlif.c: don't suppress kernel <linux/types.h> inclusion
5
6Defining _LINUX_TYPES_H before including <linux/keystone_remoteproc.h> causes
7<linux/types.h> to skip defining kernel types, resulting in undefined __u32
8
9Signed-off-by: Denys Dmytriyenko <denys@ti.com>
10---
11 src/daemon/mpmdlif.c | 1 -
12 1 file changed, 1 deletion(-)
13
14diff --git a/src/daemon/mpmdlif.c b/src/daemon/mpmdlif.c
15index 0c31604..1abd00f 100644
16--- a/src/daemon/mpmdlif.c
17+++ b/src/daemon/mpmdlif.c
18@@ -46,7 +46,6 @@
19 #include <byteswap.h>
20 #include <stdint.h>
21
22-#define _LINUX_TYPES_H
23 #include "linux/keystone_remoteproc.h"
24 #include "internal/rsc_types.h"
25 //#include <elf.h>
26--
272.7.4
28
diff --git a/recipes-ti/multiprocmgr/multiprocmgr_git.bb b/recipes-ti/multiprocmgr/multiprocmgr_git.bb
index 6143341d..aea24456 100644
--- a/recipes-ti/multiprocmgr/multiprocmgr_git.bb
+++ b/recipes-ti/multiprocmgr/multiprocmgr_git.bb
@@ -6,6 +6,7 @@ include multiprocmgr.inc
6SRC_URI += " \ 6SRC_URI += " \
7 file://mpmsrv-daemon.service \ 7 file://mpmsrv-daemon.service \
8 file://0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch \ 8 file://0001-mpmdlif.c-don-t-hardcode-kernel-s-uapi-location-keys.patch \
9 file://0001-mpmdlif.c-don-t-suppress-kernel-linux-types.h-inclus.patch \
9" 10"
10 11
11PR = "${INC_PR}.2" 12PR = "${INC_PR}.2"
@@ -14,8 +15,6 @@ DEPENDS = "mpm-transport libdaemon virtual/kernel cmem"
14 15
15PACKAGE_ARCH = "${MACHINE_ARCH}" 16PACKAGE_ARCH = "${MACHINE_ARCH}"
16 17
17CC += "-I${STAGING_KERNEL_DIR}/include -I${STAGING_KERNEL_DIR}/include/uapi"
18
19INITSCRIPT_NAME = "mpmsrv-daemon.sh" 18INITSCRIPT_NAME = "mpmsrv-daemon.sh"
20INITSCRIPT_PARAMS = "defaults 10" 19INITSCRIPT_PARAMS = "defaults 10"
21 20