summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2020-02-18 03:20:57 +0000
committerDenys Dmytriyenko <denys@ti.com>2020-02-17 21:05:03 +0000
commit19a73c96bd05a74711a36a61077e8a7b88b55c63 (patch)
treeca0fdcb2f353af93d915df0413756547bc04d3a9
parent1e9dde5af91990f9d28092fcf300dd3d69bed451 (diff)
downloadmeta-ti-19a73c96bd05a74711a36a61077e8a7b88b55c63.tar.gz
k3conf: add diagnostic tool for K3 platformsti2020.00-rc1
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-devtools/k3conf/k3conf_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-devtools/k3conf/k3conf_git.bb b/recipes-devtools/k3conf/k3conf_git.bb
new file mode 100644
index 00000000..52c2fcf6
--- /dev/null
+++ b/recipes-devtools/k3conf/k3conf_git.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Diagnostic tool for TI K3 processors"
2
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://common/k3conf.c;beginline=1;endline=34;md5=37f4e460bd8501c6f02ce71f02bc7ccf"
5
6PV = "0.1+git${SRCPV}"
7
8COMPATIBLE_MACHINE = "k3"
9
10BRANCH ?= "master"
11SRCREV = "9199c3a3b6ec5603a2c4283410b4761e79e81e82"
12
13SRC_URI = "git://git.ti.com/k3conf/k3conf.git;protocol=git;branch=${BRANCH}"
14
15S = "${WORKDIR}/git"
16
17do_compile () {
18 oe_runmake CC="${CC}" CROSS_COMPILE=${TARGET_PREFIX} all
19}
20
21do_install () {
22 install -d ${D}${bindir}
23 install ${S}/k3conf ${D}${bindir}
24}