diff options
author | Denys Dmytriyenko <denys@ti.com> | 2019-10-09 02:07:15 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2019-10-08 23:51:58 +0000 |
commit | b5cdc2699899aef371518c7ee46b09576c425838 (patch) | |
tree | 493966b0aa9759dbfea90afd756f0ae7596266d4 | |
parent | dc6693c8391e4abd85e9949244c69ced1c79fca8 (diff) | |
download | meta-ti-b5cdc2699899aef371518c7ee46b09576c425838.tar.gz |
pru-pwm-fw: add PRU PWM Firmware recipe
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r-- | recipes-bsp/pru/pru-pwm-fw_git.bb | 40 |
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes-bsp/pru/pru-pwm-fw_git.bb b/recipes-bsp/pru/pru-pwm-fw_git.bb new file mode 100644 index 00000000..0fe79879 --- /dev/null +++ b/recipes-bsp/pru/pru-pwm-fw_git.bb | |||
@@ -0,0 +1,40 @@ | |||
1 | SUMMARY = "Programmable Real-time Unit PWM Firmware" | ||
2 | LICENSE = "BSD-3-Clause" | ||
3 | |||
4 | LIC_FILES_CHKSUM = "file://main.c;beginline=1;endline=32;md5=893d6a0cf1644338ea96642c0db97f59" | ||
5 | |||
6 | require recipes-ti/includes/ti-paths.inc | ||
7 | |||
8 | COMPATIBLE_MACHINE = "am65xx" | ||
9 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
10 | |||
11 | # Below commit ID corresponds to "DEV.PRUSS_LLD.01.00.00.15B" | ||
12 | SRCREV = "989f802266d52f50a6db8f2be6967eacd9d2b409" | ||
13 | |||
14 | PV = "01.00.00.15B" | ||
15 | |||
16 | BRANCH = "master" | ||
17 | SRC_URI = "git://git.ti.com/keystone-rtos/pruss-lld.git;protocol=git;branch=${BRANCH}" | ||
18 | |||
19 | DEPENDS = "ti-cgt-pru-native pru-icss common-csl-ip-rtos" | ||
20 | |||
21 | S = "${WORKDIR}/git/example/apps/icssg_pwm/firmware/src" | ||
22 | |||
23 | EXTRA_OEMAKE += " \ | ||
24 | PRU_CGT="${TI_CGT_PRU_INSTALL_DIR}" \ | ||
25 | PRU_SSP="${STAGING_DIR_TARGET}/usr" \ | ||
26 | PDK_INSTALL_DIR="${STAGING_DATADIR}/ti/ti-pdk-tree/packages" \ | ||
27 | " | ||
28 | |||
29 | do_compile() { | ||
30 | oe_runmake | ||
31 | } | ||
32 | |||
33 | do_install() { | ||
34 | install -d ${D}/lib/firmware/ti-pruss | ||
35 | install -m 0644 ${S}/gen/pwm.out ${D}/lib/firmware/ti-pruss/am65x-pru0-pwm-fw.elf | ||
36 | } | ||
37 | |||
38 | FILES_${PN} = "/lib/firmware" | ||
39 | |||
40 | INSANE_SKIP_${PN} = "arch" | ||