summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2019-11-15 21:14:41 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-12-06 22:38:10 +0000
commit0d29cd87ba93ff64c354845a878d556c37ee3b23 (patch)
treee54566270e1f2dbc400b55341e5ca150874cb270
parent258cd4b7e696d35ea0619fea8541eaa7d2fd5b49 (diff)
downloadmeta-ti-0d29cd87ba93ff64c354845a878d556c37ee3b23.tar.gz
osal: migrate to ti-pdk-fetch.bbclass
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/osal/osal-rtos_git.bb2
-rw-r--r--recipes-bsp/osal/osal-test_git.bb2
-rw-r--r--recipes-bsp/osal/osal.inc14
-rw-r--r--recipes-bsp/osal/osal_git.bb2
4 files changed, 4 insertions, 16 deletions
diff --git a/recipes-bsp/osal/osal-rtos_git.bb b/recipes-bsp/osal/osal-rtos_git.bb
index 62d1f997..a718f7ca 100644
--- a/recipes-bsp/osal/osal-rtos_git.bb
+++ b/recipes-bsp/osal/osal-rtos_git.bb
@@ -5,8 +5,6 @@ PR = "${INC_PR}.0"
5 5
6COMPATIBLE_MACHINE_append = "|c66x|k3" 6COMPATIBLE_MACHINE_append = "|c66x|k3"
7 7
8S = "${WORKDIR}/${OSAL_GIT_DESTSUFFIX}"
9
10DEPENDS_append_ti33x = " starterware-rtos" 8DEPENDS_append_ti33x = " starterware-rtos"
11DEPENDS_append_ti43x = " starterware-rtos" 9DEPENDS_append_ti43x = " starterware-rtos"
12 10
diff --git a/recipes-bsp/osal/osal-test_git.bb b/recipes-bsp/osal/osal-test_git.bb
index 58156e3b..354aa797 100644
--- a/recipes-bsp/osal/osal-test_git.bb
+++ b/recipes-bsp/osal/osal-test_git.bb
@@ -6,8 +6,6 @@ include osal.inc
6 6
7PR = "${INC_PR}.1" 7PR = "${INC_PR}.1"
8 8
9S = "${WORKDIR}/${OSAL_GIT_DESTSUFFIX}"
10
11EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} OSAL_SRC_DIR=${S}" 9EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} OSAL_SRC_DIR=${S}"
12 10
13do_compile () { 11do_compile () {
diff --git a/recipes-bsp/osal/osal.inc b/recipes-bsp/osal/osal.inc
index b0b015c7..1f0a0778 100644
--- a/recipes-bsp/osal/osal.inc
+++ b/recipes-bsp/osal/osal.inc
@@ -4,17 +4,11 @@ LIC_FILES_CHKSUM = "file://osal.h;beginline=1;endline=31;md5=6fbde6922f8bca1e6cd
4COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|omapl1" 4COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|omapl1"
5PACKAGE_ARCH = "${MACHINE_ARCH}" 5PACKAGE_ARCH = "${MACHINE_ARCH}"
6 6
7OSAL_GIT_URI = "git://git.ti.com/keystone-rtos/osal.git" 7inherit ti-pdk-fetch
8OSAL_GIT_PROTOCOL = "git"
9OSAL_GIT_BRANCH = "master"
10OSAL_GIT_DESTSUFFIX = "git/ti/osal"
11 8
12# Below commit ID corresponding to "DEV.OSAL.01.00.00.16B" 9TI_PDK_COMP = "ti.osal"
13OSAL_SRCREV = "b78489d9d78d9366f1865aa847b743b1b29f6fd4"
14 10
15BRANCH = "${OSAL_GIT_BRANCH}" 11PE = "1"
16SRC_URI = "${OSAL_GIT_URI};destsuffix=${OSAL_GIT_DESTSUFFIX};protocol=${OSAL_GIT_PROTOCOL};branch=${BRANCH}"
17 12
18SRCREV = "${OSAL_SRCREV}"
19PV = "01.00.00.16B"
20INC_PR = "r0" 13INC_PR = "r0"
14
diff --git a/recipes-bsp/osal/osal_git.bb b/recipes-bsp/osal/osal_git.bb
index 8f589376..4f881d2e 100644
--- a/recipes-bsp/osal/osal_git.bb
+++ b/recipes-bsp/osal/osal_git.bb
@@ -6,8 +6,6 @@ include osal.inc
6 6
7PR = "${INC_PR}.1" 7PR = "${INC_PR}.1"
8 8
9S = "${WORKDIR}/${OSAL_GIT_DESTSUFFIX}"
10
11EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}" 9EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}"
12 10
13do_compile () { 11do_compile () {