summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Ceresoli <luca@lucaceresoli.net>2019-12-04 17:45:29 +0100
committerDenys Dmytriyenko <denys@ti.com>2019-12-06 22:38:10 +0000
commitc9df259df4d915ca205ff69d18cdc1237a8b409c (patch)
tree95b6ef90b6ac8058848d6a94a6f7c67a78b1f0a7
parent90c7b65cb44aef370163382f67beedaf42c435cf (diff)
downloadmeta-ti-c9df259df4d915ca205ff69d18cdc1237a8b409c.tar.gz
Fix "basehash value changed" errors and BB_NUMBER_THREADS usage
Changing BB_NUMBER_THREADS between successive builds causes a "basehash value changed" error. Additionally, using BB_NUMBER_THREADS to pass a number of processes to run to xdc is wrong: PARALLEL_MAKE is the correct variable to use. Fix both problems by using oe.utils.parallel_make_argument() to obtain the number of processes to run from PARALLEL_MAKE. Fixes: ERROR: When reparsing .../meta-ti/recipes-ti/ipc/ti-ipc-rtos_git.bb.do_configure, the basehash value changed from 63897a188012cedde03f756b5dbbfa70 to 13b80bf4f4327c367bd201eb4aa32ad7. The metadata is not deterministic and this needs to be fixed. ERROR: When reparsing .../meta-ti/recipes-ti/ipc/ti-ipc-rtos_git.bb.do_compile, the basehash value changed from 2fb59a7db2a2f69d2c25c06c1b6a4245 to 314c664cc040afae2800fcc378dd9ae0. The metadata is not deterministic and this needs to be fixed. Steps to reproduce: BB_NUMBER_THREADS="3" bitbake ti-ipc-rtos ti-ipc-examples-linux BB_NUMBER_THREADS="4" bitbake -c cleansstate osal-rtos BB_NUMBER_THREADS="5" bitbake ti-ipc-rtos ti-ipc-examples-linux Reported here: https://e2e.ti.com/support/processors/f/791/p/825142/3059419 Reported-by: Matthew McKee (e-mail unknown) Suggested-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--classes/ti-pdk.bbclass2
-rw-r--r--recipes-ti/ipc/ti-ipc-rtos.inc3
2 files changed, 3 insertions, 2 deletions
diff --git a/classes/ti-pdk.bbclass b/classes/ti-pdk.bbclass
index 7030f70e..a07fdbb3 100644
--- a/classes/ti-pdk.bbclass
+++ b/classes/ti-pdk.bbclass
@@ -71,7 +71,7 @@ TI_PDK_DOXYGEN_SUPPORT ?= "1"
71 71
72TI_PDK_XDC_ARGS ?= "${TI_PDK_LIMIT_SOCS}" 72TI_PDK_XDC_ARGS ?= "${TI_PDK_LIMIT_SOCS}"
73 73
74PARALLEL_XDC = "--jobs=${BB_NUMBER_THREADS}" 74PARALLEL_XDC = "${@oe.utils.parallel_make_argument(d, '--jobs=%d')}"
75PARALLEL_MAKE = "" 75PARALLEL_MAKE = ""
76 76
77def get_doxygen_support(d): 77def get_doxygen_support(d):
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc
index 7789b5a1..baf1ccc1 100644
--- a/recipes-ti/ipc/ti-ipc-rtos.inc
+++ b/recipes-ti/ipc/ti-ipc-rtos.inc
@@ -84,12 +84,13 @@ IPC_TARGETS_am65xx = "\
84 ti.targets.arm.elf.R5F="${M4_TOOLCHAIN_INSTALL_DIR}" \ 84 ti.targets.arm.elf.R5F="${M4_TOOLCHAIN_INSTALL_DIR}" \
85" 85"
86 86
87PARALLEL_XDC = "${@oe.utils.parallel_make_argument(d, '--jobs=%d')}"
87EXTRA_OEMAKE = "\ 88EXTRA_OEMAKE = "\
88 PLATFORM=${PLATFORM} \ 89 PLATFORM=${PLATFORM} \
89 XDC_INSTALL_DIR="${XDC_INSTALL_DIR}" \ 90 XDC_INSTALL_DIR="${XDC_INSTALL_DIR}" \
90 BIOS_INSTALL_DIR="${SYSBIOS_INSTALL_DIR}" \ 91 BIOS_INSTALL_DIR="${SYSBIOS_INSTALL_DIR}" \
91 ${IPC_TARGETS} \ 92 ${IPC_TARGETS} \
92 JOBS="--jobs=${BB_NUMBER_THREADS}" \ 93 ${PARALLEL_XDC} \
93 JAVA_TOOL_OPTIONS=-Xss2560k \ 94 JAVA_TOOL_OPTIONS=-Xss2560k \
94" 95"
95EXTRA_OEMAKE_append_am65xx = " PDK_INSTALL_DIR=${PDK_INSTALL_DIR}" 96EXTRA_OEMAKE_append_am65xx = " PDK_INSTALL_DIR=${PDK_INSTALL_DIR}"