summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2019-11-15 21:14:46 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-12-06 22:38:10 +0000
commit49874edd268a953789b9084da1168f47dfc3fe46 (patch)
tree338affe7ba64c785bac8bd885601e89b223d0049
parentff3ffb4cee4ac3687123a2af07b56e226110c6b7 (diff)
downloadmeta-ti-49874edd268a953789b9084da1168f47dfc3fe46.tar.gz
pruss-lld: migrate to ti-pdk-fetch.bbclass
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/pruss-lld/pruss-lld-apps_git.bb2
-rw-r--r--recipes-bsp/pruss-lld/pruss-lld-rtos_git.bb2
-rw-r--r--recipes-bsp/pruss-lld/pruss-lld-test_git.bb2
-rw-r--r--recipes-bsp/pruss-lld/pruss-lld.inc13
-rw-r--r--recipes-bsp/pruss-lld/pruss-lld_git.bb2
5 files changed, 3 insertions, 18 deletions
diff --git a/recipes-bsp/pruss-lld/pruss-lld-apps_git.bb b/recipes-bsp/pruss-lld/pruss-lld-apps_git.bb
index 5867984b..48eab404 100644
--- a/recipes-bsp/pruss-lld/pruss-lld-apps_git.bb
+++ b/recipes-bsp/pruss-lld/pruss-lld-apps_git.bb
@@ -9,8 +9,6 @@ include pruss-lld.inc
9 9
10PR = "${INC_PR}.0" 10PR = "${INC_PR}.0"
11 11
12S = "${WORKDIR}/${PRUSS_LLD_GIT_DESTSUFFIX}"
13
14EXTRA_OEMAKE += "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} PDK_PKG_PATH=${STAGING_DATADIR}/ti/ti-pdk-tree/packages PRUSS_SRC_DIR=${S}" 12EXTRA_OEMAKE += "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} PDK_PKG_PATH=${STAGING_DATADIR}/ti/ti-pdk-tree/packages PRUSS_SRC_DIR=${S}"
15 13
16 14
diff --git a/recipes-bsp/pruss-lld/pruss-lld-rtos_git.bb b/recipes-bsp/pruss-lld/pruss-lld-rtos_git.bb
index b8db20ed..9ab09b64 100644
--- a/recipes-bsp/pruss-lld/pruss-lld-rtos_git.bb
+++ b/recipes-bsp/pruss-lld/pruss-lld-rtos_git.bb
@@ -6,8 +6,6 @@ require recipes-bsp/pruss-lld/pruss-lld.inc
6COMPATIBLE_MACHINE_append = "|k3" 6COMPATIBLE_MACHINE_append = "|k3"
7PR = "${INC_PR}.0" 7PR = "${INC_PR}.0"
8 8
9S = "${WORKDIR}/${PRUSS_LLD_GIT_DESTSUFFIX}"
10
11DEPENDS_append = " osal-rtos" 9DEPENDS_append = " osal-rtos"
12DEPENDS_append_ti33x = " starterware-rtos" 10DEPENDS_append_ti33x = " starterware-rtos"
13DEPENDS_append_ti43x = " starterware-rtos" 11DEPENDS_append_ti43x = " starterware-rtos"
diff --git a/recipes-bsp/pruss-lld/pruss-lld-test_git.bb b/recipes-bsp/pruss-lld/pruss-lld-test_git.bb
index 93f19011..8007f652 100644
--- a/recipes-bsp/pruss-lld/pruss-lld-test_git.bb
+++ b/recipes-bsp/pruss-lld/pruss-lld-test_git.bb
@@ -6,8 +6,6 @@ include pruss-lld.inc
6 6
7PR = "${INC_PR}.2" 7PR = "${INC_PR}.2"
8 8
9S = "${WORKDIR}/${PRUSS_LLD_GIT_DESTSUFFIX}"
10
11EXTRA_OEMAKE += "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} PRUSS_SRC_DIR=${S}" 9EXTRA_OEMAKE += "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} PRUSS_SRC_DIR=${S}"
12 10
13DEVICE_LIST ?= "${TI_PDK_LIMIT_SOCS}" 11DEVICE_LIST ?= "${TI_PDK_LIMIT_SOCS}"
diff --git a/recipes-bsp/pruss-lld/pruss-lld.inc b/recipes-bsp/pruss-lld/pruss-lld.inc
index 1fd3fb71..793ba838 100644
--- a/recipes-bsp/pruss-lld/pruss-lld.inc
+++ b/recipes-bsp/pruss-lld/pruss-lld.inc
@@ -4,18 +4,11 @@ LIC_FILES_CHKSUM = "file://pruicss.h;beginline=1;endline=31;md5=315177aa03d58bcd
4COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|k2g" 4COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|k2g"
5PACKAGE_ARCH = "${MACHINE_ARCH}" 5PACKAGE_ARCH = "${MACHINE_ARCH}"
6 6
7PRUSS_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/pruss-lld.git" 7inherit ti-pdk-fetch
8PRUSS_LLD_GIT_PROTOCOL = "git"
9PRUSS_LLD_GIT_BRANCH = "master"
10PRUSS_LLD_GIT_DESTSUFFIX = "git/ti/drv/pruss"
11 8
12# Below commit ID corresponds to "DEV.PRUSS_LLD.01.00.00.15B" 9TI_PDK_COMP = "ti.drv.pruss"
13PRUSS_LLD_SRCREV = "989f802266d52f50a6db8f2be6967eacd9d2b409"
14 10
15BRANCH = "${PRUSS_LLD_GIT_BRANCH}" 11PE = "1"
16SRC_URI = "${PRUSS_LLD_GIT_URI};destsuffix=${PRUSS_LLD_GIT_DESTSUFFIX};protocol=${PRUSS_LLD_GIT_PROTOCOL};branch=${BRANCH}"
17 12
18SRCREV = "${PRUSS_LLD_SRCREV}"
19PV = "01.00.00.15B"
20INC_PR = "r0" 13INC_PR = "r0"
21 14
diff --git a/recipes-bsp/pruss-lld/pruss-lld_git.bb b/recipes-bsp/pruss-lld/pruss-lld_git.bb
index 5b0a2576..f1e93cd7 100644
--- a/recipes-bsp/pruss-lld/pruss-lld_git.bb
+++ b/recipes-bsp/pruss-lld/pruss-lld_git.bb
@@ -6,8 +6,6 @@ include pruss-lld.inc
6 6
7PR = "${INC_PR}.2" 7PR = "${INC_PR}.2"
8 8
9S = "${WORKDIR}/${PRUSS_LLD_GIT_DESTSUFFIX}"
10
11EXTRA_OEMAKE += "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}" 9EXTRA_OEMAKE += "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}"
12 10
13do_compile () { 11do_compile () {