summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2019-11-15 21:14:58 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-12-06 22:38:10 +0000
commit6d006070e6bc50d86680bf45dbc8d08ed81d2278 (patch)
tree4a991be86dbd386da2fd85cf8926e22427619f3b
parent69a5c3462f82eb8fef0c1624b9a083b1f1556694 (diff)
downloadmeta-ti-6d006070e6bc50d86680bf45dbc8d08ed81d2278.tar.gz
utils-rtos: migrate to ti-pdk-fetch.bbclass
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/utils-rtos/profiling-rtos_git.bb18
-rw-r--r--recipes-bsp/utils-rtos/trace-rtos_git.bb18
2 files changed, 10 insertions, 26 deletions
diff --git a/recipes-bsp/utils-rtos/profiling-rtos_git.bb b/recipes-bsp/utils-rtos/profiling-rtos_git.bb
index 134a0f9b..9846804d 100644
--- a/recipes-bsp/utils-rtos/profiling-rtos_git.bb
+++ b/recipes-bsp/utils-rtos/profiling-rtos_git.bb
@@ -1,6 +1,10 @@
1SUMMARY = "TI RTOS profiling utilities" 1SUMMARY = "TI RTOS profiling utilities"
2 2
3inherit ti-pdk 3inherit ti-pdk ti-pdk-fetch
4
5TI_PDK_COMP = "ti.utils.profiling"
6
7PE = "1"
4 8
5LICENSE = "BSD-3-Clause" 9LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://profilingver.h;beginline=1;endline=46;md5=974494ad60f33cfc0340e421c5a5a7a0" 10LIC_FILES_CHKSUM = "file://profilingver.h;beginline=1;endline=46;md5=974494ad60f33cfc0340e421c5a5a7a0"
@@ -8,21 +12,9 @@ LIC_FILES_CHKSUM = "file://profilingver.h;beginline=1;endline=46;md5=974494ad60f
8COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|c66x|k3" 12COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|c66x|k3"
9PACKAGE_ARCH = "${MACHINE_ARCH}" 13PACKAGE_ARCH = "${MACHINE_ARCH}"
10 14
11PROFILING_GIT_URI = "git://git.ti.com/keystone-rtos/utils.git"
12PROFILING_GIT_PROTOCOL = "git"
13PROFILING_GIT_BRANCH = "master"
14
15# Below commit ID corresponds to "DEV.UTILS.01.00.00.10"
16PROFILING_SRCREV = "dbd2683d80326165d078282b1ef7dce44667e972"
17
18BRANCH = "${PROFILING_GIT_BRANCH}"
19SRC_URI = "${PROFILING_GIT_URI};protocol=${PROFILING_GIT_PROTOCOL};branch=${BRANCH}"
20 15
21SRCREV = "${PROFILING_SRCREV}"
22PV = "01.00.00.10"
23PR = "r0" 16PR = "r0"
24 17
25S = "${WORKDIR}/git/profiling"
26 18
27# Build with make instead of XDC 19# Build with make instead of XDC
28TI_PDK_XDCMAKE = "0" 20TI_PDK_XDCMAKE = "0"
diff --git a/recipes-bsp/utils-rtos/trace-rtos_git.bb b/recipes-bsp/utils-rtos/trace-rtos_git.bb
index 48b3bf24..249ffc79 100644
--- a/recipes-bsp/utils-rtos/trace-rtos_git.bb
+++ b/recipes-bsp/utils-rtos/trace-rtos_git.bb
@@ -2,7 +2,11 @@ SUMMARY = "TI RTOS Trace utility"
2 2
3DESCRIPTION = "This utility allows for tracing support in PDK drivers" 3DESCRIPTION = "This utility allows for tracing support in PDK drivers"
4 4
5inherit ti-pdk 5inherit ti-pdk ti-pdk-fetch
6
7TI_PDK_COMP = "ti.utils.trace"
8
9PE = "1"
6 10
7LICENSE = "BSD-3-Clause" 11LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://tracever.h;beginline=19;endline=47;md5=983f531ecfc9fc8c4bc3af9333ab6696" 12LIC_FILES_CHKSUM = "file://tracever.h;beginline=19;endline=47;md5=983f531ecfc9fc8c4bc3af9333ab6696"
@@ -10,21 +14,9 @@ LIC_FILES_CHKSUM = "file://tracever.h;beginline=19;endline=47;md5=983f531ecfc9fc
10COMPATIBLE_MACHINE = "k3" 14COMPATIBLE_MACHINE = "k3"
11PACKAGE_ARCH = "${MACHINE_ARCH}" 15PACKAGE_ARCH = "${MACHINE_ARCH}"
12 16
13TRACE_GIT_URI = "git://git.ti.com/keystone-rtos/utils.git"
14TRACE_GIT_PROTOCOL = "git"
15TRACE_GIT_BRANCH = "master"
16
17# Below commit ID corresponds to "DEV.UTILS.01.00.00.09"
18TRACE_SRCREV = "84802d7a787a53f33a24254069c90208c5d87d1e"
19
20BRANCH = "${TRACE_GIT_BRANCH}"
21SRC_URI = "${TRACE_GIT_URI};protocol=${TRACE_GIT_PROTOCOL};branch=${BRANCH}"
22 17
23SRCREV = "${TRACE_SRCREV}"
24PV = "01.00.00.09"
25PR = "r0" 18PR = "r0"
26 19
27S = "${WORKDIR}/git/trace"
28 20
29# Build with make instead of XDC 21# Build with make instead of XDC
30TI_PDK_XDCMAKE = "0" 22TI_PDK_XDCMAKE = "0"