summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikhil Devshatwar <nikhil.nd@ti.com>2019-09-30 14:44:06 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-09-30 17:38:06 +0000
commit666cff264f48f0c8db0b01749c94b19202b5171e (patch)
treeb07be2ec88ae54a2006560d04349e00d50be0b6b
parent2d5a7e066231ee96e19463cc22310bf6b66ce554 (diff)
downloadmeta-ti-666cff264f48f0c8db0b01749c94b19202b5171e.tar.gz
recipes-bsp: ivshmem-uio: Add new recipe for ivshmem-uio driver
This is external kernel module which enables userspace io over the Jailhouse ivhsmem (inter VM shared memory) This driver is useful to test the inter VM communication. Signed-off-by: Nikhil Devshatwar <nikhil.nd@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/ivshmem-uio/ivshmem-uio-driver_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-bsp/ivshmem-uio/ivshmem-uio-driver_git.bb b/recipes-bsp/ivshmem-uio/ivshmem-uio-driver_git.bb
new file mode 100644
index 00000000..a9f14552
--- /dev/null
+++ b/recipes-bsp/ivshmem-uio/ivshmem-uio-driver_git.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Kernel driver for IVSHMEM based UIO driver"
2DESCRIPTION = "Kernel module which registers a UIO (userspace io) device for inter VM shared memory"
3HOMEPAGE = "https://github.com/henning-schild-work/ivshmem-guest-code"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=0546a27aad86c83b75ad4ee6133e9d5e"
6
7inherit module
8
9RDEPENDS_${PN} = "jailhouse"
10
11PROTOCOL = "git"
12BRANCH = "jailhouse"
13SRCREV = "f3ad79881bebb6c6068966ee3d265d8034c20492"
14SRC_URI = "git://github.com/henning-schild-work/ivshmem-guest-code.git;protocol=${PROTOCOL};branch=${BRANCH}"
15
16S = "${WORKDIR}/git"
17
18EXTRA_OEMAKE += 'KDIR="${STAGING_KERNEL_DIR}"'
19
20do_compile_prepend() {
21 cd ${S}/kernel_module/uio
22}
23
24do_install() {
25 install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/extra
26 install -m 644 ${S}/kernel_module/uio/uio_ivshmem.ko ${D}/${base_libdir}/modules/${KERNEL_VERSION}/extra
27}