summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew F. Davis <afd@ti.com>2019-09-05 22:38:43 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-09-05 21:25:27 +0000
commitf22dceb15579b5d3291746c6147d0adf7535a21e (patch)
tree7a9fbdd0301c140c333d02f58c275b30188bbcc6
parent850d2b608c2d9d4d1c03396cc61e443b364a6b4e (diff)
downloadmeta-ti-f22dceb15579b5d3291746c6147d0adf7535a21e.tar.gz
ti-sgx-ddk-um: libgbm is now part of this project
The GBM library is tightly coupled with the system graphics systems, other hardware GPU vendors (including our Rogue DDK) and Mesa all deploy a version of the library as part of their GPU driver. We SGX does the same. This should ease integration for us as we now don't rely on a separate project for this library and our deployment strategy can match across Mesa/RGX recipes, allowing for better re-use of common components. Signed-off-by: Andrew F. Davis <afd@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-graphics/gbm/libgbm_10.0.0.bb23
-rw-r--r--recipes-graphics/libgles/ti-sgx-ddk-um_1.17.4948957.bb30
2 files changed, 14 insertions, 39 deletions
diff --git a/recipes-graphics/gbm/libgbm_10.0.0.bb b/recipes-graphics/gbm/libgbm_10.0.0.bb
deleted file mode 100644
index 6d058b72..00000000
--- a/recipes-graphics/gbm/libgbm_10.0.0.bb
+++ /dev/null
@@ -1,23 +0,0 @@
1SUMMARY = "Userspace interface for the kernel GBM services"
2HOMEPAGE = "http://git.ti.com/glsdk/libgbm.git"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://gbm.c;beginline=1;endline=26;md5=b871c7f2f477df29ee4c0ec437b187f7"
6
7DEPENDS = "libdrm udev"
8
9PROVIDES += "virtual/libgbm"
10
11inherit autotools pkgconfig
12
13BRANCH = "next"
14
15SRCREV = "96f37555c7e82a417b02051661377b10e6b3966e"
16
17SRC_URI = "git://git.ti.com/glsdk/libgbm.git;protocol=git;branch=${BRANCH} \
18 file://0001-gbm.c-include-sys-sysmacros.h-for-minor-major-in-new.patch"
19
20S = "${WORKDIR}/git"
21
22COMPATIBLE_HOST ?= "null"
23COMPATIBLE_HOST_ti-soc = "(.*)"
diff --git a/recipes-graphics/libgles/ti-sgx-ddk-um_1.17.4948957.bb b/recipes-graphics/libgles/ti-sgx-ddk-um_1.17.4948957.bb
index 02c9b750..80570ef0 100644
--- a/recipes-graphics/libgles/ti-sgx-ddk-um_1.17.4948957.bb
+++ b/recipes-graphics/libgles/ti-sgx-ddk-um_1.17.4948957.bb
@@ -10,7 +10,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
10BRANCH = "ti-img-sgx/thud/${PV}" 10BRANCH = "ti-img-sgx/thud/${PV}"
11 11
12SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-um-linux.git;protocol=git;branch=${BRANCH}" 12SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-um-linux.git;protocol=git;branch=${BRANCH}"
13SRCREV = "9e63d5ac0b40d6a70463173c597122b6645c8a95" 13SRCREV = "87d7e5c1e4db1bab048939c9719059d549c1e8dd"
14 14
15TARGET_PRODUCT_omap-a15 = "jacinto6evm" 15TARGET_PRODUCT_omap-a15 = "jacinto6evm"
16TARGET_PRODUCT_ti33x = "ti335x" 16TARGET_PRODUCT_ti33x = "ti335x"
@@ -22,23 +22,23 @@ INITSCRIPT_PARAMS = "defaults 8"
22 22
23inherit update-rc.d 23inherit update-rc.d
24 24
25PR = "r33" 25PR = "r34"
26PROVIDES += "virtual/egl virtual/libgles1 virtual/libgles2 omap5-sgx-ddk-um-linux" 26PROVIDES += "virtual/egl virtual/libgles1 virtual/libgles2 virtual/libgbm omap5-sgx-ddk-um-linux"
27 27
28DEPENDS += "libdrm udev libgbm wayland libffi" 28DEPENDS += "libdrm udev wayland libffi"
29RDEPENDS_${PN} += "libdrm libudev libgbm wayland libffi libdrm-omap" 29RDEPENDS_${PN} += "libdrm libudev wayland libffi libdrm-omap"
30 30
31RPROVIDES_${PN} = "libegl libgles1 libgles2 omap5-sgx-ddk-um-linux" 31RPROVIDES_${PN} = "libegl libgles1 libgles2 libgbm omap5-sgx-ddk-um-linux"
32RPROVIDES_${PN}-dev = "libegl-dev libgles1-dev libgles2-dev omap5-sgx-ddk-um-linux-dev" 32RPROVIDES_${PN}-dev = "libegl-dev libgles1-dev libgles2-dev libgbm-dev omap5-sgx-ddk-um-linux-dev"
33RPROVIDES_${PN}-dbg = "libegl-dbg libgles1-dbg libgles2-dbg omap5-sgx-ddk-um-linux-dbg" 33RPROVIDES_${PN}-dbg = "libegl-dbg libgles1-dbg libgles2-dbg libgbm-dbg omap5-sgx-ddk-um-linux-dbg"
34 34
35RREPLACES_${PN} = "libegl libgles1 libgles2 omap5-sgx-ddk-um-linux" 35RREPLACES_${PN} = "libegl libgles1 libgles2 libgbm omap5-sgx-ddk-um-linux"
36RREPLACES_${PN}-dev = "libegl-dev libgles1-dev libgles2-dev omap5-sgx-ddk-um-linux-dev" 36RREPLACES_${PN}-dev = "libegl-dev libgles1-dev libgles2-dev libgbm-dev omap5-sgx-ddk-um-linux-dev"
37RREPLACES_${PN}-dbg = "libegl-dbg libgles1-dbg libgles2-dbg omap5-sgx-ddk-um-linux-dbg" 37RREPLACES_${PN}-dbg = "libegl-dbg libgles1-dbg libgles2-dbg libgbm-dbg omap5-sgx-ddk-um-linux-dbg"
38 38
39RCONFLICTS_${PN} = "libegl libgles1 libgles2 omap5-sgx-ddk-um-linux" 39RCONFLICTS_${PN} = "libegl libgles1 libgles2 libgbm omap5-sgx-ddk-um-linux"
40RCONFLICTS_${PN}-dev = "libegl-dev libgles1-dev libgles2-dev omap5-sgx-ddk-um-linux-dev" 40RCONFLICTS_${PN}-dev = "libegl-dev libgles1-dev libgles2-dev libgbm-dev omap5-sgx-ddk-um-linux-dev"
41RCONFLICTS_${PN}-dbg = "libegl-dbg libgles1-dbg libgles2-dbg omap5-sgx-ddk-um-linux-dbg" 41RCONFLICTS_${PN}-dbg = "libegl-dbg libgles1-dbg libgles2-dbg libgbm-dbg omap5-sgx-ddk-um-linux-dbg"
42 42
43# The actual SONAME is libGLESv2.so.2, so need to explicitly specify RPROVIDES for .so.1 here 43# The actual SONAME is libGLESv2.so.2, so need to explicitly specify RPROVIDES for .so.1 here
44RPROVIDES_${PN} += "libGLESv2.so.1" 44RPROVIDES_${PN} += "libGLESv2.so.1"
@@ -47,8 +47,6 @@ S = "${WORKDIR}/git"
47 47
48do_install () { 48do_install () {
49 oe_runmake install DESTDIR=${D} TARGET_PRODUCT=${TARGET_PRODUCT} 49 oe_runmake install DESTDIR=${D} TARGET_PRODUCT=${TARGET_PRODUCT}
50 mkdir -p ${D}${libdir}/gbm
51 ln -sf ../libpvrGBMWSEGL.so.${PV} ${D}${libdir}/gbm/gbm_pvr.so
52 ln -sf libGLESv2.so.${PV} ${D}${libdir}/libGLESv2.so.1 50 ln -sf libGLESv2.so.${PV} ${D}${libdir}/libGLESv2.so.1
53 51
54 rm -f ${D}${libdir}/pkgconfig/wayland-egl.pc 52 rm -f ${D}${libdir}/pkgconfig/wayland-egl.pc