summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2019-09-12 01:23:53 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-09-12 16:00:43 +0000
commit7a5897c7e77a4b3e6f459351dcefeb0e5ab8cc19 (patch)
tree083b3a26b4766d01f7c60deaeb762fd9c5d89195
parentb9ce2c78e20ab312f43d50b51e3cc3242569cbad (diff)
downloadmeta-ti-7a5897c7e77a4b3e6f459351dcefeb0e5ab8cc19.tar.gz
ti-img-rogue-driver: port generic toolchain support from SGX
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/powervr-drivers/ti-img-rogue-driver/0001-km-support-general-toolchain.patch56
-rw-r--r--recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.10.5371573.bb4
2 files changed, 59 insertions, 1 deletions
diff --git a/recipes-bsp/powervr-drivers/ti-img-rogue-driver/0001-km-support-general-toolchain.patch b/recipes-bsp/powervr-drivers/ti-img-rogue-driver/0001-km-support-general-toolchain.patch
new file mode 100644
index 00000000..4dc219cd
--- /dev/null
+++ b/recipes-bsp/powervr-drivers/ti-img-rogue-driver/0001-km-support-general-toolchain.patch
@@ -0,0 +1,56 @@
1From dbdbd9309a58ee723fc827ef5fd45c28347cf61f Mon Sep 17 00:00:00 2001
2From: Eric Ruei <e-ruei1@ti.com>
3Date: Tue, 7 May 2019 17:06:09 -0400
4Subject: [PATCH] km: support general toolchain
5
6This is a patch from IMG to support general toolchains such as
7aarch64-oe-linux-gnu, aarch64-poky-linux-gnu, arm-none-linux-gnueabi
8per IMG ticket 122059
9
10Signed-off-by: Eric Ruei <e-ruei1@ti.com>
11Signed-off-by: Denys Dmytriyenko <denys@ti.com>
12---
13 build/linux/config/compiler.mk | 12 +++++++++++-
14 .../build/linux/config/compilers/arm-linux-gnueabi.mk | 6 ++++++
15 2 files changed, 17 insertions(+), 1 deletion(-)
16 create mode 100644 build/linux/config/compilers/arm-linux-gnueabi.mk
17
18diff --git a/build/linux/config/compiler.mk b/build/linux/config/compiler.mk
19index 82c9d44..dead2f9 100644
20--- a/build/linux/config/compiler.mk
21+++ b/build/linux/config/compiler.mk
22@@ -48,13 +48,14 @@ define calculate-compiler-preferred-target
23 ifeq ($(2),qcc)
24 $(1)_compiler_preferred_target := qcc
25 else
26- $(1)_compiler_preferred_target := $$(subst --,-,$$(shell $(2) -dumpmachine))
27+ $(1)_compiler_preferred_target := $$(subst --,-,$$(subst unknown,,$$(shell $(2) -dumpmachine)))
28 ifeq ($$($(1)_compiler_preferred_target),)
29 $$(warning No output from '$(2) -dumpmachine')
30 $$(warning Check that the compiler is in your PATH and CROSS_COMPILE is)
31 $$(warning set correctly.)
32 $$(error Unable to run compiler '$(2)')
33 endif
34+ $$(warning $(1) $(2))
35 ifneq ($$(filter %-w64-mingw32,$$($(1)_compiler_preferred_target)),)
36 # Use the compiler target name.
37 else
38@@ -64,6 +65,15 @@ define calculate-compiler-preferred-target
39 ifneq ($$(filter arm-linux-android,$$($(1)_compiler_preferred_target)),)
40 $(1)_compiler_preferred_target := arm-linux-androideabi
41 endif
42+ ifneq ($$(filter aarch64-%,$$($(1)_compiler_preferred_target)),)
43+ $(1)_compiler_preferred_target := aarch64-linux-gnu
44+ endif
45+ ifneq ($$(filter arm-%-gnueabi armv7a-cros-linux-gnueabi armv7hl-redhat-linux-gnueabi,$$($(1)_compiler_preferred_target)),)
46+ $(1)_compiler_preferred_target := arm-linux-gnueabi
47+ endif
48+ ifneq ($$(filter arm-%-gnueabihf,$$($(1)_compiler_preferred_target)),)
49+ $(1)_compiler_preferred_target := arm-linux-gnueabihf
50+ endif
51 ifneq ($$(filter clang%,$(2)),)
52 ifeq ($(1),target)
53 ifeq (arm-linux-gnueabihf,$$(CROSS_TRIPLE))
54--
552.7.4
56
diff --git a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.10.5371573.bb b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.10.5371573.bb
index 067c3b69..5b9f7c08 100644
--- a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.10.5371573.bb
+++ b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.10.5371573.bb
@@ -17,7 +17,9 @@ PROVIDES = "virtual/gpudriver"
17 17
18BRANCH = "linuxws/thud/k4.19/${PV}" 18BRANCH = "linuxws/thud/k4.19/${PV}"
19 19
20SRC_URI = "git://git.ti.com/graphics/ti-img-rogue-driver.git;branch=${BRANCH}" 20SRC_URI = "git://git.ti.com/graphics/ti-img-rogue-driver.git;branch=${BRANCH} \
21 file://0001-km-support-general-toolchain.patch \
22"
21S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
22 24
23SRCREV = "12594852f8a46ead75b5ce3309372e4a1054be05" 25SRCREV = "12594852f8a46ead75b5ce3309372e4a1054be05"