summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-11 16:29:32 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-11 17:16:49 +0100
commit6e51674f6e0537254349d8f4dc46f32953fe616f (patch)
treee277fa8f76fdabb7da47435189e94120cde008f7
parent7c1509e70ec896562bf5e26bded8dc1a13b4ad33 (diff)
downloadmeta-ti-6e51674f6e0537254349d8f4dc46f32953fe616f.tar.gz
bonescript: fixup git repo
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--recipes-misc/payload/bonescript.bb14
-rw-r--r--recipes-misc/payload/bonescript/bonescript-git11
2 files changed, 22 insertions, 3 deletions
diff --git a/recipes-misc/payload/bonescript.bb b/recipes-misc/payload/bonescript.bb
index 700d460e..bbce0223 100644
--- a/recipes-misc/payload/bonescript.bb
+++ b/recipes-misc/payload/bonescript.bb
@@ -1,6 +1,6 @@
1DESCRIPTION = "Scripting tools for the BeagleBoard and BeagleBone" 1DESCRIPTION = "Scripting tools for the BeagleBoard and BeagleBone"
2 2
3PR = "r1" 3PR = "r6"
4 4
5inherit allarch 5inherit allarch
6 6
@@ -9,14 +9,22 @@ LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58" 9LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
10 10
11SRCREV = "0b264f3144cb6385e33346dec02692d71844898d" 11SRCREV = "0b264f3144cb6385e33346dec02692d71844898d"
12SRC_URI = "git://github.com/jadonk/bonescript.git" 12SRC_URI = "git://github.com/jadonk/bonescript.git \
13 file://bonescript-git \
14 "
13S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
14 16
15do_install() { 17do_install() {
18 install -m 0644 ${WORKDIR}/bonescript-git ${S}/.git/config
19 cp $(cat .git/objects/info/alternates)/pack/* .git/objects/pack
20 rm -f ${S}/.git/objects/info/alternates
21 echo ${SRCREV} > .git/refs/heads/master
22 git checkout master || true
16 install -d ${D}${localstatedir}/lib/cloud9/ 23 install -d ${D}${localstatedir}/lib/cloud9/
17 cp -a ${S}/* ${D}${localstatedir}/lib/cloud9/ 24 cp -a ${S}/* ${D}${localstatedir}/lib/cloud9/
18 cp -a ${S}/.git ${D}${localstatedir}/lib/cloud9/ 25 cp -a ${S}/.git ${D}${localstatedir}/lib/cloud9/
19} 26}
20 27
21RDEPENDS_${PN} = "nodejs" 28RDEPENDS_${PN} = "nodejs cloud9"
29RRECOMMENDS_${PN} = "git"
22FILES_${PN} += "${localstatedir}" 30FILES_${PN} += "${localstatedir}"
diff --git a/recipes-misc/payload/bonescript/bonescript-git b/recipes-misc/payload/bonescript/bonescript-git
new file mode 100644
index 00000000..d9e66cfb
--- /dev/null
+++ b/recipes-misc/payload/bonescript/bonescript-git
@@ -0,0 +1,11 @@
1[core]
2 repositoryformatversion = 0
3 filemode = true
4 bare = false
5 logallrefupdates = true
6[remote "origin"]
7 fetch = +refs/heads/*:refs/remotes/origin/*
8 url = git://github.com/jadonk/bonescript.git
9[branch "master"]
10 remote = origin
11 merge = refs/heads/master