diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-11-08 13:50:43 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-11-08 13:50:43 +0100 |
commit | 5cf947e941cac336cef86c2f70362c9642de36f1 (patch) | |
tree | 46bde666e139a433affdaae924e367d1771379d5 | |
parent | 4402447bb482368c5ddc663e5cc280e1e51aeb43 (diff) | |
download | meta-ti-5cf947e941cac336cef86c2f70362c9642de36f1.tar.gz |
u-boot 2011.10rc: uboot extX loading is 20 times slower than vfat loading :(
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
3 files changed, 8 insertions, 8 deletions
diff --git a/recipes-bsp/u-boot/u-boot/2011.09git/0002-am335x_evm-boot-kernel-from-boot-in-ext2-3-filesyste.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0002-am335x_evm-boot-kernel-from-boot-in-ext2-3-filesyste.patch index 612ac981..61614f70 100644 --- a/recipes-bsp/u-boot/u-boot/2011.09git/0002-am335x_evm-boot-kernel-from-boot-in-ext2-3-filesyste.patch +++ b/recipes-bsp/u-boot/u-boot/2011.09git/0002-am335x_evm-boot-kernel-from-boot-in-ext2-3-filesyste.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 206baf5d1d8eb19312c0c8216e6722a63548573d Mon Sep 17 00:00:00 2001 | 1 | From 206baf5d1d8eb19312c0c8216e6722a63548573d Mon Sep 17 00:00:00 2001 |
2 | From: Koen Kooi <koen@dominion.thruhere.net> | 2 | From: Koen Kooi <koen@dominion.thruhere.net> |
3 | Date: Tue, 1 Nov 2011 12:21:07 +0100 | 3 | Date: Tue, 1 Nov 2011 12:21:07 +0100 |
4 | Subject: [PATCH 2/4] am335x_evm: boot kernel from /boot in ext2/3 filesystem | 4 | Subject: [PATCH 2/4] am335x_evm: add option to boot kernel from /boot in ext2/3 filesystem |
5 | 5 | ||
6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | 6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> |
7 | --- | 7 | --- |
@@ -17,8 +17,8 @@ index 93b3161..9bbfe3b 100755 | |||
17 | "importbootenv=echo Importing environment from mmc ...; " \ | 17 | "importbootenv=echo Importing environment from mmc ...; " \ |
18 | "env import -t $loadaddr $filesize\0" \ | 18 | "env import -t $loadaddr $filesize\0" \ |
19 | - "mmc_load_uimage=fatload mmc ${mmc_dev} ${loadaddr} ${bootfile}\0" \ | 19 | - "mmc_load_uimage=fatload mmc ${mmc_dev} ${loadaddr} ${bootfile}\0" \ |
20 | + "mmc_load_uimage_fat=fatload mmc ${mmc_dev} ${loadaddr} ${bootfile}\0" \ | 20 | + "mmc_load_uimage=fatload mmc ${mmc_dev} ${loadaddr} ${bootfile}\0" \ |
21 | + "mmc_load_uimage=ext2load mmc 0:2 ${loadaddr} /boot/${bootfile}\0" \ | 21 | + "mmc_load_uimage_ext2=ext2load ${mmc_dev} ${loadaddr} /boot/${bootfile}\0" \ |
22 | "optargs=\0" \ | 22 | "optargs=\0" \ |
23 | "bootargs_defaults=setenv bootargs " \ | 23 | "bootargs_defaults=setenv bootargs " \ |
24 | "console=${console} " \ | 24 | "console=${console} " \ |
diff --git a/recipes-bsp/u-boot/u-boot/2011.09git/0005-am335x-Change-mmc_load_uimage-to-load-at-a-fixed-add.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0005-am335x-Change-mmc_load_uimage-to-load-at-a-fixed-add.patch index f73d3c4e..ff18bed6 100644 --- a/recipes-bsp/u-boot/u-boot/2011.09git/0005-am335x-Change-mmc_load_uimage-to-load-at-a-fixed-add.patch +++ b/recipes-bsp/u-boot/u-boot/2011.09git/0005-am335x-Change-mmc_load_uimage-to-load-at-a-fixed-add.patch | |||
@@ -19,10 +19,10 @@ index 56e36da..8c0fae2 100755 | |||
19 | "loadbootenv=fatload mmc ${mmc_dev} ${loadaddr} ${bootenv}\0" \ | 19 | "loadbootenv=fatload mmc ${mmc_dev} ${loadaddr} ${bootenv}\0" \ |
20 | "importbootenv=echo Importing environment from mmc ...; " \ | 20 | "importbootenv=echo Importing environment from mmc ...; " \ |
21 | "env import -t $loadaddr $filesize\0" \ | 21 | "env import -t $loadaddr $filesize\0" \ |
22 | - "mmc_load_uimage_fat=fatload mmc ${mmc_dev} ${loadaddr} ${bootfile}\0" \ | 22 | - "mmc_load_uimage=fatload mmc ${mmc_dev} ${loadaddr} ${bootfile}\0" \ |
23 | - "mmc_load_uimage=ext2load mmc 0:2 ${loadaddr} /boot/${bootfile}\0" \ | 23 | - "mmc_load_uimage_ext2=ext2load ${mmc_dev} ${loadaddr} /boot/${bootfile}\0" \ |
24 | + "mmc_load_uimage_fat=fatload mmc ${mmc_dev} 0x80007fc0 ${bootfile}\0" \ | 24 | + "mmc_load_uimage=fatload mmc ${mmc_dev} 0x80007fc0 ${bootfile}\0" \ |
25 | + "mmc_load_uimage=ext2load mmc 0:2 0x80007fc0 /boot/${bootfile}\0" \ | 25 | + "mmc_load_uimage_ext2=ext2load ${mmc_dev} 0x80007fc0 /boot/${bootfile}\0" \ |
26 | "optargs=\0" \ | 26 | "optargs=\0" \ |
27 | "bootargs_defaults=setenv bootargs " \ | 27 | "bootargs_defaults=setenv bootargs " \ |
28 | "console=${console} " \ | 28 | "console=${console} " \ |
diff --git a/recipes-bsp/u-boot/u-boot_2011.10rc.bb b/recipes-bsp/u-boot/u-boot_2011.10rc.bb index fd7d99c4..983a1878 100644 --- a/recipes-bsp/u-boot/u-boot_2011.10rc.bb +++ b/recipes-bsp/u-boot/u-boot_2011.10rc.bb | |||
@@ -4,7 +4,7 @@ require u-boot.inc | |||
4 | COMPATIBLE_MACHINE = "(ti33x)" | 4 | COMPATIBLE_MACHINE = "(ti33x)" |
5 | DEFAULT_PREFERENCE_ti33x = "99" | 5 | DEFAULT_PREFERENCE_ti33x = "99" |
6 | PV = "2011.09+git" | 6 | PV = "2011.09+git" |
7 | PR = "r21" | 7 | PR = "r22" |
8 | 8 | ||
9 | # SPL build | 9 | # SPL build |
10 | UBOOT_BINARY = "u-boot.img" | 10 | UBOOT_BINARY = "u-boot.img" |