summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMahesh Radhakrishnan <m-radhakrishnan2@ti.com>2019-08-16 02:22:10 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-08-16 18:24:52 +0000
commit8b25bf3a078b6d365e66446b3ac1b2dd4024595b (patch)
tree35a5872d5c569550bb9d16d97398d650d9abdfda
parent6bb2459fb86590b024b457c38d5bb48f8efde68a (diff)
downloadmeta-ti-8b25bf3a078b6d365e66446b3ac1b2dd4024595b.tar.gz
ti-cgt-7x: Initial version of TI-CGT-C7000 recipe
This tool is not publically fetchable yet and requires pre-downloading Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-ti/devtools/ti-cgt7x_1.1.0.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/recipes-ti/devtools/ti-cgt7x_1.1.0.bb b/recipes-ti/devtools/ti-cgt7x_1.1.0.bb
new file mode 100644
index 00000000..72bbcc12
--- /dev/null
+++ b/recipes-ti/devtools/ti-cgt7x_1.1.0.bb
@@ -0,0 +1,48 @@
1SUMMARY = "TI DSP Code Generation Tools"
2DESCRIPTION = "Texas Instruments (TI) Code Generation Tools are custom \
3utilities targeted for TI embedded processors. This Digital Signal \
4Processor (DSP) suite contains tools needed to create and debug \
5applications for the C7000 DSP family. This includes tools such as: \
6compiler, linker, assembler, etc. This also includes C runtime \
7libraries and standard header files needed to produce a working DSP application."
8HOMEPAGE = "https://www-a.ti.com/downloads/sds_support/TICodegenerationTools/download.htm"
9LICENSE = "(TI-TSPA & Thai-Open-Source-Software-Center) & BSD-3-Clause & BSL-1.0 & Patrick-Powell & AFL-3.0 & MIT & BSD-2-Clause & PD"
10
11LIC_FILES_CHKSUM = "file://ti-cgt-c7000_${PV}/C7000_1.0.x_CodeGenerationTools_Manifest.html;md5=3074e433c5d52657076d1d138dfbdaf8"
12
13require recipes-ti/includes/ti-unpack.inc
14require recipes-ti/includes/ti-paths.inc
15
16# only x86_64 is supported
17COMPATIBLE_HOST = "x86_64.*-linux"
18COMPATIBLE_HOST_class-target = "null"
19
20BINFILE = "ti_cgt_c7000_${PV}_linux_installer_x86.bin"
21BINFILE_NAME = "cgt7x_x86_installer"
22
23# Please note, "install.source.dir.local" is not a real URL, below files need to be pre-downloaded
24SRC_URI = "http://install.source.dir.local/${BINFILE};name=${BINFILE_NAME}"
25
26TI_BIN_UNPK_ARGS = "--prefix ${S}"
27TI_BIN_UNPK_CMDS = ""
28
29SRC_URI[cgt7x_x86_installer.md5sum] = "feb668b4213403c661909adcf65d2ba8"
30SRC_URI[cgt7x_x86_installer.sha256sum] = "4a3954c973622c00a9b91fa90473cf921f4b763300b0e7c32735304867856ab8"
31
32S = "${WORKDIR}/c7000_${PV}"
33
34do_install() {
35 install -d ${D}/${TI_CGT7X_INSTALL_DIR_RECIPE}
36 cp -rP --preserve=mode,links,timestamps --no-preserve=ownership ${WORKDIR}/c7000_${PV}/ti-cgt-c7000_${PV}/. ${D}/${TI_CGT7X_INSTALL_DIR_RECIPE}
37}
38
39
40FILES_${PN} += "${TI_CGT7X_INSTALL_DIR_RECIPE}"
41
42INSANE_SKIP_${PN} += "arch staticdev textrel"
43
44INHIBIT_PACKAGE_STRIP = "1"
45INHIBIT_SYSROOT_STRIP = "1"
46INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
47
48BBCLASSEXTEND = "native nativesdk"