summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2019-07-08 23:12:00 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-07-08 22:28:20 +0000
commitbb3fe1645b246dc6c8aeb77d8b2dc396f2421867 (patch)
treeb4cb1d60069d8aef3776f0be9b3b1bdf3c0e5f48
parent528c168f158ac1bc0f982c587e88758bba850f9e (diff)
downloadmeta-ti-bb3fe1645b246dc6c8aeb77d8b2dc396f2421867.tar.gz
linux-ti-staging: add configuration for remoteproc/rpmsg IPC modules
* rpmsg_client_sample is a test module and should not be autoloaded * Both k3_r5 and k3_dsp remoteproc modules depend on virtio_rpmsg_bus Signed-off-by: Denys Dmytriyenko <denys@ti.com> Cc: Suman Anna <s-anna@ti.com> Reviewed-by: Suman Anna <s-anna@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-kernel/linux/linux-ti-staging_4.19.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-ti-staging_4.19.bb b/recipes-kernel/linux/linux-ti-staging_4.19.bb
index a52c339b..099631cf 100644
--- a/recipes-kernel/linux/linux-ti-staging_4.19.bb
+++ b/recipes-kernel/linux/linux-ti-staging_4.19.bb
@@ -72,3 +72,9 @@ SRC_URI += "${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH} \
72 file://defconfig" 72 file://defconfig"
73 73
74FILES_${KERNEL_PACKAGE_NAME}-devicetree += "/${KERNEL_IMAGEDEST}/*.itb" 74FILES_${KERNEL_PACKAGE_NAME}-devicetree += "/${KERNEL_IMAGEDEST}/*.itb"
75
76# Special configuration for remoteproc/rpmsg IPC modules
77module_conf_rpmsg_client_sample = "blacklist rpmsg_client_sample"
78module_conf_ti_k3_r5_remoteproc = "softdep ti_k3_r5_remoteproc pre: virtio_rpmsg_bus"
79module_conf_ti_k3_dsp_remoteproc = "softdep ti_k3_dsp_remoteproc pre: virtio_rpmsg_bus"
80KERNEL_MODULE_PROBECONF += "rpmsg_client_sample ti_k3_r5_remoteproc ti_k3_dsp_remoteproc"