summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnand Balagopalakrishnan <anandb@ti.com>2019-06-28 16:48:00 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-06-28 21:20:38 +0000
commitd88ce32d1978263ff90be76bf07b944b2c925b2a (patch)
tree94843f31facc114caa06d7af8f06cf67c0245929
parent802efa98cd98e353035c83c53271fa001df8022a (diff)
downloadmeta-ti-d88ce32d1978263ff90be76bf07b944b2c925b2a.tar.gz
ti-img-rogue-umlibs: add window system as an install option
We will start supporting Wayland window system. It is good to have nulldrmws as a debug option. GPU driver recipe already support window system option. Signed-off-by: Anand Balagopalakrishnan <anandb@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-graphics/libgles/ti-img-rogue-umlibs_1.10.5187610.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/recipes-graphics/libgles/ti-img-rogue-umlibs_1.10.5187610.bb b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.10.5187610.bb
index c7700fb7..94f078e2 100644
--- a/recipes-graphics/libgles/ti-img-rogue-umlibs_1.10.5187610.bb
+++ b/recipes-graphics/libgles/ti-img-rogue-umlibs_1.10.5187610.bb
@@ -6,15 +6,16 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=7232b98c1c58f99e3baa03de5207e76f"
6PACKAGE_ARCH = "${MACHINE_ARCH}" 6PACKAGE_ARCH = "${MACHINE_ARCH}"
7COMPATIBLE_MACHINE = "j7-evm" 7COMPATIBLE_MACHINE = "j7-evm"
8 8
9PR = "r2" 9PR = "r3"
10 10
11BRANCH = "linuxws/thud/k4.19/${PV}" 11BRANCH = "linuxws/thud/k4.19/${PV}"
12 12
13SRC_URI = "git://git.ti.com/graphics/ti-img-rogue-umlibs.git;branch=${BRANCH}" 13SRC_URI = "git://git.ti.com/graphics/ti-img-rogue-umlibs.git;branch=${BRANCH}"
14SRCREV = "97fc1ca42b03f400de38b78e21aaf6b5d94b1c5d" 14SRCREV = "3da5ebfde8a41cd38ab935f3e350d5d195fe7309"
15 15
16PVR_SOC ?= "j721e_linux" 16PVR_SOC ?= "j721e_linux"
17PVR_BUILD ?= "release" 17PVR_BUILD ?= "release"
18PVR_WS = "nulldrmws"
18 19
19INITSCRIPT_NAME = "rc.pvr" 20INITSCRIPT_NAME = "rc.pvr"
20INITSCRIPT_PARAMS = "defaults 8" 21INITSCRIPT_PARAMS = "defaults 8"
@@ -43,7 +44,7 @@ RCONFLICTS_${PN}-dbg = "libegl-dbg libgles1-dbg libgles2-dbg"
43S = "${WORKDIR}/git" 44S = "${WORKDIR}/git"
44 45
45do_install () { 46do_install () {
46 oe_runmake install DESTDIR=${D} TARGET_PRODUCT=${PVR_SOC} BUILD=${PVR_BUILD} 47 oe_runmake install DESTDIR=${D} TARGET_PRODUCT=${PVR_SOC} BUILD=${PVR_BUILD} WINDOW_SYSTEM=${PVR_WS}
47 chown -R root:root ${D} 48 chown -R root:root ${D}
48} 49}
49 50