summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSubhajit Paul <subhajit_paul@ti.com>2019-07-03 00:17:46 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-07-02 18:58:09 +0000
commit57c52ef27ba8ea0046a8dffb9c37ee9c4f5335cd (patch)
treeb6e96ffe10bf758b939d3b4e11c77ce8a93f6402
parentd439856bff1e17227714d6da448b54026081235c (diff)
downloadmeta-ti-57c52ef27ba8ea0046a8dffb9c37ee9c4f5335cd.tar.gz
ti-display-sharing: add recipe for fw integration
Signed-off-by: Subhajit Paul <subhajit_paul@ti.com> Reviewed-by: Dan Murphy <dmurphy@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/ti-display-sharing-fw/ti-display-sharing-firmware_git.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-bsp/ti-display-sharing-fw/ti-display-sharing-firmware_git.bb b/recipes-bsp/ti-display-sharing-fw/ti-display-sharing-firmware_git.bb
new file mode 100644
index 00000000..675b3f2c
--- /dev/null
+++ b/recipes-bsp/ti-display-sharing-fw/ti-display-sharing-firmware_git.bb
@@ -0,0 +1,46 @@
1SUMMARY = "TI Display Sharing Firmware"
2
3LICENSE = "TI-TFL"
4LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76"
5
6PV = "00.09.00.00-git${SRCPV}"
7PACKAGE_ARCH = "${MACHINE_ARCH}"
8
9inherit deploy
10inherit update-alternatives
11
12PROTOCOL = "git"
13BRANCH = "ti-linux-firmware"
14SRCREV = "4a86f16df9b44798851e51fa465825710cda76cf"
15
16SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=${PROTOCOL};branch=${BRANCH}"
17
18S = "${WORKDIR}/git"
19
20TI_DISP_SHARE_FW_DIR = "${S}/ti-display-sharing/"
21TI_DISP_SHARE_FW_FILENAME = "ti-display-sharing-j721e.bin"
22
23# make sure that lib/firmware, and all its contents are part of the package
24FILES_${PN} += "${base_libdir}/firmware"
25
26do_install() {
27 install -d ${D}${base_libdir}/firmware
28 install -m 0755 ${TI_DISP_SHARE_FW_DIR}/${TI_DISP_SHARE_FW_FILENAME} ${D}${base_libdir}/firmware
29}
30
31TARGET_MAIN_R5FSS0_1 = "j7-main-r5f0_1-fw"
32ALTERNATIVE_${PN} = "j7-main-r5f0_1-fw"
33ALTERNATIVE_LINK_NAME[j7-main-r5f0_1-fw] = "${base_libdir}/firmware/${TARGET_MAIN_R5FSS0_1}"
34ALTERNATIVE_TARGET[j7-main-r5f0_1-fw] = "${base_libdir}/firmware/${TI_DISP_SHARE_FW_FILENAME}"
35ALTERNATIVE_PRIORITY = "9"
36
37# This is used to prevent the build system to strip the executables
38INHIBIT_PACKAGE_STRIP = "1"
39# This is used to prevent the build system to split the debug info in a separate file
40INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
41# As it likely to be a different arch from the Yocto build, disable checking by adding "arch" to INSANE_SKIP
42INSANE_SKIP_${PN} += "arch"
43
44# we don't want to configure and build the source code
45do_compile[noexec] = "1"
46do_configure[noexec] = "1"