diff options
author | Denys Dmytriyenko <denys@ti.com> | 2012-02-28 17:05:03 -0500 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2012-02-28 17:05:03 -0500 |
commit | 827f9e9a8a8d933791966da46e9ad9d1a57b0403 (patch) | |
tree | 29731e688f4a667d0c58a2e24ef05709e5779b55 | |
parent | 263ddd18798eb5ef7dc1e58dcd3e392cfca39135 (diff) | |
download | meta-ti-827f9e9a8a8d933791966da46e9ad9d1a57b0403.tar.gz |
matrix-tui: deprecated
Remove matrix-tui, since it has been deprecated and no longer supported.
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r-- | recipes-ti/matrix/matrix-tui.inc | 44 | ||||
-rwxr-xr-x | recipes-ti/matrix/matrix-tui/init | 24 | ||||
-rw-r--r-- | recipes-ti/matrix/matrix-tui_1.1.bb | 4 |
3 files changed, 0 insertions, 72 deletions
diff --git a/recipes-ti/matrix/matrix-tui.inc b/recipes-ti/matrix/matrix-tui.inc deleted file mode 100644 index 3be12950..00000000 --- a/recipes-ti/matrix/matrix-tui.inc +++ /dev/null | |||
@@ -1,44 +0,0 @@ | |||
1 | DESCRIPTION = "Matrix TUI" | ||
2 | HOMEPAGE = "https://gforge.ti.com/gf/project/matrix_tui/" | ||
3 | LICENSE = "BSD" | ||
4 | SECTION = "multimedia" | ||
5 | DEPENDS = "libxml2 zlib ncurses" | ||
6 | |||
7 | INC_PR = "r7" | ||
8 | |||
9 | COMPATIBLE_MACHINE = "(omapl138|omap3)" | ||
10 | |||
11 | SRC_URI = "svn://gforge.ti.com/svn/matrix_tui/;module=trunk;proto=https;user=anonymous;pswd='' \ | ||
12 | file://init \ | ||
13 | " | ||
14 | |||
15 | S = "${WORKDIR}/trunk" | ||
16 | |||
17 | # Do not auto-start TUI by default, uncomment otherwise | ||
18 | #inherit update-rc.d | ||
19 | #INITSCRIPT_NAME = "matrix-tui" | ||
20 | #INITSCRIPT_PARAMS = "defaults 99" | ||
21 | |||
22 | do_configure() { | ||
23 | sed -i -e 's|LIBS :=|LIBS := ${LDFLAGS} |' Release/objects.mk | ||
24 | } | ||
25 | |||
26 | do_compile() { | ||
27 | # don't build debug version | ||
28 | touch debug | ||
29 | export CROSS_COMPILE=${TARGET_PREFIX} | ||
30 | export TUI_INCLUDE_PATH=${STAGING_INCDIR} | ||
31 | export XML_INCLUDE_PATH=${STAGING_INCDIR}/libxml2 | ||
32 | export TUI_LIB_PATH=${STAGING_LIBDIR} | ||
33 | export PLATFORM=${MACHINE} | ||
34 | make release | ||
35 | } | ||
36 | |||
37 | do_install() { | ||
38 | export PLATFORM=${MACHINE} | ||
39 | make DESTDIR=${D} install | ||
40 | install -d ${D}${sysconfdir}/init.d/ | ||
41 | install -c -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/matrix-tui | ||
42 | } | ||
43 | |||
44 | FILES_${PN} += "${datadir}/matrix/*" | ||
diff --git a/recipes-ti/matrix/matrix-tui/init b/recipes-ti/matrix/matrix-tui/init deleted file mode 100755 index e5813825..00000000 --- a/recipes-ti/matrix/matrix-tui/init +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | #! /bin/sh | ||
2 | |||
3 | matrixtui="/usr/bin/matrix_tui" | ||
4 | TUI_OPTS="/usr/share/matrix/xml/matrix.xml" | ||
5 | |||
6 | test -x "$matrixtui" || exit 0 | ||
7 | |||
8 | case "$1" in | ||
9 | start) | ||
10 | echo -n "Starting Matrix TUI application" | ||
11 | start-stop-daemon --start --quiet --background --pidfile /var/run/matrix-tui.pid --exec $matrixtui -- $TUI_OPTS | ||
12 | echo "." | ||
13 | ;; | ||
14 | stop) | ||
15 | echo -n "Stopping Matrix TUI application" | ||
16 | start-stop-daemon --stop --quiet --pidfile /var/run/matrix-tui.pid | ||
17 | echo "." | ||
18 | ;; | ||
19 | *) | ||
20 | echo "Usage: /etc/init.d/matrix-tui {start|stop}" | ||
21 | exit 1 | ||
22 | esac | ||
23 | |||
24 | exit 0 | ||
diff --git a/recipes-ti/matrix/matrix-tui_1.1.bb b/recipes-ti/matrix/matrix-tui_1.1.bb deleted file mode 100644 index 9814d5fa..00000000 --- a/recipes-ti/matrix/matrix-tui_1.1.bb +++ /dev/null | |||
@@ -1,4 +0,0 @@ | |||
1 | require matrix-tui.inc | ||
2 | |||
3 | SRCREV = "37" | ||
4 | PR = "${INC_PR}.4" | ||