summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2019-05-22 22:23:01 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-06-11 19:35:43 +0000
commitaee573173cd0fbefd5a9c54fda61d03de004687c (patch)
tree1974d75ffc0ab8d5ac2ebbb64d959c27088037b1
parent2da08ed8b2f4a29fb7d45e769171ea5bb79cf0b2 (diff)
downloadmeta-ti-aee573173cd0fbefd5a9c54fda61d03de004687c.tar.gz
vps-lld-rtos: fix DEPENDS
* Add to the dependencies set in ti-pdk.bbclass so that we get tools such as XDC. * Set the edma3-lld path so the makefile can push it onto XDCPATH. Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/vps-lld/vps-lld-rtos_git.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes-bsp/vps-lld/vps-lld-rtos_git.bb b/recipes-bsp/vps-lld/vps-lld-rtos_git.bb
index a06aae49..e2834a63 100644
--- a/recipes-bsp/vps-lld/vps-lld-rtos_git.bb
+++ b/recipes-bsp/vps-lld/vps-lld-rtos_git.bb
@@ -25,7 +25,9 @@ PR = "r0"
25 25
26S = "${WORKDIR}/${VPS_LLD_GIT_DESTSUFFIX}" 26S = "${WORKDIR}/${VPS_LLD_GIT_DESTSUFFIX}"
27 27
28DEPENDS = " ti-sysbios \ 28# Add to DEPENDS set in ti-pdk.bbclass
29DEPENDS_append = " \
30 ti-sysbios \
29 osal-rtos \ 31 osal-rtos \
30 edma3-lld-rtos \ 32 edma3-lld-rtos \
31 board-rtos \ 33 board-rtos \
@@ -39,6 +41,9 @@ export DEST_ROOT="${S}"
39# Build with make instead of XDC 41# Build with make instead of XDC
40TI_PDK_XDCMAKE = "0" 42TI_PDK_XDCMAKE = "0"
41 43
44# The makefile will push these on the XDCPATH
45export EDMA3LLD_BIOS6_INSTALLDIR = "${EDMA3_LLD_INSTALL_DIR}"
46
42do_compile_append() { 47do_compile_append() {
43 # Delete archive created by XDC release command since it does not contain all content 48 # Delete archive created by XDC release command since it does not contain all content
44 find -name "*.tar" -exec rm -f {} \; 49 find -name "*.tar" -exec rm -f {} \;