summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2019-06-26 21:49:53 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-06-27 21:08:16 +0000
commit8a0742080134ce5c2e5457ebf652d41ba7f4da48 (patch)
treea6ec5ae5a6978fcdf38f9c5a32ea5a2810d577b6
parentd270e28d857d56936ba642402ba3d5354dbe847d (diff)
downloadmeta-ti-8a0742080134ce5c2e5457ebf652d41ba7f4da48.tar.gz
prueth-fw-bin: remove prebuilt firmware recipe
* The prueth-fw-am65xx provides the same firmware but built from sourecs. Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/prueth-fw/prueth-fw-bin_git.bb32
1 files changed, 0 insertions, 32 deletions
diff --git a/recipes-bsp/prueth-fw/prueth-fw-bin_git.bb b/recipes-bsp/prueth-fw/prueth-fw-bin_git.bb
deleted file mode 100644
index 60dc0879..00000000
--- a/recipes-bsp/prueth-fw/prueth-fw-bin_git.bb
+++ /dev/null
@@ -1,32 +0,0 @@
1SUMMARY = "PRU Ethernet firmware for AM65xx"
2
3LICENSE = "TI-TFL"
4LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76"
5
6PV = "5.3.0.5"
7
8CLEANBROKEN = "1"
9
10COMPATIBLE_MACHINE = "am65xx-evm"
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14SRCREV = "534ba03becfa9b39ccbd42b97e091abd94a207e7"
15BRANCH ?= "ti-linux-firmware"
16
17SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}"
18
19S = "${WORKDIR}/git"
20
21TARGET = "am65x-pru0-prueth-fw.elf am65x-pru1-prueth-fw.elf am65x-rtu0-prueth-fw.elf am65x-rtu1-prueth-fw.elf"
22
23do_install() {
24 install -d ${D}${base_libdir}/firmware/ti-pruss
25 for f in ${TARGET}; do
26 install -m 0644 ${S}/ti-pruss/$f ${D}${base_libdir}/firmware/ti-pruss/$f
27 done
28}
29
30FILES_${PN} = "${base_libdir}/firmware"
31
32INSANE_SKIP_${PN} = "arch"