summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-10-08 01:23:49 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-08 21:07:39 +0200
commit5c52cbe6a25ea3010731795bb1e1c5d94123eef0 (patch)
treeb442172a5a3bbfb021ea3c642ad9e5ac66dd63bf
parent29851840a1d2b10d8759d1a44c59460afd367f8f (diff)
downloadmeta-ti-5c52cbe6a25ea3010731795bb1e1c5d94123eef0.tar.gz
ti-hw-bringup-image: import from meta-angstrom
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--recipes-misc/images/ti-hw-bringup-image.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes-misc/images/ti-hw-bringup-image.bb b/recipes-misc/images/ti-hw-bringup-image.bb
new file mode 100644
index 00000000..7c8c1bea
--- /dev/null
+++ b/recipes-misc/images/ti-hw-bringup-image.bb
@@ -0,0 +1,44 @@
1# Image for assisting in hardware bringup
2
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
5
6IMAGE_PREPROCESS_COMMAND = "rootfs_update_timestamp"
7
8
9IMAGE_INSTALL += " \
10 angstrom-task-boot \
11 rsyslog \
12 dropbear-systemd openssh-sftp \
13 e2fsprogs-e2fsck e2fsprogs-blkid \
14 avahi-daemon avahi-utils avahi-systemd \
15 ${CONMANPKGS} \
16 systemd-compat-units python-dbus python-pycairo \
17 cpufrequtils \
18 htop \
19 usbutils \
20 i2c-tools \
21 alsa-utils \
22 devmem2 \
23 iw \
24 bonnie++ \
25 hdparm \
26 iozone3 \
27 iperf \
28 lmbench \
29 rt-tests \
30 evtest \
31 bc \
32"
33
34CONMANPKGS = "connman connman-plugin-loopback connman-plugin-ethernet connman-plugin-wifi connman-systemd"
35CONMANPKGS_libc-uclibc = ""
36
37IMAGE_DEV_MANAGER = "udev"
38IMAGE_INIT_MANAGER = "systemd"
39IMAGE_INITSCRIPTS = " "
40IMAGE_LOGIN_MANAGER = "tinylogin shadow"
41
42export IMAGE_BASENAME = "TI-hw-bringup"
43
44inherit sdcard_image