summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2019-06-26 21:49:51 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-06-27 21:08:16 +0000
commit3db629082bca3c6dd6f052e30a2428dd51d28f3a (patch)
tree42adc2cd8bf940ea9499d726910540b272bd7486
parenta9ea0e990d63070e54837e9ef1d8bd6c57aba092 (diff)
downloadmeta-ti-3db629082bca3c6dd6f052e30a2428dd51d28f3a.tar.gz
prueth-fw-am65xx: build am65xx prueth-fw from source
* The sources for the am65xx prueth-fw are located in within the emac-lld sources. Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb b/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb
new file mode 100644
index 00000000..08ef7f06
--- /dev/null
+++ b/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb
@@ -0,0 +1,43 @@
1SUMMARY = "PRU Ethernet firmware for AM65x"
2
3require recipes-ti/includes/ti-paths.inc
4require recipes-bsp/emac-lld/emac-lld.inc
5
6LICENSE = "TI-TFL"
7LIC_FILES_CHKSUM = "file://src/makefile;beginline=6;endline=53;md5=3f9129d208f240940749757214bdc191"
8
9PR = "r0"
10
11S = "${WORKDIR}/git/firmware/icss_dualmac"
12
13COMPATIBLE_MACHINE = "am65xx"
14
15PACKAGE_ARCH = "${MACHINE_ARCH}"
16
17DEPENDS = "ti-cgt-pru-native"
18
19EXTRA_OEMAKE += "CL_PRU_INSTALL_PATH="${TI_CGT_PRU_INSTALL_DIR}""
20
21do_compile() {
22 oe_runmake -C src
23}
24
25do_install() {
26 install -d ${D}${base_libdir}/firmware/ti-pruss
27
28 install -m 0644 bin/rxl2_txl2_rgmii0/rxl2_txl2.out \
29 ${D}${base_libdir}/firmware/ti-pruss/am65x-pru0-prueth-fw.elf
30
31 install -m 0644 bin/rtu_test0/rtu_v2.out \
32 ${D}${base_libdir}/firmware/ti-pruss/am65x-rtu0-prueth-fw.elf
33
34 install -m 0644 bin/rxl2_txl2_rgmii1/rxl2_txl2.out \
35 ${D}${base_libdir}/firmware/ti-pruss/am65x-pru1-prueth-fw.elf
36
37 install -m 0644 bin/rtu_test1/rtu_v2.out \
38 ${D}${base_libdir}/firmware/ti-pruss/am65x-rtu1-prueth-fw.elf
39}
40
41FILES_${PN} = "${base_libdir}/firmware"
42
43INSANE_SKIP_${PN} = "arch"