diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2015-08-21 19:41:05 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-08-24 14:20:19 -0400 |
commit | 2ea16a954200f6092435985a4430c772b0c36d8e (patch) | |
tree | b40a2b75885413b39aefbf0d2be6599bf66c8ea8 | |
parent | 3d31d82b334ea0e608dbee3b2d5d1cde85eaa10c (diff) | |
download | meta-ti-2ea16a954200f6092435985a4430c772b0c36d8e.tar.gz |
cmem: Bump SRCREV to fix build with GCC 4.9 and Linux 4.1
* Changes retain compatibility with older tolchain and kernl.
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r-- | recipes-bsp/cmem/cmem-mod_git.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/cmem/cmem.inc | 8 | ||||
-rw-r--r-- | recipes-bsp/cmem/cmem_git.bb | 2 |
3 files changed, 6 insertions, 6 deletions
diff --git a/recipes-bsp/cmem/cmem-mod_git.bb b/recipes-bsp/cmem/cmem-mod_git.bb index b36eb096..6b2303c0 100644 --- a/recipes-bsp/cmem/cmem-mod_git.bb +++ b/recipes-bsp/cmem/cmem-mod_git.bb | |||
@@ -3,7 +3,7 @@ DESCRIPTION = "Kernel module for contiguous memory allocation from userspace" | |||
3 | include cmem.inc | 3 | include cmem.inc |
4 | 4 | ||
5 | # This package builds a kernel module, use kernel PR as base and append a local | 5 | # This package builds a kernel module, use kernel PR as base and append a local |
6 | MACHINE_KERNEL_PR_append = "b" | 6 | MACHINE_KERNEL_PR_append = "a" |
7 | PR = "${MACHINE_KERNEL_PR}" | 7 | PR = "${MACHINE_KERNEL_PR}" |
8 | 8 | ||
9 | inherit module | 9 | inherit module |
diff --git a/recipes-bsp/cmem/cmem.inc b/recipes-bsp/cmem/cmem.inc index 23e5f2e2..0d3e918b 100644 --- a/recipes-bsp/cmem/cmem.inc +++ b/recipes-bsp/cmem/cmem.inc | |||
@@ -3,11 +3,11 @@ HOMEPAGE = "http://processors.wiki.ti.com/index.php/Category:CMEM" | |||
3 | LICENSE = "GPLv2" | 3 | LICENSE = "GPLv2" |
4 | LIC_FILES_CHKSUM = "file://include/ti/cmem.h;beginline=1;endline=30;md5=9b745e2765a6ba8a636c91aed4b02ac1" | 4 | LIC_FILES_CHKSUM = "file://include/ti/cmem.h;beginline=1;endline=30;md5=9b745e2765a6ba8a636c91aed4b02ac1" |
5 | 5 | ||
6 | BRANCH ?= "master" | 6 | BRANCH ?= "lu-next" |
7 | # This corresponds to version 4.10.01.02 | 7 | # This corresponds to version 4.10.02.03 |
8 | SRCREV = "a51d9770021fd16c97fc59b320286a3fa43278bc" | 8 | SRCREV = "d47ac635699da6bee6daff31b87b0123e13af4ac" |
9 | 9 | ||
10 | PV = "4.10.01.02+git${SRCPV}" | 10 | PV = "4.10.02.03+git${SRCPV}" |
11 | 11 | ||
12 | SRC_URI = "git://git.ti.com/ipc/ludev.git;protocol=git;branch=${BRANCH}" | 12 | SRC_URI = "git://git.ti.com/ipc/ludev.git;protocol=git;branch=${BRANCH}" |
13 | 13 | ||
diff --git a/recipes-bsp/cmem/cmem_git.bb b/recipes-bsp/cmem/cmem_git.bb index b30029d6..bab9238f 100644 --- a/recipes-bsp/cmem/cmem_git.bb +++ b/recipes-bsp/cmem/cmem_git.bb | |||
@@ -4,7 +4,7 @@ include cmem.inc | |||
4 | 4 | ||
5 | RDEPENDS_${PN} = "cmem-mod" | 5 | RDEPENDS_${PN} = "cmem-mod" |
6 | 6 | ||
7 | PR = "r1" | 7 | PR = "r0" |
8 | 8 | ||
9 | PACKAGES =+ "${PN}-test" | 9 | PACKAGES =+ "${PN}-test" |
10 | 10 | ||